Message ID | 20240822133908.1042240-1-lizetao1@huawei.com (mailing list archive) |
---|---|
Headers | show |
Series | Some modifications to optimize code readability | expand |
Hello: This series was applied to netdev/net-next.git (main) by Jakub Kicinski <kuba@kernel.org>: On Thu, 22 Aug 2024 21:39:00 +0800 you wrote: > This patchset is mainly optimized for readability in contexts where size > needs to be determined. By using min() or max(), or even directly > removing redundant judgments (such as the 5th patch), the code is more > consistent with the context. > > Li Zetao (8): > atm: use min() to simplify the code > Bluetooth: use min() to simplify the code > net: caif: use max() to simplify the code > libceph: use min() to simplify the code > net: remove redundant judgments to simplify the code > ipv6: mcast: use min() to simplify the code > tipc: use min() to simplify the code > SUNRPC: use min() to simplify the code > > [...] Here is the summary with links: - [net-next,1/8] atm: use min() to simplify the code (no matching commit) - [net-next,2/8] Bluetooth: use min() to simplify the code (no matching commit) - [net-next,3/8] net: caif: use max() to simplify the code https://git.kernel.org/netdev/net-next/c/b4985aa8e312 - [net-next,4/8] libceph: use min() to simplify the code (no matching commit) - [net-next,5/8] net: remove redundant judgments to simplify the code (no matching commit) - [net-next,6/8] ipv6: mcast: use min() to simplify the code https://git.kernel.org/netdev/net-next/c/26549dab8a46 - [net-next,7/8] tipc: use min() to simplify the code https://git.kernel.org/netdev/net-next/c/a18308623ce3 - [net-next,8/8] SUNRPC: use min() to simplify the code (no matching commit) You are awesome, thank you!
Hello: This series was applied to bluetooth/bluetooth-next.git (master) by Jakub Kicinski <kuba@kernel.org>: On Thu, 22 Aug 2024 21:39:00 +0800 you wrote: > This patchset is mainly optimized for readability in contexts where size > needs to be determined. By using min() or max(), or even directly > removing redundant judgments (such as the 5th patch), the code is more > consistent with the context. > > Li Zetao (8): > atm: use min() to simplify the code > Bluetooth: use min() to simplify the code > net: caif: use max() to simplify the code > libceph: use min() to simplify the code > net: remove redundant judgments to simplify the code > ipv6: mcast: use min() to simplify the code > tipc: use min() to simplify the code > SUNRPC: use min() to simplify the code > > [...] Here is the summary with links: - [net-next,1/8] atm: use min() to simplify the code (no matching commit) - [net-next,2/8] Bluetooth: use min() to simplify the code (no matching commit) - [net-next,3/8] net: caif: use max() to simplify the code https://git.kernel.org/bluetooth/bluetooth-next/c/b4985aa8e312 - [net-next,4/8] libceph: use min() to simplify the code (no matching commit) - [net-next,5/8] net: remove redundant judgments to simplify the code (no matching commit) - [net-next,6/8] ipv6: mcast: use min() to simplify the code https://git.kernel.org/bluetooth/bluetooth-next/c/26549dab8a46 - [net-next,7/8] tipc: use min() to simplify the code https://git.kernel.org/bluetooth/bluetooth-next/c/a18308623ce3 - [net-next,8/8] SUNRPC: use min() to simplify the code (no matching commit) You are awesome, thank you!