mbox series

[0/4] libceph/ceph: cleanups and move more into ceph.ko

Message ID 20200701155446.41141-1-jlayton@kernel.org (mailing list archive)
Headers show
Series libceph/ceph: cleanups and move more into ceph.ko | expand

Message

Jeffrey Layton July 1, 2020, 3:54 p.m. UTC
This is just a small set of cleanups, with a final patch that moves a
chunk of cephfs-specific code out of libceph.ko and into ceph.ko. There
should be no functional changes here.

Jeff Layton (4):
  libceph: just have osd_req_op_init return a pointer
  libceph: refactor osdc request initialization
  libceph: rename __ceph_osdc_alloc_messages to ceph_osdc_alloc_num_messages
  libceph/ceph: move ceph_osdc_new_request into ceph.ko

 fs/ceph/Makefile                |   2 +-
 fs/ceph/addr.c                  |   1 +
 fs/ceph/file.c                  |   1 +
 fs/ceph/osdc.c                  | 113 +++++++++++++++++++
 fs/ceph/osdc.h                  |  16 +++
 include/linux/ceph/osd_client.h |  19 ++--
 net/ceph/osd_client.c           | 185 ++++++--------------------------
 7 files changed, 173 insertions(+), 164 deletions(-)
 create mode 100644 fs/ceph/osdc.c
 create mode 100644 fs/ceph/osdc.h