Message ID | 170319606771.2212653.5435838660860735129.stgit@djiang5-mobl3 |
---|---|
Headers | show |
Series | cxl: Add support for QTG ID retrieval for CXL subsystem | expand |
On Thu, Dec 21, 2023 at 03:02:25PM -0700, Dave Jiang wrote: > v15: > - Update the hmat generic targets via hmat_update_target_attrs() to retain the best > performance numbers from HMAT table. > - Refactor qos_class valid checks to simplify (Jonathan) One of these versions apparently rebased to v6.7-rc5. > v14: > - Fix 0day issue with fw_table usage (Dan) > - Move all DSMAS processing local to core/cdat.c (Dan) > - Change get_qos_class() to qos_class() (Dan) > - Fix perf entry allocation lifetime (Dan) > - Rename perf_prop_entry to cxl_dpa_perf (Dan) > - Cleanup gotos using DEFINE_FREE() (Dan) > - Move qos computation before regions arrive. (Dan) > - Drop unmatched perf list (Dan) > - Add target_lock locking for retrieving genport coordinates (Dan) > > v13: > - Convert temp dsmas list to xarray, optimize DSLBIS matching (Dan) > - Add a cxl_test fix for mock ACPI cxl host bridge UID. > > v12: > - Tested on hardware > - Rebased to v6.7-rc1 > ... > lib/firmware_table: tables: Add CDAT table parsing support > base/node / acpi: Change 'node_hmem_attrs' to 'access_coordinates' > acpi: numa: Create enum for memory_target access coordinates indexing > acpi: numa: Add genport target allocation to the HMAT parsing > acpi: Break out nesting for hmat_parse_locality() > acpi: numa: Add setting of generic port system locality attributes > acpi: numa: Add helper function to retrieve the performance attributes Drive-by comment since this series isn't for me, but "acpi:" and "acpi: numa:" are new prefix styles that don't match the drivers/acpi/ history. It looks nice in *this* series, but not quite as nice in the future drivers/acpi history. > cxl: Add callback to parse the DSMAS subtables from CDAT > cxl: Add callback to parse the DSLBIS subtable from CDAT > cxl: Add callback to parse the SSLBIS subtable from CDAT > cxl: Add support for _DSM Function for retrieving QTG ID > cxl: Calculate and store PCI link latency for the downstream ports > tools/testing/cxl: Add hostbridge UID string for cxl_test mock hb devices > cxl: Store the access coordinates for the generic ports > cxl: Add helper function that calculate performance data for downstream ports > cxl: Compute the entire CXL path latency and bandwidth data > cxl: Store QTG IDs and related info to the CXL memory device context > cxl: Export sysfs attributes for memory device QoS class > cxl: Check qos_class validity on memdev probe > > > Documentation/ABI/testing/sysfs-bus-cxl | 34 ++ > drivers/acpi/numa/hmat.c | 193 +++++++-- > drivers/acpi/tables.c | 5 +-
Bjorn Helgaas wrote: > On Thu, Dec 21, 2023 at 03:02:25PM -0700, Dave Jiang wrote: > > v15: > > - Update the hmat generic targets via hmat_update_target_attrs() to retain the best > > performance numbers from HMAT table. > > - Refactor qos_class valid checks to simplify (Jonathan) > > One of these versions apparently rebased to v6.7-rc5. > > > v14: > > - Fix 0day issue with fw_table usage (Dan) > > - Move all DSMAS processing local to core/cdat.c (Dan) > > - Change get_qos_class() to qos_class() (Dan) > > - Fix perf entry allocation lifetime (Dan) > > - Rename perf_prop_entry to cxl_dpa_perf (Dan) > > - Cleanup gotos using DEFINE_FREE() (Dan) > > - Move qos computation before regions arrive. (Dan) > > - Drop unmatched perf list (Dan) > > - Add target_lock locking for retrieving genport coordinates (Dan) > > > > v13: > > - Convert temp dsmas list to xarray, optimize DSLBIS matching (Dan) > > - Add a cxl_test fix for mock ACPI cxl host bridge UID. > > > > v12: > > - Tested on hardware > > - Rebased to v6.7-rc1 > > ... > > > lib/firmware_table: tables: Add CDAT table parsing support > > base/node / acpi: Change 'node_hmem_attrs' to 'access_coordinates' > > acpi: numa: Create enum for memory_target access coordinates indexing > > acpi: numa: Add genport target allocation to the HMAT parsing > > acpi: Break out nesting for hmat_parse_locality() > > acpi: numa: Add setting of generic port system locality attributes > > acpi: numa: Add helper function to retrieve the performance attributes > > Drive-by comment since this series isn't for me, but "acpi:" and > "acpi: numa:" are new prefix styles that don't match the drivers/acpi/ > history. It looks nice in *this* series, but not quite as nice in the > future drivers/acpi history. Missed this feedback over the holiday break. Will do better next time as I don't want to rebase to reset the age of commits this close to the merge window.