Message ID | 20250107141015.3367194-2-rrichter@amd.com |
---|---|
State | New |
Headers | show |
Series | cxl: Add address translation support and enable AMD Zen5 platforms | expand |
On Tue, Jan 07, 2025 at 03:09:47PM +0100, Robert Richter wrote: > Remove unnecessary 'else' after return. Improves readability of code. > It is easier to place comments. Check and fix all occurrences under > drivers/cxl/. > > Signed-off-by: Robert Richter <rrichter@amd.com> > --- > drivers/cxl/core/cdat.c | 2 +- > drivers/cxl/core/pci.c | 3 ++- > drivers/cxl/core/region.c | 4 +++- > 3 files changed, 6 insertions(+), 3 deletions(-) > Reviewed-by: Gregory Price <gourry@gourry.net>
On 1/7/25 7:09 AM, Robert Richter wrote: > Remove unnecessary 'else' after return. Improves readability of code. > It is easier to place comments. Check and fix all occurrences under > drivers/cxl/. > > Signed-off-by: Robert Richter <rrichter@amd.com> Just send this ahead of the series to reduce this series size. It's trivial enough I can probably take it for 5.13 merge window. Reviewed-by: Dave Jiang <dave.jiang@intel.com> > --- > drivers/cxl/core/cdat.c | 2 +- > drivers/cxl/core/pci.c | 3 ++- > drivers/cxl/core/region.c | 4 +++- > 3 files changed, 6 insertions(+), 3 deletions(-) > > diff --git a/drivers/cxl/core/cdat.c b/drivers/cxl/core/cdat.c > index 8153f8d83a16..2e69d9f27028 100644 > --- a/drivers/cxl/core/cdat.c > +++ b/drivers/cxl/core/cdat.c > @@ -28,7 +28,7 @@ static u32 cdat_normalize(u16 entry, u64 base, u8 type) > */ > if (entry == 0xffff || !entry) > return 0; > - else if (base > (UINT_MAX / (entry))) > + if (base > (UINT_MAX / (entry))) > return 0; > > /* > diff --git a/drivers/cxl/core/pci.c b/drivers/cxl/core/pci.c > index b3aac9964e0d..3e8d20f8955c 100644 > --- a/drivers/cxl/core/pci.c > +++ b/drivers/cxl/core/pci.c > @@ -415,7 +415,8 @@ int cxl_hdm_decode_init(struct cxl_dev_state *cxlds, struct cxl_hdm *cxlhdm, > */ > if (global_ctrl & CXL_HDM_DECODER_ENABLE || (!hdm && info->mem_enabled)) > return devm_cxl_enable_mem(&port->dev, cxlds); > - else if (!hdm) > + > + if (!hdm) > return -ENODEV; > > root = to_cxl_port(port->dev.parent); > diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c > index b98b1ccffd1c..9b3efa841c8f 100644 > --- a/drivers/cxl/core/region.c > +++ b/drivers/cxl/core/region.c > @@ -1915,7 +1915,9 @@ static int cxl_region_attach(struct cxl_region *cxlr, > if (p->state > CXL_CONFIG_INTERLEAVE_ACTIVE) { > dev_dbg(&cxlr->dev, "region already active\n"); > return -EBUSY; > - } else if (p->state < CXL_CONFIG_INTERLEAVE_ACTIVE) { > + } > + > + if (p->state < CXL_CONFIG_INTERLEAVE_ACTIVE) { > dev_dbg(&cxlr->dev, "interleave config missing\n"); > return -ENXIO; > }
On 07.01.25 09:37:43, Dave Jiang wrote: > > > On 1/7/25 7:09 AM, Robert Richter wrote: > > Remove unnecessary 'else' after return. Improves readability of code. > > It is easier to place comments. Check and fix all occurrences under > > drivers/cxl/. > > > > Signed-off-by: Robert Richter <rrichter@amd.com> > > Just send this ahead of the series to reduce this series size. It's trivial enough I can probably take it for 5.13 merge window. > > Reviewed-by: Dave Jiang <dave.jiang@intel.com> I realized patches #1 to #4 are independent of the rest of the series so removing it from the series and sending it separately. Thanks for review, -Robert
diff --git a/drivers/cxl/core/cdat.c b/drivers/cxl/core/cdat.c index 8153f8d83a16..2e69d9f27028 100644 --- a/drivers/cxl/core/cdat.c +++ b/drivers/cxl/core/cdat.c @@ -28,7 +28,7 @@ static u32 cdat_normalize(u16 entry, u64 base, u8 type) */ if (entry == 0xffff || !entry) return 0; - else if (base > (UINT_MAX / (entry))) + if (base > (UINT_MAX / (entry))) return 0; /* diff --git a/drivers/cxl/core/pci.c b/drivers/cxl/core/pci.c index b3aac9964e0d..3e8d20f8955c 100644 --- a/drivers/cxl/core/pci.c +++ b/drivers/cxl/core/pci.c @@ -415,7 +415,8 @@ int cxl_hdm_decode_init(struct cxl_dev_state *cxlds, struct cxl_hdm *cxlhdm, */ if (global_ctrl & CXL_HDM_DECODER_ENABLE || (!hdm && info->mem_enabled)) return devm_cxl_enable_mem(&port->dev, cxlds); - else if (!hdm) + + if (!hdm) return -ENODEV; root = to_cxl_port(port->dev.parent); diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c index b98b1ccffd1c..9b3efa841c8f 100644 --- a/drivers/cxl/core/region.c +++ b/drivers/cxl/core/region.c @@ -1915,7 +1915,9 @@ static int cxl_region_attach(struct cxl_region *cxlr, if (p->state > CXL_CONFIG_INTERLEAVE_ACTIVE) { dev_dbg(&cxlr->dev, "region already active\n"); return -EBUSY; - } else if (p->state < CXL_CONFIG_INTERLEAVE_ACTIVE) { + } + + if (p->state < CXL_CONFIG_INTERLEAVE_ACTIVE) { dev_dbg(&cxlr->dev, "interleave config missing\n"); return -ENXIO; }
Remove unnecessary 'else' after return. Improves readability of code. It is easier to place comments. Check and fix all occurrences under drivers/cxl/. Signed-off-by: Robert Richter <rrichter@amd.com> --- drivers/cxl/core/cdat.c | 2 +- drivers/cxl/core/pci.c | 3 ++- drivers/cxl/core/region.c | 4 +++- 3 files changed, 6 insertions(+), 3 deletions(-)