Show patches with: State = Action Required       |    Archived = No       |   141 patches
« 1 2 »
Patch Series A/R/T S/W/F Date Submitter Delegate State
dm: add module parameter bdev_wait dm: add module parameter bdev_wait - - - --- 2021-10-22 Mark-PK Tsai New
dm: log table creation error code dm: log table creation error code - - - --- 2021-10-21 Michał Mirosław New
dm: make workqueue names device-specific dm: make workqueue names device-specific - - - --- 2021-10-21 Michał Mirosław New
[3/3] dm: don't stop request queue after the dm device is suspended block: keep quiesce & unquiesce balanced for scsi/dm - - - --- 2021-10-21 Ming Lei New
[2/3] scsi: make sure that request queue queiesce and unquiesce balanced block: keep quiesce & unquiesce balanced for scsi/dm - - - --- 2021-10-21 Ming Lei New
[1/3] scsi: avoid to quiesce sdev->request_queue two times block: keep quiesce & unquiesce balanced for scsi/dm - - - --- 2021-10-21 Ming Lei New
dm writecache: Make use of the helper macro kthread_run() dm writecache: Make use of the helper macro kthread_run() - - - --- 2021-10-21 Cai,Huoqing New
dm crypt: Make use of the helper macro kthread_run() dm crypt: Make use of the helper macro kthread_run() - - - --- 2021-10-21 Cai,Huoqing New
[6/6] dm: Ensure dm honors DAXDEV_F_RECOVERY flag on dax only dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[5/6] dax, pmem: Add data recovery feature to pmem_copy_to/from_iter() dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[4/6] dm, dax, pmem: prepare dax_copy_to/from_iter() APIs with DAXDEV_F_RECOVERY dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[3/6] pmem: pmem_dax_direct_access() to honor the DAXDEV_F_RECOVERY flag dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[2/6] dax: prepare dax_direct_access() API with DAXDEV_F_RECOVERY flag dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[1/6] dax: introduce RWF_RECOVERY_DATA flag to preadv2() and pwritev2() dax poison recovery with RWF_RECOVERY_DATA flag - - - --- 2021-10-21 Jane Chu New
[7/7] multipathd: Remove dependency on systemd-udev-settle.service multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[6/7] multipathd: remove INIT_PARTIAL paths that aren't in a multipath device multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[5/7] multipathd: fully initialize paths added by update_pathvec_from_dm multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[4/7] libmultipath: always set INIT_REMOVED in set_path_removed multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[3/7] libmultipath: don't use fallback wwid in update_pathvec_from_dm multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[2/7] libmultipath: skip unneeded steps to get path name multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
[1/7] multipathd: remove missing paths on startup multipathd: remove udev settle dependency - - - --- 2021-10-20 Benjamin Marzinski New
audit: correct the AUDIT_DM_CTRL and AUDIT_DM_EVENT numbering audit: correct the AUDIT_DM_CTRL and AUDIT_DM_EVENT numbering - - - --- 2021-10-20 Paul Moore New
[4/4] dm-verity: use bvec_kmap_local in verity_for_bv_block [1/4] dm-integrity: use bvec_kmap_local in integrity_metadata - - - --- 2021-10-19 Christoph Hellwig New
[3/4] dm-log-writes: use memcpy_from_bvec in log_writes_map [1/4] dm-integrity: use bvec_kmap_local in integrity_metadata - - - --- 2021-10-19 Christoph Hellwig New
[2/4] dm-integrity: use bvec_kmap_local in __journal_read_write [1/4] dm-integrity: use bvec_kmap_local in integrity_metadata - - - --- 2021-10-19 Christoph Hellwig New
[1/4] dm-integrity: use bvec_kmap_local in integrity_metadata [1/4] dm-integrity: use bvec_kmap_local in integrity_metadata - - - --- 2021-10-19 Christoph Hellwig New
[v6,4/4] blk-crypto: update inline encryption documentation blk-crypto cleanups - 2 - --- 2021-10-18 Eric Biggers New
[v6,3/4] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile blk-crypto cleanups 1 2 - --- 2021-10-18 Eric Biggers New
[v6,2/4] blk-crypto: rename keyslot-manager files to blk-crypto-profile blk-crypto cleanups 1 3 - --- 2021-10-18 Eric Biggers New
[v6,1/4] blk-crypto-fallback: properly prefix function and struct names blk-crypto cleanups - 4 - --- 2021-10-18 Eric Biggers New
[30/30] udf: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[29/30] reiserfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[28/30] ntfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[27/30] jfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[26/30] ext4: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 3 - --- 2021-10-18 Christoph Hellwig New
[25/30] block: add a sb_bdev_nr_blocks helper [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[24/30] block: use bdev_nr_bytes instead of open coding it in blkdev_fallocate [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-18 Christoph Hellwig New
[23/30] squashfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[22/30] reiserfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-18 Christoph Hellwig New
[21/30] pstore/blk: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 - - --- 2021-10-18 Christoph Hellwig New
[20/30] ntfs3: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - - - --- 2021-10-18 Christoph Hellwig New
[19/30] nilfs2: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[18/30] nfs/blocklayout: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[17/30] jfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[16/30] hfsplus: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[15/30] hfs: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[14/30] fat: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[13/30] cramfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[12/30] btrfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 3 - --- 2021-10-18 Christoph Hellwig New
[11/30] affs: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[10/30] fs: simplify init_page_buffers [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[09/30] fs: use bdev_nr_bytes instead of open coding it in blkdev_max_block [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-18 Christoph Hellwig New
[08/30] target/iblock: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[07/30] nvmet: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-18 Christoph Hellwig New
[06/30] md: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[05/30] dm: use bdev_nr_sectors and bdev_nr_bytes instead of open coding them [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-18 Christoph Hellwig New
[04/30] drbd: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-18 Christoph Hellwig New
[03/30] bcache: remove bdev_sectors [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 2 - --- 2021-10-18 Christoph Hellwig New
[02/30] block: add a bdev_nr_bytes helper [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-18 Christoph Hellwig New
[01/30] block: move the SECTOR_SIZE related definitions to blk_types.h [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-18 Christoph Hellwig New
[11/11] dax: move bdev_dax_pgoff to fs/dax.c [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[10/11] dm-stripe: add a stripe_dax_pgoff helper [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[09/11] dm-log-writes: add a log_writes_dax_pgoff helper [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[08/11] dm-linear: add a linear_dax_pgoff helper [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[07/11] dax: remove dax_capable [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - 2 - --- 2021-10-18 Christoph Hellwig New
[06/11] xfs: factor out a xfs_setup_dax helper [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - 1 - --- 2021-10-18 Christoph Hellwig New
[05/11] dax: move the partition alignment check into fs_dax_get_by_bdev [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[04/11] dax: remove the pgmap sanity checks in generic_fsdax_supported [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[03/11] dax: simplify the dax_device <-> gendisk association [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[02/11] dax: remove CONFIG_DAX_DRIVER [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[01/11] dm: make the DAX support dependend on CONFIG_FS_DAX [01/11] dm: make the DAX support dependend on CONFIG_FS_DAX - - - --- 2021-10-18 Christoph Hellwig New
[9/9] mtd: add add_disk() error handling block: reviewed add_disk() error handling set 1 - - --- 2021-10-15 Luis Chamberlain New
[8/9] rnbd: add error handling support for add_disk() block: reviewed add_disk() error handling set 1 - - --- 2021-10-15 Luis Chamberlain New
[7/9] um/drivers/ubd_kern: add error handling support for add_disk() block: reviewed add_disk() error handling set - 1 - --- 2021-10-15 Luis Chamberlain New
[6/9] m68k/emu/nfblock: add error handling support for add_disk() block: reviewed add_disk() error handling set 1 1 - --- 2021-10-15 Luis Chamberlain New
[5/9] xen-blkfront: add error handling support for add_disk() block: reviewed add_disk() error handling set - 1 - --- 2021-10-15 Luis Chamberlain New
[4/9] bcache: add error handling support for add_disk() block: reviewed add_disk() error handling set 1 - - --- 2021-10-15 Luis Chamberlain New
[3/9] dm: add add_disk() error handling block: reviewed add_disk() error handling set - 1 - --- 2021-10-15 Luis Chamberlain New
[2/9] scsi/sr: add error handling support for add_disk() block: reviewed add_disk() error handling set 1 1 - --- 2021-10-15 Luis Chamberlain New
[1/9] scsi/sd: add error handling support for add_disk() block: reviewed add_disk() error handling set 1 1 - --- 2021-10-15 Luis Chamberlain New
[git,pull] device mapper fixes for 5.15-rc6 [git,pull] device mapper fixes for 5.15-rc6 - - - --- 2021-10-15 Mike Snitzer New
[30/30] udf: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-15 Christoph Hellwig New
[29/30] reiserfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-15 Christoph Hellwig New
[28/30] ntfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-15 Christoph Hellwig New
[27/30] jfs: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-15 Christoph Hellwig New
[26/30] ext4: use sb_bdev_nr_blocks [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 3 - --- 2021-10-15 Christoph Hellwig New
[25/30] block: add a sb_bdev_nr_blocks helper [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 2 - --- 2021-10-15 Christoph Hellwig New
[24/30] block: use bdev_nr_bytes instead of open coding it in blkdev_fallocate [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-15 Christoph Hellwig New
[23/30] squashfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-15 Christoph Hellwig New
[22/30] reiserfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 3 - --- 2021-10-15 Christoph Hellwig New
[21/30] pstore/blk: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 - - --- 2021-10-15 Christoph Hellwig New
[20/30] ntfs3: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[19/30] nilfs2: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-15 Christoph Hellwig New
[18/30] nfs/blocklayout: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[17/30] jfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 1 - --- 2021-10-15 Christoph Hellwig New
[16/30] hfsplus: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[15/30] hfs: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[14/30] fat: use bdev_nr_sectors instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[13/30] cramfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h - 1 - --- 2021-10-15 Christoph Hellwig New
[12/30] btrfs: use bdev_nr_bytes instead of open coding it [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h 1 3 - --- 2021-10-15 Christoph Hellwig New
« 1 2 »