mbox series

[RFC,0/6] Rename functions to match their entry points

Message ID 20190710123631.26575-1-janusz.krzysztofik@linux.intel.com (mailing list archive)
Headers show
Series Rename functions to match their entry points | expand

Message

Janusz Krzysztofik July 10, 2019, 12:36 p.m. UTC
Need for this was identified while working on split of driver unbind
path into _remove() and _release() parts.  Consistency in function
naming has been recognized as helpful when trying to work out which
phase the code is in.

What I'm still not sure about is desired depth of that modification -
how deep should we go down with renaming to not override meaningfull
function names.  Please advise if you think still more deep renaming
makes sense.

Thanks,
Janusz

Janusz Krzysztofik (6):
  drm/i915: Rename "_load"/"_unload" to match PCI entry points
  drm/i915: Replace "_load" with "_probe" consequently
  drm/i915: Propagate "_release" function name suffix down
  drm/i915: Propagate "_remove" function name suffix down
  drm/i915: Propagate "_probe" function name suffix down
  drm/i915: Rename "inject_load_failure" module parameter

 drivers/gpu/drm/i915/display/intel_bios.c     |   4 +-
 drivers/gpu/drm/i915/display/intel_bios.h     |   2 +-
 .../gpu/drm/i915/display/intel_connector.c    |   2 +-
 drivers/gpu/drm/i915/display/intel_display.c  |   2 +-
 .../drm/i915/display/intel_display_power.c    |   6 +-
 .../drm/i915/display/intel_display_power.h    |   2 +-
 drivers/gpu/drm/i915/gt/intel_engine_cs.c     |   2 +-
 drivers/gpu/drm/i915/i915_drv.c               | 111 +++++++++---------
 drivers/gpu/drm/i915/i915_drv.h               |  20 ++--
 drivers/gpu/drm/i915/i915_gem.c               |  12 +-
 drivers/gpu/drm/i915/i915_gem_gtt.c           |   4 +-
 drivers/gpu/drm/i915/i915_gem_gtt.h           |   2 +-
 drivers/gpu/drm/i915/i915_params.c            |   2 +-
 drivers/gpu/drm/i915/i915_params.h            |   2 +-
 drivers/gpu/drm/i915/i915_pci.c               |   6 +-
 drivers/gpu/drm/i915/intel_gvt.c              |   7 +-
 drivers/gpu/drm/i915/intel_gvt.h              |   4 +-
 drivers/gpu/drm/i915/intel_runtime_pm.c       |   2 +-
 drivers/gpu/drm/i915/intel_runtime_pm.h       |   2 +-
 drivers/gpu/drm/i915/intel_uncore.c           |   2 +-
 drivers/gpu/drm/i915/intel_wopcm.c            |   2 +-
 21 files changed, 100 insertions(+), 98 deletions(-)

Comments

Chris Wilson July 10, 2019, 12:47 p.m. UTC | #1
Quoting Janusz Krzysztofik (2019-07-10 13:36:25)
> Need for this was identified while working on split of driver unbind
> path into _remove() and _release() parts.  Consistency in function
> naming has been recognized as helpful when trying to work out which
> phase the code is in.
> 
> What I'm still not sure about is desired depth of that modification -
> how deep should we go down with renaming to not override meaningfull
> function names.  Please advise if you think still more deep renaming
> makes sense.

I did a double take over "driver_release" but by the end I was in
agreement.

The early_release though, that is worth a bit of artistic license to say
early_probe pairs with late_release.
-Chris
Janusz Krzysztofik July 10, 2019, 12:54 p.m. UTC | #2
On Wednesday, July 10, 2019 2:47:08 PM CEST Chris Wilson wrote:
> Quoting Janusz Krzysztofik (2019-07-10 13:36:25)
> > Need for this was identified while working on split of driver unbind
> > path into _remove() and _release() parts.  Consistency in function
> > naming has been recognized as helpful when trying to work out which
> > phase the code is in.
> > 
> > What I'm still not sure about is desired depth of that modification -
> > how deep should we go down with renaming to not override meaningfull
> > function names.  Please advise if you think still more deep renaming
> > makes sense.
> 
> I did a double take over "driver_release" but by the end I was in
> agreement.
> 
> The early_release though, that is worth a bit of artistic license to say
> early_probe pairs with late_release.

OK, I'll fix it, as well as other issues pointed out by dim, and resubmit.

Thanks,
Janusz

> -Chris
>