mbox series

[v2,0/7] drm/vc4: hvs: Various improvements

Message ID 20220331143744.777652-1-maxime@cerno.tech (mailing list archive)
Headers show
Series drm/vc4: hvs: Various improvements | expand

Message

Maxime Ripard March 31, 2022, 2:37 p.m. UTC
Hi,

These patches used to be part of the series:
https://lore.kernel.org/all/20220221134155.125447-1-maxime@cerno.tech/

but since the main patch got superseded by another core patch, I've split the
cleanup patches out into their own series.

Let me know what you think,
Maxime

Changes from v1:
  - Used DRM_PLANE_COMMIT_ACTIVE_ONLY to skip atomic_flush

Maxime Ripard (7):
  drm/vc4: kms: Take old state core clock rate into account
  drm/vc4: hvs: Fix frame count register readout
  drm/vc4: hvs: Store channel in variable
  drm/vc4: hvs: Remove dlist setup duplication
  drm/vc4: hvs: Move the dlist setup to its own function
  drm/vc4: kms: Ignore atomic_flush if we're disabled
  drm/vc4: hvs: Use pointer to HVS in HVS_READ and HVS_WRITE macros

 drivers/gpu/drm/vc4/vc4_crtc.c |  14 ++--
 drivers/gpu/drm/vc4/vc4_drv.h  |  15 ++--
 drivers/gpu/drm/vc4/vc4_hvs.c  | 127 ++++++++++++++++++++-------------
 drivers/gpu/drm/vc4/vc4_kms.c  |  13 ++--
 drivers/gpu/drm/vc4/vc4_regs.h |  12 +++-
 5 files changed, 115 insertions(+), 66 deletions(-)

Comments

Thomas Zimmermann April 6, 2022, 10:44 a.m. UTC | #1
Hi Maxime,

for the whole patchset

Acked-by: Thomas Zimmermann <tzimmermann@suse.de>

Best regards
Thomas

Am 31.03.22 um 16:37 schrieb Maxime Ripard:
> Hi,
> 
> These patches used to be part of the series:
> https://lore.kernel.org/all/20220221134155.125447-1-maxime@cerno.tech/
> 
> but since the main patch got superseded by another core patch, I've split the
> cleanup patches out into their own series.
> 
> Let me know what you think,
> Maxime
> 
> Changes from v1:
>    - Used DRM_PLANE_COMMIT_ACTIVE_ONLY to skip atomic_flush
> 
> Maxime Ripard (7):
>    drm/vc4: kms: Take old state core clock rate into account
>    drm/vc4: hvs: Fix frame count register readout
>    drm/vc4: hvs: Store channel in variable
>    drm/vc4: hvs: Remove dlist setup duplication
>    drm/vc4: hvs: Move the dlist setup to its own function
>    drm/vc4: kms: Ignore atomic_flush if we're disabled
>    drm/vc4: hvs: Use pointer to HVS in HVS_READ and HVS_WRITE macros
> 
>   drivers/gpu/drm/vc4/vc4_crtc.c |  14 ++--
>   drivers/gpu/drm/vc4/vc4_drv.h  |  15 ++--
>   drivers/gpu/drm/vc4/vc4_hvs.c  | 127 ++++++++++++++++++++-------------
>   drivers/gpu/drm/vc4/vc4_kms.c  |  13 ++--
>   drivers/gpu/drm/vc4/vc4_regs.h |  12 +++-
>   5 files changed, 115 insertions(+), 66 deletions(-)
>
Maxime Ripard April 6, 2022, 1:26 p.m. UTC | #2
On Thu, 31 Mar 2022 16:37:37 +0200, Maxime Ripard wrote:
> These patches used to be part of the series:
> https://lore.kernel.org/all/20220221134155.125447-1-maxime@cerno.tech/
> 
> but since the main patch got superseded by another core patch, I've split the
> cleanup patches out into their own series.
> 
> Let me know what you think,
> Maxime
> 
> [...]

Applied to drm/drm-misc (drm-misc-next).

Thanks!
Maxime