diff mbox

[3/3] drm: Fix drm_rect documentation

Message ID 1368020315-4820-4-git-send-email-ville.syrjala@linux.intel.com (mailing list archive)
State New, archived
Headers show

Commit Message

Ville Syrjala May 8, 2013, 1:38 p.m. UTC
From: Ville Syrjälä <ville.syrjala@linux.intel.com>

The 'struct' keyword was missing so struct drm_rect documentation never
ended up in the generated docs.

Also reorder drm_rect.h to become before drm_rect.c so that the struct
documentation appears first in the docs. And change it to use the 'I'
directive instead of 'F' while we're at it.

Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
 Documentation/DocBook/drm.tmpl | 2 +-
 include/drm/drm_rect.h         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Daniel Vetter May 8, 2013, 1:55 p.m. UTC | #1
On Wed, May 08, 2013 at 04:38:35PM +0300, ville.syrjala@linux.intel.com wrote:
> From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> 
> The 'struct' keyword was missing so struct drm_rect documentation never
> ended up in the generated docs.
> 
> Also reorder drm_rect.h to become before drm_rect.c so that the struct
> documentation appears first in the docs. And change it to use the 'I'
> directive instead of 'F' while we're at it.
> 
> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> ---
>  Documentation/DocBook/drm.tmpl | 2 +-
>  include/drm/drm_rect.h         | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index 7c7af25..89b6faa 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -1653,8 +1653,8 @@ void intel_crt_init(struct drm_device *dev)
>      <sect2>
>        <title>KMS API Functions</title>
>  !Edrivers/gpu/drm/drm_crtc.c
> +!Iinclude/drm/drm_rect.h
>  !Edrivers/gpu/drm/drm_rect.c
> -!Finclude/drm/drm_rect.h

Shameless bikeshed while at it: Can you move the drm_rect stuff to it's
own sections, like all the other kms helper stuff? Only the things in
drm_crtc.c are really core kms apis.
-Daniel

>      </sect2>
>    </sect1>
>  
> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
> index 64fa265..9a98321 100644
> --- a/include/drm/drm_rect.h
> +++ b/include/drm/drm_rect.h
> @@ -25,7 +25,7 @@
>  #define DRM_RECT_H
>  
>  /**
> - * drm_rect - two dimensional rectangle
> + * struct drm_rect - two dimensional rectangle
>   * @x1: horizontal starting coordinate (inclusive)
>   * @x2: horizontal ending coordinate (exclusive)
>   * @y1: vertical starting coordinate (inclusive)
> -- 
> 1.8.1.5
> 
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx
diff mbox

Patch

diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
index 7c7af25..89b6faa 100644
--- a/Documentation/DocBook/drm.tmpl
+++ b/Documentation/DocBook/drm.tmpl
@@ -1653,8 +1653,8 @@  void intel_crt_init(struct drm_device *dev)
     <sect2>
       <title>KMS API Functions</title>
 !Edrivers/gpu/drm/drm_crtc.c
+!Iinclude/drm/drm_rect.h
 !Edrivers/gpu/drm/drm_rect.c
-!Finclude/drm/drm_rect.h
     </sect2>
   </sect1>
 
diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
index 64fa265..9a98321 100644
--- a/include/drm/drm_rect.h
+++ b/include/drm/drm_rect.h
@@ -25,7 +25,7 @@ 
 #define DRM_RECT_H
 
 /**
- * drm_rect - two dimensional rectangle
+ * struct drm_rect - two dimensional rectangle
  * @x1: horizontal starting coordinate (inclusive)
  * @x2: horizontal ending coordinate (exclusive)
  * @y1: vertical starting coordinate (inclusive)