diff mbox

[RFC,5/5] drm: Do not log driver prefix in debug messages

Message ID 1481050681-23416-6-git-send-email-tvrtko.ursulin@linux.intel.com (mailing list archive)
State New, archived
Headers show

Commit Message

Tvrtko Ursulin Dec. 6, 2016, 6:58 p.m. UTC
From: Tvrtko Ursulin <tvrtko.ursulin@intel.com>

Driver prefix is a bit redundant in debug messages. If we choose
not to log it we change debug messages which used to look like this:

 [i915:edp_panel_off [i915]] Wait for panel power off time

to this:

 [edp_panel_off [i915]] Wait for panel power off time

Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
---
 drivers/gpu/drm/drm_drv.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Tvrtko Ursulin Dec. 7, 2016, 6:52 a.m. UTC | #1
Hi,

On 06/12/2016 19:49, Gustavo Padovan wrote:
> Hi Tvrtko,
>
> 2016-12-06 Tvrtko Ursulin <tursulin@ursulin.net>:
>
>> From: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
>>
>> Driver prefix is a bit redundant in debug messages. If we choose
>> not to log it we change debug messages which used to look like this:
>>
>>  [i915:edp_panel_off [i915]] Wait for panel power off time
>>
>> to this:
>>
>>  [edp_panel_off [i915]] Wait for panel power off time
>
> Why not remove the second mention to the driver's name instead.
>
> [i915:edp_panel_off] looks more logic to me.

Would possibly be more readable yes, but the whole string comes from %ps 
AFAICS so I don't think we could split it.

Regards,

Tvrtko
diff mbox

Patch

diff --git a/drivers/gpu/drm/drm_drv.c b/drivers/gpu/drm/drm_drv.c
index bda4639c73e4..498beaf8ee8b 100644
--- a/drivers/gpu/drm/drm_drv.c
+++ b/drivers/gpu/drm/drm_drv.c
@@ -118,8 +118,8 @@  void drm_printk(const char *level, unsigned int category,
 		       level, driver,
 		       strcmp(level, KERN_ERR) == 0 ? " *ERROR*" : "", &vaf);
 	else
-		printk("%s[%s:%ps] %pV",
-		       level, driver, __builtin_return_address(0), &vaf);
+		printk("%s[%ps] %pV",
+		       level, __builtin_return_address(0), &vaf);
 
 	va_end(args);
 }