diff mbox

drm/omap: fix tiled buffer stride calculations

Message ID 1495103306-7041-1-git-send-email-tomi.valkeinen@ti.com (mailing list archive)
State New, archived
Headers show

Commit Message

Tomi Valkeinen May 18, 2017, 10:28 a.m. UTC
omap_gem uses page alignment for buffer stride. The related calculations
are a bit off, though, as byte stride of 4096 gets aligned to 8192,
instead of 4096. This patch fixes those calculations.

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
---
 drivers/gpu/drm/omapdrm/omap_gem.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Laurent Pinchart May 18, 2017, 10:59 a.m. UTC | #1
Hi Tomi,

Thank you for the patch.

On Thursday 18 May 2017 13:28:26 Tomi Valkeinen wrote:
> omap_gem uses page alignment for buffer stride. The related calculations
> are a bit off, though, as byte stride of 4096 gets aligned to 8192,
> instead of 4096. This patch fixes those calculations.
> 
> Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
> ---
>  drivers/gpu/drm/omapdrm/omap_gem.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c
> b/drivers/gpu/drm/omapdrm/omap_gem.c index 13abf221d153..4c41000ff4c4
> 100644
> --- a/drivers/gpu/drm/omapdrm/omap_gem.c
> +++ b/drivers/gpu/drm/omapdrm/omap_gem.c
> @@ -182,7 +182,7 @@ static void evict_entry(struct drm_gem_object *obj,
>  	size_t size = PAGE_SIZE * n;
>  	loff_t off = mmap_offset(obj) +
>  			(entry->obj_pgoff << PAGE_SHIFT);
> -	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
> +	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);

How about 

	int m = round_up(omap_obj->width << fmt, PAGE_SIZE);

instead of open-coding it ? I find that a bit easier to understand.

By the way, shifting left by fmt should be fine for TILFMT_8BIT, TILFMT_16BIT 
and TILFMT_32BIT that evaluate to 0, 1 and 2 respectively, but how does it 
work with TILFMT_PAGE ? fmt is computed by gem2fmt() in call cases, which 
returns TILFMT_PAGE in the default case (no tiled flag set). Can this happen 
in practice ?

> 
>  	if (m > 1) {
>  		int i;
> @@ -424,7 +424,7 @@ static int fault_2d(struct drm_gem_object *obj,
>  	 * into account in some of the math, so figure out virtual stride
>  	 * in pages
>  	 */
> -	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
> +	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
> 
>  	/* We don't use vmf->pgoff since that has the fake offset: */
>  	pgoff = (vmf->address - vma->vm_start) >> PAGE_SHIFT;
Tomi Valkeinen May 18, 2017, 11:14 a.m. UTC | #2
On 18/05/17 13:59, Laurent Pinchart wrote:
> Hi Tomi,
> 
> Thank you for the patch.
> 
> On Thursday 18 May 2017 13:28:26 Tomi Valkeinen wrote:
>> omap_gem uses page alignment for buffer stride. The related calculations
>> are a bit off, though, as byte stride of 4096 gets aligned to 8192,
>> instead of 4096. This patch fixes those calculations.
>>
>> Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
>> ---
>>  drivers/gpu/drm/omapdrm/omap_gem.c | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c
>> b/drivers/gpu/drm/omapdrm/omap_gem.c index 13abf221d153..4c41000ff4c4
>> 100644
>> --- a/drivers/gpu/drm/omapdrm/omap_gem.c
>> +++ b/drivers/gpu/drm/omapdrm/omap_gem.c
>> @@ -182,7 +182,7 @@ static void evict_entry(struct drm_gem_object *obj,
>>  	size_t size = PAGE_SIZE * n;
>>  	loff_t off = mmap_offset(obj) +
>>  			(entry->obj_pgoff << PAGE_SHIFT);
>> -	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
>> +	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
> 
> How about 
> 
> 	int m = round_up(omap_obj->width << fmt, PAGE_SIZE);
> 
> instead of open-coding it ? I find that a bit easier to understand.

That should be:

round_up(omap_obj->width << fmt, PAGE_SIZE) / PAGE_SIZE;

Yes, I think that's more understandable.

> By the way, shifting left by fmt should be fine for TILFMT_8BIT, TILFMT_16BIT 
> and TILFMT_32BIT that evaluate to 0, 1 and 2 respectively, but how does it 
> work with TILFMT_PAGE ? fmt is computed by gem2fmt() in call cases, which 
> returns TILFMT_PAGE in the default case (no tiled flag set). Can this happen 
> in practice ?

These functions are only called for 2D buffers. I do find shifting by
'enum tiler_fmt' quite ugly, though...

 Tomi
Laurent Pinchart May 18, 2017, 11:25 a.m. UTC | #3
Hi Tomi,

On Thursday 18 May 2017 14:14:35 Tomi Valkeinen wrote:
> On 18/05/17 13:59, Laurent Pinchart wrote:
> > On Thursday 18 May 2017 13:28:26 Tomi Valkeinen wrote:
> >> omap_gem uses page alignment for buffer stride. The related calculations
> >> are a bit off, though, as byte stride of 4096 gets aligned to 8192,
> >> instead of 4096. This patch fixes those calculations.
> >> 
> >> Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
> >> ---
> >> 
> >>  drivers/gpu/drm/omapdrm/omap_gem.c | 4 ++--
> >>  1 file changed, 2 insertions(+), 2 deletions(-)
> >> 
> >> diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c
> >> b/drivers/gpu/drm/omapdrm/omap_gem.c index 13abf221d153..4c41000ff4c4
> >> 100644
> >> --- a/drivers/gpu/drm/omapdrm/omap_gem.c
> >> +++ b/drivers/gpu/drm/omapdrm/omap_gem.c
> >> @@ -182,7 +182,7 @@ static void evict_entry(struct drm_gem_object *obj,
> >>  	size_t size = PAGE_SIZE * n;
> >>  	loff_t off = mmap_offset(obj) +
> >>  			(entry->obj_pgoff << PAGE_SHIFT);
> >> -	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
> >> +	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
> > 
> > How about
> > 
> > 	int m = round_up(omap_obj->width << fmt, PAGE_SIZE);
> > 
> > instead of open-coding it ? I find that a bit easier to understand.
> 
> That should be:
> 
> round_up(omap_obj->width << fmt, PAGE_SIZE) / PAGE_SIZE;

Sorry, I meant DIV_ROUND_UP, not round_up.

> Yes, I think that's more understandable.
>
> > By the way, shifting left by fmt should be fine for TILFMT_8BIT,
> > TILFMT_16BIT and TILFMT_32BIT that evaluate to 0, 1 and 2 respectively,
> > but how does it work with TILFMT_PAGE ? fmt is computed by gem2fmt() in
> > call cases, which returns TILFMT_PAGE in the default case (no tiled flag
> > set). Can this happen in practice ?
> 
> These functions are only called for 2D buffers. I do find shifting by
> 'enum tiler_fmt' quite ugly, though...

So do I. This should be added to the infinite todo list :-)
Ville Syrjälä May 18, 2017, 11:32 a.m. UTC | #4
On Thu, May 18, 2017 at 02:14:35PM +0300, Tomi Valkeinen wrote:
> On 18/05/17 13:59, Laurent Pinchart wrote:
> > Hi Tomi,
> > 
> > Thank you for the patch.
> > 
> > On Thursday 18 May 2017 13:28:26 Tomi Valkeinen wrote:
> >> omap_gem uses page alignment for buffer stride. The related calculations
> >> are a bit off, though, as byte stride of 4096 gets aligned to 8192,
> >> instead of 4096. This patch fixes those calculations.
> >>
> >> Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
> >> ---
> >>  drivers/gpu/drm/omapdrm/omap_gem.c | 4 ++--
> >>  1 file changed, 2 insertions(+), 2 deletions(-)
> >>
> >> diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c
> >> b/drivers/gpu/drm/omapdrm/omap_gem.c index 13abf221d153..4c41000ff4c4
> >> 100644
> >> --- a/drivers/gpu/drm/omapdrm/omap_gem.c
> >> +++ b/drivers/gpu/drm/omapdrm/omap_gem.c
> >> @@ -182,7 +182,7 @@ static void evict_entry(struct drm_gem_object *obj,
> >>  	size_t size = PAGE_SIZE * n;
> >>  	loff_t off = mmap_offset(obj) +
> >>  			(entry->obj_pgoff << PAGE_SHIFT);
> >> -	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
> >> +	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
> > 
> > How about 
> > 
> > 	int m = round_up(omap_obj->width << fmt, PAGE_SIZE);
> > 
> > instead of open-coding it ? I find that a bit easier to understand.
> 
> That should be:
> 
> round_up(omap_obj->width << fmt, PAGE_SIZE) / PAGE_SIZE;

Or a bit more optimally just DIV_ROUND_UP()
diff mbox

Patch

diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c b/drivers/gpu/drm/omapdrm/omap_gem.c
index 13abf221d153..4c41000ff4c4 100644
--- a/drivers/gpu/drm/omapdrm/omap_gem.c
+++ b/drivers/gpu/drm/omapdrm/omap_gem.c
@@ -182,7 +182,7 @@  static void evict_entry(struct drm_gem_object *obj,
 	size_t size = PAGE_SIZE * n;
 	loff_t off = mmap_offset(obj) +
 			(entry->obj_pgoff << PAGE_SHIFT);
-	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
+	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
 
 	if (m > 1) {
 		int i;
@@ -424,7 +424,7 @@  static int fault_2d(struct drm_gem_object *obj,
 	 * into account in some of the math, so figure out virtual stride
 	 * in pages
 	 */
-	const int m = 1 + ((omap_obj->width << fmt) / PAGE_SIZE);
+	const int m = 1 + (((omap_obj->width - 1) << fmt) / PAGE_SIZE);
 
 	/* We don't use vmf->pgoff since that has the fake offset: */
 	pgoff = (vmf->address - vma->vm_start) >> PAGE_SHIFT;