diff mbox series

[v3,05/13] drm/dp: Add drm_dp_alternate_scrambler_reset_cap() helper

Message ID 20191021143437.1477719-6-thierry.reding@gmail.com (mailing list archive)
State New, archived
Headers show
Series drm/dp: Move drm_dp_link helpers to Tegra DRM | expand

Commit Message

Thierry Reding Oct. 21, 2019, 2:34 p.m. UTC
From: Thierry Reding <treding@nvidia.com>

Add a helper to check if the sink supports the eDP alternate scrambler
reset value of 0xfffe.

Reviewed-by: Lyude Paul <lyude@redhat.com>
Signed-off-by: Thierry Reding <treding@nvidia.com>
---
 include/drm/drm_dp_helper.h | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h
index bc276c80b927..b3402cb186a4 100644
--- a/include/drm/drm_dp_helper.h
+++ b/include/drm/drm_dp_helper.h
@@ -1294,6 +1294,13 @@  drm_dp_channel_coding_supported(const u8 dpcd[DP_RECEIVER_CAP_SIZE])
 	return dpcd[DP_MAIN_LINK_CHANNEL_CODING] & DP_CAP_ANSI_8B10B;
 }
 
+static inline bool
+drm_dp_alternate_scrambler_reset_cap(const u8 dpcd[DP_RECEIVER_CAP_SIZE])
+{
+	return dpcd[DP_EDP_CONFIGURATION_CAP] &
+			DP_ALTERNATE_SCRAMBLER_RESET_CAP;
+}
+
 /*
  * DisplayPort AUX channel
  */