diff mbox series

drm/fb_dma: s/drm_panic_gem_get_scanout_buffer/drm_fb_dma_get_scanout_buffer

Message ID 20240415151013.3210278-1-mcanal@igalia.com (mailing list archive)
State New, archived
Headers show
Series drm/fb_dma: s/drm_panic_gem_get_scanout_buffer/drm_fb_dma_get_scanout_buffer | expand

Commit Message

Maíra Canal April 15, 2024, 3:09 p.m. UTC
On version 11, Thomas suggested to change the name of the function and
this request was applied on version 12, which is the version that
landed. Although the name of the function changed on the C file, it
didn't changed on the header file, leading to a compilation error as
such:

drivers/gpu/drm/imx/ipuv3/ipuv3-plane.c:780:24: error: use of undeclared
identifier 'drm_fb_dma_get_scanout_buffer'; did you mean 'drm_panic_gem_get_scanout_buffer'?
  780 |         .get_scanout_buffer = drm_fb_dma_get_scanout_buffer,
      |                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |                               drm_panic_gem_get_scanout_buffer
./include/drm/drm_fb_dma_helper.h:23:5: note: 'drm_panic_gem_get_scanout_buffer'
declared here
   23 | int drm_panic_gem_get_scanout_buffer(struct drm_plane *plane,
      |     ^
1 error generated.

Best Regards,
- Maíra

Fixes: 879b3b6511fe ("drm/fb_dma: Add generic get_scanout_buffer() for drm_panic"
Signed-off-by: Maíra Canal <mcanal@igalia.com>
---
 include/drm/drm_fb_dma_helper.h | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Jocelyn Falempe April 15, 2024, 3:19 p.m. UTC | #1
Hi,

You're right, I messed up the rename, and I mostly test on x86, where I 
don't build the imx driver.

Reviewed-by: Jocelyn Falempe <jfalempe@redhat.com>

Best regards,
Maíra Canal April 15, 2024, 5:04 p.m. UTC | #2
On 4/15/24 12:19, Jocelyn Falempe wrote:
> Hi,
> 
> You're right, I messed up the rename, and I mostly test on x86, where I 
> don't build the imx driver.
> 
> Reviewed-by: Jocelyn Falempe <jfalempe@redhat.com>
> 
> Best regards,
> 

Applied to drm-misc/drm-misc-next!

Best Regards,
- Maíra
diff mbox series

Patch

diff --git a/include/drm/drm_fb_dma_helper.h b/include/drm/drm_fb_dma_helper.h
index 61f24c2aba2f..c950732c6d36 100644
--- a/include/drm/drm_fb_dma_helper.h
+++ b/include/drm/drm_fb_dma_helper.h
@@ -6,6 +6,7 @@ 
 
 struct drm_device;
 struct drm_framebuffer;
+struct drm_plane;
 struct drm_plane_state;
 struct drm_scanout_buffer;
 
@@ -20,8 +21,8 @@  void drm_fb_dma_sync_non_coherent(struct drm_device *drm,
 				  struct drm_plane_state *old_state,
 				  struct drm_plane_state *state);
 
-int drm_panic_gem_get_scanout_buffer(struct drm_plane *plane,
-				     struct drm_scanout_buffer *sb);
+int drm_fb_dma_get_scanout_buffer(struct drm_plane *plane,
+				  struct drm_scanout_buffer *sb);
 
 #endif