mbox series

[PULL] drm-xe-next-fixes v2

Message ID Zo_3ustogPDVKZwu@intel.com (mailing list archive)
State New, archived
Headers show
Series [PULL] drm-xe-next-fixes v2 | expand

Pull-request

https://gitlab.freedesktop.org/drm/xe/kernel.git tags/drm-xe-next-fixes-2024-07-11

Message

Rodrigo Vivi July 11, 2024, 3:18 p.m. UTC
Hi Dave and Sima,

This is a v2 of https://lore.kernel.org/intel-xe/Zo2sO4t32dxqy6Q7@intel.com/

v2 - Removed Thomas' write-back caching mode patch since Lucas will propagete
that through drm-xe-fixes towards 6.10. So we remove the amount of patch
duplication.

Again, it is important to highlight the uapi rename present in this
pull-request.
Mesa is aligned and waiting to merge their side:
https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/30027

Since this uapi was recently merged, after we get both sides propagate
there won't be any kernel or mesa releases with the old bad naming.
So we should be good.

Thanks,
Rodrigo.

drm-xe-next-fixes-2024-07-11:
UAPI Changes:
- Rename xe perf layer as xe observation layer (Ashutosh)

Driver Changes:
- Drop trace_xe_hw_fence_free (Brost)
The following changes since commit dbf35b4deabb5706e739cec7ce35c12631bb8c87:

  Merge tag 'drm-intel-next-2024-06-28' of https://gitlab.freedesktop.org/drm/i915/kernel into drm-next (2024-07-10 10:36:47 +0200)

are available in the Git repository at:

  https://gitlab.freedesktop.org/drm/xe/kernel.git tags/drm-xe-next-fixes-2024-07-11

for you to fetch changes up to 26d289158e491d5ae34b10eab40b093a40fab7d7:

  drm/xe: Drop trace_xe_hw_fence_free (2024-07-11 09:54:24 -0400)

----------------------------------------------------------------
UAPI Changes:
- Rename xe perf layer as xe observation layer (Ashutosh)

Driver Changes:
- Drop trace_xe_hw_fence_free (Brost)

----------------------------------------------------------------
Ashutosh Dixit (1):
      drm/xe/uapi: Rename xe perf layer as xe observation layer

Matthew Brost (1):
      drm/xe: Drop trace_xe_hw_fence_free

 drivers/gpu/drm/xe/Makefile          |   2 +-
 drivers/gpu/drm/xe/xe_device.c       |   4 +-
 drivers/gpu/drm/xe/xe_device_types.h |   2 +-
 drivers/gpu/drm/xe/xe_gt_types.h     |   2 +-
 drivers/gpu/drm/xe/xe_hw_fence.c     |   1 -
 drivers/gpu/drm/xe/xe_module.c       |   6 +--
 drivers/gpu/drm/xe/xe_oa.c           |  34 ++++++------
 drivers/gpu/drm/xe/xe_observation.c  |  93 ++++++++++++++++++++++++++++++++
 drivers/gpu/drm/xe/xe_observation.h  |  20 +++++++
 drivers/gpu/drm/xe/xe_perf.c         |  92 -------------------------------
 drivers/gpu/drm/xe/xe_perf.h         |  20 -------
 drivers/gpu/drm/xe/xe_trace.h        |   5 --
 include/uapi/drm/xe_drm.h            | 102 ++++++++++++++++++-----------------
 13 files changed, 190 insertions(+), 193 deletions(-)
 create mode 100644 drivers/gpu/drm/xe/xe_observation.c
 create mode 100644 drivers/gpu/drm/xe/xe_observation.h
 delete mode 100644 drivers/gpu/drm/xe/xe_perf.c
 delete mode 100644 drivers/gpu/drm/xe/xe_perf.h

Comments

Jordan Justen July 11, 2024, 9:29 p.m. UTC | #1
On 2024-07-11 08:18:18, Rodrigo Vivi wrote:
> Hi Dave and Sima,
> 
> This is a v2 of https://lore.kernel.org/intel-xe/Zo2sO4t32dxqy6Q7@intel.com/
> 
> v2 - Removed Thomas' write-back caching mode patch since Lucas will propagete
> that through drm-xe-fixes towards 6.10. So we remove the amount of patch
> duplication.
> 
> Again, it is important to highlight the uapi rename present in this
> pull-request.
> Mesa is aligned and waiting to merge their side:
> https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/30027
> 
> Since this uapi was recently merged, after we get both sides propagate
> there won't be any kernel or mesa releases with the old bad naming.
> So we should be good.

This looks to be a simple rename, and it appears that the binary
interface is functionally the same. So, even if there was a Mesa
release using the old header, it should function fine with the
interface to the kernel regardless of which header the kernel used.

If the binary interface had changed, I'm not sure an argument of "no
kernel or Mesa releases have happened" would be a good way to justify
such a change. Luckily that is not the case here anyway.

-Jordan
Rodrigo Vivi July 11, 2024, 9:33 p.m. UTC | #2
On Thu, Jul 11, 2024 at 02:29:04PM -0700, Jordan Justen wrote:
> On 2024-07-11 08:18:18, Rodrigo Vivi wrote:
> > Hi Dave and Sima,
> > 
> > This is a v2 of https://lore.kernel.org/intel-xe/Zo2sO4t32dxqy6Q7@intel.com/
> > 
> > v2 - Removed Thomas' write-back caching mode patch since Lucas will propagete
> > that through drm-xe-fixes towards 6.10. So we remove the amount of patch
> > duplication.
> > 
> > Again, it is important to highlight the uapi rename present in this
> > pull-request.
> > Mesa is aligned and waiting to merge their side:
> > https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/30027
> > 
> > Since this uapi was recently merged, after we get both sides propagate
> > there won't be any kernel or mesa releases with the old bad naming.
> > So we should be good.
> 
> This looks to be a simple rename, and it appears that the binary
> interface is functionally the same. So, even if there was a Mesa
> release using the old header, it should function fine with the
> interface to the kernel regardless of which header the kernel used.
> 
> If the binary interface had changed, I'm not sure an argument of "no
> kernel or Mesa releases have happened" would be a good way to justify
> such a change. Luckily that is not the case here anyway.

Agreed. If it was that drastic we should never do and this argument
shouldn't apply.

But it is not so transparent as a full rename because there's one
sysfs file name that also changed with the rest of the renaming. :/

> 
> -Jordan