mbox series

[Outreachy,v3,00/13] Finish converting git bisect to C part 1

Message ID 20200208090704.26506-1-mirucam@gmail.com (mailing list archive)
Headers show
Series Finish converting git bisect to C part 1 | expand

Message

Miriam R. Feb. 8, 2020, 9:06 a.m. UTC
These patches correspond to a first part of patch series 
of Outreachy project "Finish converting `git bisect` from shell to C" 
started by Pranit Bauva and Tanushree Tumane
(https://public-inbox.org/git/pull.117.git.gitgitgadget@gmail.com) and
continued by me.

This first part is formed of preparatory/clean-up patches and all 
`bisect.c` libification work. 

I would like to thank Johannes Schindelin and Junio Hamano for reviewing
the patch series.

These patch series emails were generated from:
https://gitlab.com/mirucam/git/commits/git-bisect-work-part1-v3

--- Changes since v2 Finish converting git bisect to C part 1 patch series ---

General changes
---------------

* Rebase on master branch: de93cc14ab (The third batch for 2.26, 2020-02-05).
* Amend commit messages.
* Add an enum to represent bisecting error codes.

Specific changes
----------------

[5/13] bisect--helper: introduce new `decide_next()` function

* Change const char* types to char* and fix `free()` calls.

--

[6/13] bisect: add enum to represent bisect returning codes

* New patch that adds an enum to represent bisecting error codes.

--

[7/13] bisect--helper: return error codes from `cmd_bisect__helper()`

* New patch split from `libify `check_good_are_ancestors_of_bad` and its 
dependents`.
* Change code in return for readability.

--

[8/13] bisect: libify `exit_if_skipped_commits` to `error_if_skipped*` 
and its dependents

* Remove comments.

--

[9/13] bisect: libify `bisect_checkout`

* Fix declaration block.
* Change code in return for readability.
* Add comments.

--

[11/13] bisect: libify `check_good_are_ancestors_of_bad` and its 
dependents

* Fix brace location.

--

Miriam Rubio (3):
  bisect--helper: convert `vocab_*` char pointers to char arrays
  bisect: use the standard 'if (!var)' way to check for 0
  bisect: add enum to represent bisect returning codes

Pranit Bauva (8):
  run-command: make `exists_in_PATH()` non-static
  bisect--helper: return error codes from `cmd_bisect__helper()`
  bisect: libify `exit_if_skipped_commits` to `error_if_skipped*` and
    its dependents
  bisect: libify `bisect_checkout`
  bisect: libify `check_merge_bases` and its dependents
  bisect: libify `check_good_are_ancestors_of_bad` and its dependents
  bisect: libify `handle_bad_merge_base` and its dependents
  bisect: libify `bisect_next_all`

Tanushree Tumane (2):
  bisect--helper: change `retval` to `res`
  bisect--helper: introduce new `decide_next()` function

 bisect.c                 | 135 +++++++++++++++++++++++++++------------
 bisect.h                 |  29 ++++++++-
 builtin/bisect--helper.c | 123 +++++++++++++++++++----------------
 run-command.c            |   2 +-
 run-command.h            |  11 ++++
 5 files changed, 201 insertions(+), 99 deletions(-)