@@ -108,9 +108,9 @@ static int has_changes(mmfile_t *one, mmfile_t *two,
struct diff_options *o,
regex_t *regexp, kwset_t kws)
{
- unsigned int one_contains = one ? contains(one, regexp, kws) : 0;
- unsigned int two_contains = two ? contains(two, regexp, kws) : 0;
- return one_contains != two_contains;
+ unsigned int c1 = one ? contains(one, regexp, kws) : 0;
+ unsigned int c2 = two ? contains(two, regexp, kws) : 0;
+ return c1 != c2;
}
static int pickaxe_match(struct diff_filepair *p, struct diff_options *o,
Rename the {one,two}_contains variables to c{1,2}. This will make a follow-up change easier to read. Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com> --- diffcore-pickaxe.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)