diff mbox series

builtin/revert.c: refactor using an enum for cmd-action

Message ID 20240111080417.59346-1-mi.al.lohmann@gmail.com (mailing list archive)
State Superseded
Headers show
Series builtin/revert.c: refactor using an enum for cmd-action | expand

Commit Message

Michael Lohmann Jan. 11, 2024, 8:04 a.m. UTC
This is done to avoid having to keep the char values in sync in
different places and also to get compiler warnings on non-exhaustive
switches.

The newly introduced `revert_action`-enum aligns with the
builtin/rebase.c `action`-enum though the name `revert_action` is chosen
to better differentiate it from `replay_opts->action` with a different
function. For rebase the equivalent of the latter is
`rebase_options->type` and `rebase_options->action` corresponds to the
`cmd` variable in revert.c.

In the rebase `action` enum there is the enumeration constant
`ACTION_NONE` which is not particularly descriptive, since it seems to
imply that no action should be taken. Instead it signals a start of a
revert/cherry-pick process, so here `REVERT_ACTION_START` was chosen.

Co-authored-by: Wanja Henze <wanja.hentze@bevuta.com>
Signed-off-by: Michael Lohmann <mi.al.lohmann@gmail.com>
---
Hello!

When I was working on `revert/cherry-pick --show-current-patch` (still
needs a little bit more discussion, if actually wanted, see thread [1])
I found the construct with the `cmd` as an int a bit irritating. I hope
this patch makes it more obvious what is actually going on.

Is there a reason why `ACTION_NONE` was chosen as a name in
builtin/rebase.c? My best guess is that it came along because it is the
implied action when no other specific action is passed in, but I don't
find that particularly descriptive on what its actual function is...
(Yes, naming things is hard... :D)

An alternative to prefixing the enum name with "revert_" would be to
rename `replay_opts->action` to `replay_opts->type` so it aligns with
rebase. Would you prefer that instead?

Cheers
Michael

[1] https://lore.kernel.org/git/20231218121048.68290-1-mi.al.lohmann@gmail.com/

 builtin/revert.c | 80 +++++++++++++++++++++++++++++-------------------
 1 file changed, 49 insertions(+), 31 deletions(-)

Comments

Phillip Wood Jan. 11, 2024, 4:57 p.m. UTC | #1
Hi Michael

On 11/01/2024 08:04, Michael Lohmann wrote:
> This is done to avoid having to keep the char values in sync in
> different places and also to get compiler warnings on non-exhaustive
> switches.

I think this is a reasonable change, thanks for working on it.

> The newly introduced `revert_action`-enum aligns with the
> builtin/rebase.c `action`-enum though the name `revert_action` is chosen
> to better differentiate it from `replay_opts->action` with a different
> function. For rebase the equivalent of the latter is
> `rebase_options->type` and `rebase_options->action` corresponds to the
> `cmd` variable in revert.c.
> 
> In the rebase `action` enum there is the enumeration constant
> `ACTION_NONE` which is not particularly descriptive, since it seems to
> imply that no action should be taken. Instead it signals a start of a
> revert/cherry-pick process, so here `REVERT_ACTION_START` was chosen.

I think ACTION_NONE was intended to covey that the user did not pass one 
of the OPT_CMDMODE() options like "--continue" as there isn't a 
"--start" option. I don't have a strong opinion between "_NONE" and 
"_START".

> +enum revert_action {
> +	REVERT_ACTION_START = 0,
> +	REVERT_ACTION_CONTINUE,
> +	REVERT_ACTION_SKIP,
> +	REVERT_ACTION_ABORT,
> +	REVERT_ACTION_QUIT,
> +};

The "REVERT_" prefix is a bit unfortunate as this is used by cherry-pick 
as well but it does match the filename. As this enum is only used in 
this file I'd be quite happy to drop the "REVERT_" prefix. (I don't 
think we need to go messing with the "action" member of struct 
replay_opts to do that)

>   	/* Check for incompatible command line arguments */
> -	if (cmd) {
> -		char *this_operation;
> -		if (cmd == 'q')
> +	{
> +		char *this_operation = 0;

style note: we use "NULL" rather than "0" when initializing pointers. 
Ideally this would be a "const char *" as we assign string literals but 
that is not a new problem with this patch.

> +		switch (cmd) {
> +		case REVERT_ACTION_START:
> +			break;

I can see the attraction of using an exhaustive switch() here but as we 
don't want to do anything in the _START case it gets a bit messy with 
the extra conditional below. I wonder if we'd be better to replace "if 
(cmd) {" with "if (cmd != REVERT_ACTION_START) {". Alternatively if you 
want to stick with the switch then declaring "this_operation" at the 
beginning of the function would mean you can get rid of the new "{}" block.

> +		case REVERT_ACTION_QUIT:
>   			this_operation = "--quit";
> -		else if (cmd == 'c')
> +			break;
> +		case REVERT_ACTION_CONTINUE:
>   			this_operation = "--continue";
> -		else if (cmd == 's')
> +			break;
> +		case REVERT_ACTION_SKIP:
>   			this_operation = "--skip";
> -		else {
> -			assert(cmd == 'a'); > +			break;
> +		case REVERT_ACTION_ABORT:
>   			this_operation = "--abort";
> +			break;
>   		}
>   
> -		verify_opt_compatible(me, this_operation,
> -				"--no-commit", opts->no_commit,
> -				"--signoff", opts->signoff,
> -				"--mainline", opts->mainline,
> -				"--strategy", opts->strategy ? 1 : 0,
> -				"--strategy-option", opts->xopts.nr ? 1 : 0,
> -				"-x", opts->record_origin,
> -				"--ff", opts->allow_ff,
> -				"--rerere-autoupdate", opts->allow_rerere_auto == RERERE_AUTOUPDATE,
> -				"--no-rerere-autoupdate", opts->allow_rerere_auto == RERERE_NOAUTOUPDATE,
> -				NULL);
> +		if (this_operation)

The extra indentation here is unfortunate as some of the lines are 
rather long already. In the current code it is clear that we only call 
verify_opt_compatible() when cmd is non-nul, I think it would be clearer 
to use "if (cmd != REVERT_ACTION_START)" here.

> +			verify_opt_compatible(me, this_operation,
> +					"--no-commit", opts->no_commit,
> +					"--signoff", opts->signoff,
> +					"--mainline", opts->mainline,
> +					"--strategy", opts->strategy ? 1 : 0,
> +					"--strategy-option", opts->xopts.nr ? 1 : 0,
> +					"-x", opts->record_origin,
> +					"--ff", opts->allow_ff,
> +					"--rerere-autoupdate", opts->allow_rerere_auto == RERERE_AUTOUPDATE,
> +					"--no-rerere-autoupdate", opts->allow_rerere_auto == RERERE_NOAUTOUPDATE,
> +					NULL);
>   	}
 > [...]
> -	if (cmd) {
> -		opts->revs = NULL;
> -	} else {
> +	if (cmd == REVERT_ACTION_START) {

I was momentarily confused by this change but you're reversing the 
conditional. I agree that the result is an improvement.

Best Wishes

Phillip
Junio C Hamano Jan. 11, 2024, 7:37 p.m. UTC | #2
Phillip Wood <phillip.wood123@gmail.com> writes:

> I think ACTION_NONE was intended to covey that the user did not pass
> one of the OPT_CMDMODE() options like "--continue" as there isn't a
> "--start" option. I don't have a strong opinion between "_NONE" and
> "_START".

I agree with you why NONE is called as such.  If "revert" does not
take "--start" (I do not remember offhand), I would think it would
be better to follow suit.
diff mbox series

Patch

diff --git a/builtin/revert.c b/builtin/revert.c
index 89821bab95..b5278b7a3b 100644
--- a/builtin/revert.c
+++ b/builtin/revert.c
@@ -20,6 +20,14 @@ 
  * Copyright (c) 2005 Junio C Hamano
  */
 
+enum revert_action {
+	REVERT_ACTION_START = 0,
+	REVERT_ACTION_CONTINUE,
+	REVERT_ACTION_SKIP,
+	REVERT_ACTION_ABORT,
+	REVERT_ACTION_QUIT,
+};
+
 static const char * const revert_usage[] = {
 	N_("git revert [--[no-]edit] [-n] [-m <parent-number>] [-s] [-S[<keyid>]] <commit>..."),
 	N_("git revert (--continue | --skip | --abort | --quit)"),
@@ -85,12 +93,12 @@  static int run_sequencer(int argc, const char **argv, const char *prefix,
 	const char * const * usage_str = revert_or_cherry_pick_usage(opts);
 	const char *me = action_name(opts);
 	const char *cleanup_arg = NULL;
-	int cmd = 0;
+	enum revert_action cmd = REVERT_ACTION_START;
 	struct option base_options[] = {
-		OPT_CMDMODE(0, "quit", &cmd, N_("end revert or cherry-pick sequence"), 'q'),
-		OPT_CMDMODE(0, "continue", &cmd, N_("resume revert or cherry-pick sequence"), 'c'),
-		OPT_CMDMODE(0, "abort", &cmd, N_("cancel revert or cherry-pick sequence"), 'a'),
-		OPT_CMDMODE(0, "skip", &cmd, N_("skip current commit and continue"), 's'),
+		OPT_CMDMODE(0, "quit", &cmd, N_("end revert or cherry-pick sequence"), REVERT_ACTION_QUIT),
+		OPT_CMDMODE(0, "continue", &cmd, N_("resume revert or cherry-pick sequence"), REVERT_ACTION_CONTINUE),
+		OPT_CMDMODE(0, "abort", &cmd, N_("cancel revert or cherry-pick sequence"), REVERT_ACTION_ABORT),
+		OPT_CMDMODE(0, "skip", &cmd, N_("skip current commit and continue"), REVERT_ACTION_SKIP),
 		OPT_CLEANUP(&cleanup_arg),
 		OPT_BOOL('n', "no-commit", &opts->no_commit, N_("don't automatically commit")),
 		OPT_BOOL('e', "edit", &opts->edit, N_("edit the commit message")),
@@ -144,30 +152,37 @@  static int run_sequencer(int argc, const char **argv, const char *prefix,
 	}
 
 	/* Check for incompatible command line arguments */
-	if (cmd) {
-		char *this_operation;
-		if (cmd == 'q')
+	{
+		char *this_operation = 0;
+		switch (cmd) {
+		case REVERT_ACTION_START:
+			break;
+		case REVERT_ACTION_QUIT:
 			this_operation = "--quit";
-		else if (cmd == 'c')
+			break;
+		case REVERT_ACTION_CONTINUE:
 			this_operation = "--continue";
-		else if (cmd == 's')
+			break;
+		case REVERT_ACTION_SKIP:
 			this_operation = "--skip";
-		else {
-			assert(cmd == 'a');
+			break;
+		case REVERT_ACTION_ABORT:
 			this_operation = "--abort";
+			break;
 		}
 
-		verify_opt_compatible(me, this_operation,
-				"--no-commit", opts->no_commit,
-				"--signoff", opts->signoff,
-				"--mainline", opts->mainline,
-				"--strategy", opts->strategy ? 1 : 0,
-				"--strategy-option", opts->xopts.nr ? 1 : 0,
-				"-x", opts->record_origin,
-				"--ff", opts->allow_ff,
-				"--rerere-autoupdate", opts->allow_rerere_auto == RERERE_AUTOUPDATE,
-				"--no-rerere-autoupdate", opts->allow_rerere_auto == RERERE_NOAUTOUPDATE,
-				NULL);
+		if (this_operation)
+			verify_opt_compatible(me, this_operation,
+					"--no-commit", opts->no_commit,
+					"--signoff", opts->signoff,
+					"--mainline", opts->mainline,
+					"--strategy", opts->strategy ? 1 : 0,
+					"--strategy-option", opts->xopts.nr ? 1 : 0,
+					"-x", opts->record_origin,
+					"--ff", opts->allow_ff,
+					"--rerere-autoupdate", opts->allow_rerere_auto == RERERE_AUTOUPDATE,
+					"--no-rerere-autoupdate", opts->allow_rerere_auto == RERERE_NOAUTOUPDATE,
+					NULL);
 	}
 
 	if (!opts->strategy && opts->default_strategy) {
@@ -183,9 +198,7 @@  static int run_sequencer(int argc, const char **argv, const char *prefix,
 				"--edit", opts->edit > 0,
 				NULL);
 
-	if (cmd) {
-		opts->revs = NULL;
-	} else {
+	if (cmd == REVERT_ACTION_START) {
 		struct setup_revision_opt s_r_opt;
 		opts->revs = xmalloc(sizeof(*opts->revs));
 		repo_init_revisions(the_repository, opts->revs, NULL);
@@ -198,6 +211,8 @@  static int run_sequencer(int argc, const char **argv, const char *prefix,
 		memset(&s_r_opt, 0, sizeof(s_r_opt));
 		s_r_opt.assume_dashdash = 1;
 		argc = setup_revisions(argc, argv, opts->revs, &s_r_opt);
+	} else {
+		opts->revs = NULL;
 	}
 
 	if (argc > 1)
@@ -210,19 +225,22 @@  static int run_sequencer(int argc, const char **argv, const char *prefix,
 		opts->strategy = xstrdup(getenv("GIT_TEST_MERGE_ALGORITHM"));
 	free(options);
 
-	if (cmd == 'q') {
+	switch (cmd) {
+	case REVERT_ACTION_QUIT: {
 		int ret = sequencer_remove_state(opts);
 		if (!ret)
 			remove_branch_state(the_repository, 0);
 		return ret;
 	}
-	if (cmd == 'c')
+	case REVERT_ACTION_CONTINUE:
 		return sequencer_continue(the_repository, opts);
-	if (cmd == 'a')
+	case REVERT_ACTION_ABORT:
 		return sequencer_rollback(the_repository, opts);
-	if (cmd == 's')
+	case REVERT_ACTION_SKIP:
 		return sequencer_skip(the_repository, opts);
-	return sequencer_pick_revisions(the_repository, opts);
+	case REVERT_ACTION_START:
+		return sequencer_pick_revisions(the_repository, opts);
+	}
 }
 
 int cmd_revert(int argc, const char **argv, const char *prefix)