diff mbox series

[v2,3/3] difftool: eliminate use of USE_THE_REPOSITORY_VARIABLE

Message ID 20250206042010.865947-3-davvid@gmail.com (mailing list archive)
State Accepted
Commit 7c2f2919434b0b9d8df79f469903d0bca815557b
Headers show
Series [v2,1/3] difftool: eliminate use of global variables | expand

Commit Message

David Aguilar Feb. 6, 2025, 4:20 a.m. UTC
Remove the USE_THE_REPOSITORY_VARIABLE #define now that all
state is passed to each function from callers.

Signed-off-by: David Aguilar <davvid@gmail.com>
---
 builtin/difftool.c | 2 --
 1 file changed, 2 deletions(-)

Comments

Elijah Newren Feb. 6, 2025, 8:31 a.m. UTC | #1
On Wed, Feb 5, 2025 at 8:20 PM David Aguilar <davvid@gmail.com> wrote:
>
> Remove the USE_THE_REPOSITORY_VARIABLE #define now that all
> state is passed to each function from callers.
>
> Signed-off-by: David Aguilar <davvid@gmail.com>
> ---
>  builtin/difftool.c | 2 --
>  1 file changed, 2 deletions(-)
>
> diff --git a/builtin/difftool.c b/builtin/difftool.c
> index 81d733dfdf..41cd00066c 100644
> --- a/builtin/difftool.c
> +++ b/builtin/difftool.c
> @@ -12,8 +12,6 @@
>   * Copyright (C) 2016 Johannes Schindelin
>   */
>
> -#define USE_THE_REPOSITORY_VARIABLE
> -
>  #include "builtin.h"
>
>  #include "abspath.h"
> --
> 2.48.1.461.g612e419e04


Nice; thanks for working on this.
Patrick Steinhardt Feb. 7, 2025, 6:28 a.m. UTC | #2
On Thu, Feb 06, 2025 at 12:31:14AM -0800, Elijah Newren wrote:
> On Wed, Feb 5, 2025 at 8:20 PM David Aguilar <davvid@gmail.com> wrote:
> >
> > Remove the USE_THE_REPOSITORY_VARIABLE #define now that all
> > state is passed to each function from callers.
> >
> > Signed-off-by: David Aguilar <davvid@gmail.com>
> > ---
> >  builtin/difftool.c | 2 --
> >  1 file changed, 2 deletions(-)
> >
> > diff --git a/builtin/difftool.c b/builtin/difftool.c
> > index 81d733dfdf..41cd00066c 100644
> > --- a/builtin/difftool.c
> > +++ b/builtin/difftool.c
> > @@ -12,8 +12,6 @@
> >   * Copyright (C) 2016 Johannes Schindelin
> >   */
> >
> > -#define USE_THE_REPOSITORY_VARIABLE
> > -
> >  #include "builtin.h"
> >
> >  #include "abspath.h"
> > --
> > 2.48.1.461.g612e419e04
> 
> 
> Nice; thanks for working on this.

Yup, thanks for rerolling. This version is much easier to read indeed
and looks good to me.

Patrick
Junio C Hamano Feb. 7, 2025, 5:49 p.m. UTC | #3
Patrick Steinhardt <ps@pks.im> writes:

> On Thu, Feb 06, 2025 at 12:31:14AM -0800, Elijah Newren wrote:
>> On Wed, Feb 5, 2025 at 8:20 PM David Aguilar <davvid@gmail.com> wrote:
>> ...
>> 
>> Nice; thanks for working on this.
>
> Yup, thanks for rerolling. This version is much easier to read indeed
> and looks good to me.

Thanks, all, for working on this and reviewing the patches.
Looking very good.

Let me mark the topic for 'next'.
diff mbox series

Patch

diff --git a/builtin/difftool.c b/builtin/difftool.c
index 81d733dfdf..41cd00066c 100644
--- a/builtin/difftool.c
+++ b/builtin/difftool.c
@@ -12,8 +12,6 @@ 
  * Copyright (C) 2016 Johannes Schindelin
  */
 
-#define USE_THE_REPOSITORY_VARIABLE
-
 #include "builtin.h"
 
 #include "abspath.h"