diff mbox series

[v2] meson: disable coccinelle configuration when building from a tarball

Message ID 20250325200920.198057-1-eschwartz@gentoo.org (mailing list archive)
State Accepted
Commit d2827dc31e6769ddd552a34593d28cecd5f3392d
Headers show
Series [v2] meson: disable coccinelle configuration when building from a tarball | expand

Commit Message

Eli Schwartz March 25, 2025, 8:08 p.m. UTC
Wiring up coccinelle in the build, depends on running git commands to
get the list of files to operate on. Reasonable, for a feature mainly
used by people developing on git. If building git itself from a tarball
distribution of git's own source code, one likely does not need to run
coccinelle.

But running those git commands failed, and caused the build to error
out, if `spatch` was installed -- because the build assumed that its
presence indicated a desire to use it on this source tree. Instead, we
can expand the conditional to check for both `spatch` and the `.git`
file or directory.

Meson's `opt.require()` method allows us to add a prerequisite for the
feature option. If the prerequisite fails, then the option either:

- converts autodetection to disabled

- emits an informative error if the feature was set to enabled:
  ```
  ERROR: Feature coccinelle cannot be enabled: coccinelle can only be run from a git checkout
  ```

Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
---

v2: accidentally chopped off part of the commit message, sorry...

 contrib/coccinelle/meson.build | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)


base-commit: c1d6628c9433c09ff62f916f2b933ee12995e9d8

Comments

Junio C Hamano March 25, 2025, 11:21 p.m. UTC | #1
Eli Schwartz <eschwartz@gentoo.org> writes:

> presence indicated a desire to use it on this source tree. Instead, we
> can expand the conditional to check for both `spatch` and the `.git`
> file or directory.

Good thinking.  I very much appreciate that you allowed .git to be a
regular file, as well as a directory.

Will queue.  Thanks.
Eli Schwartz March 25, 2025, 11:29 p.m. UTC | #2
On 3/25/25 7:21 PM, Junio C Hamano wrote:
> Eli Schwartz <eschwartz@gentoo.org> writes:
> 
>> presence indicated a desire to use it on this source tree. Instead, we
>> can expand the conditional to check for both `spatch` and the `.git`
>> file or directory.
> 
> Good thinking.  I very much appreciate that you allowed .git to be a
> regular file, as well as a directory.
> 
> Will queue.  Thanks.


As a heavy user of worktrees this topic is certainly on my mind. :D
Patrick Steinhardt March 26, 2025, 8:28 a.m. UTC | #3
On Tue, Mar 25, 2025 at 04:08:48PM -0400, Eli Schwartz wrote:
> Wiring up coccinelle in the build, depends on running git commands to
> get the list of files to operate on. Reasonable, for a feature mainly
> used by people developing on git. If building git itself from a tarball
> distribution of git's own source code, one likely does not need to run
> coccinelle.
> 
> But running those git commands failed, and caused the build to error
> out, if `spatch` was installed -- because the build assumed that its
> presence indicated a desire to use it on this source tree. Instead, we
> can expand the conditional to check for both `spatch` and the `.git`
> file or directory.
> 
> Meson's `opt.require()` method allows us to add a prerequisite for the
> feature option. If the prerequisite fails, then the option either:
> 
> - converts autodetection to disabled
> 
> - emits an informative error if the feature was set to enabled:
>   ```
>   ERROR: Feature coccinelle cannot be enabled: coccinelle can only be run from a git checkout
>   ```

Makes sense.

> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
> ---
> 
> v2: accidentally chopped off part of the commit message, sorry...
> 
>  contrib/coccinelle/meson.build | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/contrib/coccinelle/meson.build b/contrib/coccinelle/meson.build
> index 5d76a7fee6..ea054c924f 100644
> --- a/contrib/coccinelle/meson.build
> +++ b/contrib/coccinelle/meson.build
> @@ -1,4 +1,9 @@
> -spatch = find_program('spatch', required: get_option('coccinelle'))
> +coccinelle_opt = get_option('coccinelle').require(
> +  fs.exists(meson.project_source_root() / '.git'),
> +  error_message: 'coccinelle can only be run from a git checkout',
> +)
> +
> +spatch = find_program('spatch', required: coccinelle_opt)
>  if not spatch.found()
>    subdir_done()
>  endif
> 
> base-commit: c1d6628c9433c09ff62f916f2b933ee12995e9d8

Yup, makes sense, as well.

Thank you for the patch, looks good!

Patrick
diff mbox series

Patch

diff --git a/contrib/coccinelle/meson.build b/contrib/coccinelle/meson.build
index 5d76a7fee6..ea054c924f 100644
--- a/contrib/coccinelle/meson.build
+++ b/contrib/coccinelle/meson.build
@@ -1,4 +1,9 @@ 
-spatch = find_program('spatch', required: get_option('coccinelle'))
+coccinelle_opt = get_option('coccinelle').require(
+  fs.exists(meson.project_source_root() / '.git'),
+  error_message: 'coccinelle can only be run from a git checkout',
+)
+
+spatch = find_program('spatch', required: coccinelle_opt)
 if not spatch.found()
   subdir_done()
 endif