diff mbox series

meson: fix perl dependencies

Message ID 371571630df201b0b0c680f6437decc6c60ecd3b.1736307757.git.sam@gentoo.org (mailing list archive)
State Accepted
Commit 45c0897204cfb5d0d88370a4907e41b0eb717b6c
Headers show
Series meson: fix perl dependencies | expand

Commit Message

Sam James Jan. 8, 2025, 3:42 a.m. UTC
`generate_perl_command` needs `depends: [git_version_file]` and the uses
in top-level meson.build were fine, but the ones in perl/ weren't, causing
parallel build failures in some cases as GIT-BUILD-OPTIONS wasn't yet
available.

Signed-off-by: Sam James <sam@gentoo.org>
---
 perl/FromCPAN/Mail/meson.build     | 1 +
 perl/FromCPAN/meson.build          | 1 +
 perl/Git/LoadCPAN/Mail/meson.build | 1 +
 perl/Git/LoadCPAN/meson.build      | 1 +
 perl/Git/SVN/Memoize/meson.build   | 1 +
 perl/Git/SVN/meson.build           | 1 +
 perl/Git/meson.build               | 1 +
 perl/meson.build                   | 1 +
 8 files changed, 8 insertions(+)

Comments

Patrick Steinhardt Jan. 8, 2025, 6:22 a.m. UTC | #1
On Wed, Jan 08, 2025 at 03:42:37AM +0000, Sam James wrote:
> `generate_perl_command` needs `depends: [git_version_file]` and the uses
> in top-level meson.build were fine, but the ones in perl/ weren't, causing
> parallel build failures in some cases as GIT-BUILD-OPTIONS wasn't yet
> available.

Thanks for your patch! The change looks obviously correct to me.

Patrick
Junio C Hamano Jan. 8, 2025, 4:07 p.m. UTC | #2
Patrick Steinhardt <ps@pks.im> writes:

> On Wed, Jan 08, 2025 at 03:42:37AM +0000, Sam James wrote:
>> `generate_perl_command` needs `depends: [git_version_file]` and the uses
>> in top-level meson.build were fine, but the ones in perl/ weren't, causing
>> parallel build failures in some cases as GIT-BUILD-OPTIONS wasn't yet
>> available.
>
> Thanks for your patch! The change looks obviously correct to me.
>
> Patrick

Thanks, both.  Will fast-track to 'master' before the final gets
tagged, but we may want to advertise 'meson' support still as work
in progress in the release notes.
Patrick Steinhardt Jan. 8, 2025, 4:13 p.m. UTC | #3
On Wed, Jan 08, 2025 at 08:07:04AM -0800, Junio C Hamano wrote:
> Patrick Steinhardt <ps@pks.im> writes:
> 
> > On Wed, Jan 08, 2025 at 03:42:37AM +0000, Sam James wrote:
> >> `generate_perl_command` needs `depends: [git_version_file]` and the uses
> >> in top-level meson.build were fine, but the ones in perl/ weren't, causing
> >> parallel build failures in some cases as GIT-BUILD-OPTIONS wasn't yet
> >> available.
> >
> > Thanks for your patch! The change looks obviously correct to me.
> >
> > Patrick
> 
> Thanks, both.  Will fast-track to 'master' before the final gets
> tagged, but we may want to advertise 'meson' support still as work
> in progress in the release notes.

Yeah, agreed. Thanks!

Patrick
diff mbox series

Patch

diff --git a/perl/FromCPAN/Mail/meson.build b/perl/FromCPAN/Mail/meson.build
index 129cff161c..b4ff2fc0b2 100644
--- a/perl/FromCPAN/Mail/meson.build
+++ b/perl/FromCPAN/Mail/meson.build
@@ -4,4 +4,5 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5/FromCPAN/Mail',
+  depends: [git_version_file],
 )
diff --git a/perl/FromCPAN/meson.build b/perl/FromCPAN/meson.build
index 4e7ea909df..1f9ea6ce8e 100644
--- a/perl/FromCPAN/meson.build
+++ b/perl/FromCPAN/meson.build
@@ -4,6 +4,7 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5/FromCPAN',
+  depends: [git_version_file],
 )
 
 subdir('Mail')
diff --git a/perl/Git/LoadCPAN/Mail/meson.build b/perl/Git/LoadCPAN/Mail/meson.build
index 7da5b37adb..89cde56be8 100644
--- a/perl/Git/LoadCPAN/Mail/meson.build
+++ b/perl/Git/LoadCPAN/Mail/meson.build
@@ -4,4 +4,5 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5/Git/LoadCPAN/Mail',
+  depends: [git_version_file],
 )
diff --git a/perl/Git/LoadCPAN/meson.build b/perl/Git/LoadCPAN/meson.build
index 9468c073ae..1ee915c650 100644
--- a/perl/Git/LoadCPAN/meson.build
+++ b/perl/Git/LoadCPAN/meson.build
@@ -4,6 +4,7 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5/Git/LoadCPAN',
+  depends: [git_version_file],
 )
 
 subdir('Mail')
diff --git a/perl/Git/SVN/Memoize/meson.build b/perl/Git/SVN/Memoize/meson.build
index 515ab3dd92..233ec670d7 100644
--- a/perl/Git/SVN/Memoize/meson.build
+++ b/perl/Git/SVN/Memoize/meson.build
@@ -4,4 +4,5 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5/Git/SVN',
+  depends: [git_version_file],
 )
diff --git a/perl/Git/SVN/meson.build b/perl/Git/SVN/meson.build
index 8338531041..44abaf42b7 100644
--- a/perl/Git/SVN/meson.build
+++ b/perl/Git/SVN/meson.build
@@ -14,6 +14,7 @@  foreach source : [
     command: generate_perl_command,
     install: true,
     install_dir: get_option('datadir') / 'perl5/Git/SVN',
+    depends: [git_version_file],
   )
 endforeach
 
diff --git a/perl/Git/meson.build b/perl/Git/meson.build
index 259209d730..b21fa5591e 100644
--- a/perl/Git/meson.build
+++ b/perl/Git/meson.build
@@ -11,6 +11,7 @@  foreach source : [
     command: generate_perl_command,
     install: true,
     install_dir: get_option('datadir') / 'perl5/Git',
+    depends: [git_version_file],
   )
 endforeach
 
diff --git a/perl/meson.build b/perl/meson.build
index c22d6f8a1a..2d4ab1c4a9 100644
--- a/perl/meson.build
+++ b/perl/meson.build
@@ -4,6 +4,7 @@  test_dependencies += custom_target(
   command: generate_perl_command,
   install: true,
   install_dir: get_option('datadir') / 'perl5',
+  depends: [git_version_file],
 )
 
 subdir('Git')