diff mbox series

[v3] meson: fix missing deps for technical articles

Message ID 5114dc9a00377826a55f6bab007d2ad1a4de8bc5.1736866030.git.sam@gentoo.org (mailing list archive)
State New
Headers show
Series [v3] meson: fix missing deps for technical articles | expand

Commit Message

Sam James Jan. 14, 2025, 2:47 p.m. UTC
We need an explicit `depends: documentation_deps` so that all of our
Documentation targets know they require asciidoc.conf. This shows up
as parallel build failures with it not yet being available.

Other targets look OK already.

Signed-off-by: Sam James <sam@gentoo.org>
---
v3: Fixed commit message.
v2: Drop incorrect dep I'd added for api-index.sh as pointed out by Patrick.

 Documentation/technical/meson.build | 1 +
 1 file changed, 1 insertion(+)

Comments

Patrick Steinhardt Jan. 14, 2025, 3:01 p.m. UTC | #1
On Tue, Jan 14, 2025 at 02:47:10PM +0000, Sam James wrote:
> We need an explicit `depends: documentation_deps` so that all of our
> Documentation targets know they require asciidoc.conf. This shows up
> as parallel build failures with it not yet being available.
> 
> Other targets look OK already.
> 
> Signed-off-by: Sam James <sam@gentoo.org>
> ---
> v3: Fixed commit message.
> v2: Drop incorrect dep I'd added for api-index.sh as pointed out by Patrick.

Thanks, this version looks good to me.

Patrick
Sam James Jan. 14, 2025, 3:09 p.m. UTC | #2
Patrick Steinhardt <ps@pks.im> writes:

> On Tue, Jan 14, 2025 at 02:47:10PM +0000, Sam James wrote:
>> We need an explicit `depends: documentation_deps` so that all of our
>> Documentation targets know they require asciidoc.conf. This shows up
>> as parallel build failures with it not yet being available.
>> 
>> Other targets look OK already.
>> 
>> Signed-off-by: Sam James <sam@gentoo.org>
>> ---
>> v3: Fixed commit message.
>> v2: Drop incorrect dep I'd added for api-index.sh as pointed out by Patrick.
>
> Thanks, this version looks good to me.

Thanks, and sorry for the (obvious) errors.

>
> Patrick
Junio C Hamano Jan. 14, 2025, 7:16 p.m. UTC | #3
Sam James <sam@gentoo.org> writes:

> Patrick Steinhardt <ps@pks.im> writes:
>
>> On Tue, Jan 14, 2025 at 02:47:10PM +0000, Sam James wrote:
>>> We need an explicit `depends: documentation_deps` so that all of our
>>> Documentation targets know they require asciidoc.conf. This shows up
>>> as parallel build failures with it not yet being available.
>>> 
>>> Other targets look OK already.
>>> 
>>> Signed-off-by: Sam James <sam@gentoo.org>
>>> ---
>>> v3: Fixed commit message.
>>> v2: Drop incorrect dep I'd added for api-index.sh as pointed out by Patrick.
>>
>> Thanks, this version looks good to me.
>
> Thanks, and sorry for the (obvious) errors.

Thanks, both of you, to working well together and quickly.

Will queue.
diff mbox series

Patch

diff --git a/Documentation/technical/meson.build b/Documentation/technical/meson.build
index 21dfb8b5c9..3a65ee59b3 100644
--- a/Documentation/technical/meson.build
+++ b/Documentation/technical/meson.build
@@ -60,6 +60,7 @@  foreach article : api_docs + articles
     command: asciidoc_html_options,
     input: article,
     output: fs.stem(article) + '.html',
+    depends: documentation_deps,
     install: true,
     install_dir: get_option('datadir') / 'doc/git-doc/technical',
   )