diff mbox series

[3/3] pack-write: use hashwrite_be64()

Message ID 716c9fd8-273e-6bf6-ab67-1f589d2c9687@web.de (mailing list archive)
State New, archived
Headers show
Series [1/3] csum-file: add hashwrite_be64() | expand

Commit Message

René Scharfe Nov. 12, 2020, 12:23 p.m. UTC
Call hashwrite_be64() to write a 64-bit value instead of open-coding it
using htonl() and hashwrite().  This shortens the code, gets rid of a
buffer and several magic numbers, and makes the intent clearer.

Signed-off-by: René Scharfe <l.s.r@web.de>
---
 pack-write.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

--
2.29.2
diff mbox series

Patch

diff --git a/pack-write.c b/pack-write.c
index 23e19cc1ec..3513665e1e 100644
--- a/pack-write.c
+++ b/pack-write.c
@@ -151,13 +151,10 @@  const char *write_idx_file(const char *index_name, struct pack_idx_entry **objec
 		while (nr_large_offset) {
 			struct pack_idx_entry *obj = *list++;
 			uint64_t offset = obj->offset;
-			uint32_t split[2];

 			if (!need_large_offset(offset, opts))
 				continue;
-			split[0] = htonl(offset >> 32);
-			split[1] = htonl(offset & 0xffffffff);
-			hashwrite(f, split, 8);
+			hashwrite_be64(f, offset);
 			nr_large_offset--;
 		}
 	}