diff mbox series

nd/switch-and-restore, was Re: What's cooking in git.git (Apr 2019, #02; Wed, 10)

Message ID nycvar.QRO.7.76.6.1904102348500.41@tvgsbejvaqbjf.bet (mailing list archive)
State New, archived
Headers show
Series nd/switch-and-restore, was Re: What's cooking in git.git (Apr 2019, #02; Wed, 10) | expand

Commit Message

Johannes Schindelin April 10, 2019, 9:51 p.m. UTC
Hi Junio,

On Wed, 10 Apr 2019, Junio C Hamano wrote:

> * nd/switch-and-restore (2019-04-02) 39 commits
>  - doc: promote "git restore"
>  - completion: support restore
>  - SQUASH??? move -p test to 2071 from 2070
>  - t: add tests for restore
>  - restore: support --patch
>  - restore: default to --source=HEAD when only --index is specified
>  - restore: add --worktree and --index
>  - checkout: factor out worktree checkout code
>  - restore: disable overlay mode by default
>  - restore: make pathspec mandatory
>  - restore: take tree-ish from --source option instead
>  - checkout: split part of it to new command 'restore'
>  - doc: promote "git switch"
>  - completion: support switch
>  - t: add tests for switch
>  - switch: make --orphan switch to an empty tree
>  - switch: reject if some operation is in progress
>  - switch: no worktree status unless real branch switch happens
>  - switch: implicit dwim, use --no-guess to disable it
>  - switch: add short option for --detach
>  - switch: only allow explicit detached HEAD
>  - switch: reject "do nothing" case
>  - switch: stop accepting pathspec
>  - switch: remove -l
>  - switch: add --discard-changes
>  - switch: better names for -b and -B
>  - checkout: split part of it to new command 'switch'
>  - checkout: split options[] array in three pieces
>  - checkout: move 'confict_style' and 'dwim_..' to checkout_opts
>  - checkout: make "opts" in cmd_checkout() a pointer
>  - checkout: factor out some code in parse_branchname_arg()
>  - checkout: keep most #include sorted
>  - checkout: inform the user when removing branch state
>  - checkout: advice how to get out of detached HEAD mode
>  - t: rename t2014-switch.sh to t2014-checkout-switch.sh
>  - git-checkout.txt: fix monospace typeset
>  - doc: document --overwrite-ignore
>  - git-checkout.txt: fix one syntax line
>  - git-checkout.txt: spell out --no-option
>
>  Two new commands "git switch" and "git restore" are introduced to
>  split "checking out a branch to work on advancing its history" and
>  "checking out paths out of the index and/or a tree-ish to work on
>  advancing the current history" out of the single "git checkout"
>  command.
>
>  cf. <20190329103919.15642-1-pclouds@gmail.com> (switch v6)
>  cf. <20190308101655.9767-1-pclouds@gmail.com> (restore v1)

This one fails the CI for almost a month already, still needing this
squashed in:

-- snipsnap --
diff mbox series

Patch

diff --git a/Documentation/git-restore.txt b/Documentation/git-restore.txt
index a667a5ced4ec..1faeee50593e 100644
--- a/Documentation/git-restore.txt
+++ b/Documentation/git-restore.txt
@@ -144,7 +144,7 @@  $ git restore .
 ------------

 or to restore all working tree files with 'top' pathspec magic (see
-linkgit::gitglossary[7])
+linkgit:gitglossary[7])

 ------------
 $ git restore :/