mbox series

[v2,0/5] drm/i915: Rename functions to match their entry points

Message ID 20190711073155.10926-1-janusz.krzysztofik@linux.intel.com (mailing list archive)
Headers show
Series drm/i915: Rename functions to match their entry points | expand

Message

Janusz Krzysztofik July 11, 2019, 7:31 a.m. UTC
Need for this was identified while working on split of driver unbind
path into _remove() and _release() parts.  Consistency in function
naming has been recognized as helpful when trying to work out which
phase the code is in.

v2: * early_probe pairs better with late_release (Chris),
    * exclude patch 6/6 "drm/i915: Rename "inject_load_failure" module
      parameter" for now, it requires updates on user (IGT) side
    * rebase on top of "drm/i915: Drop extern qualifiers from header
      function prototypes"

Janusz Krzysztofik (5):
  drm/i915: Rename "_load"/"_unload" to match PCI entry points
  drm/i915: Replace "_load" with "_probe" consequently
  drm/i915: Propagate "_release" function name suffix down
  drm/i915: Propagate "_remove" function name suffix down
  drm/i915: Propagate "_probe" function name suffix down

 drivers/gpu/drm/i915/display/intel_bios.c     |   4 +-
 drivers/gpu/drm/i915/display/intel_bios.h     |   2 +-
 .../gpu/drm/i915/display/intel_connector.c    |   2 +-
 drivers/gpu/drm/i915/display/intel_display.c  |   2 +-
 .../drm/i915/display/intel_display_power.c    |   6 +-
 .../drm/i915/display/intel_display_power.h    |   2 +-
 drivers/gpu/drm/i915/gt/intel_engine_cs.c     |   2 +-
 drivers/gpu/drm/i915/i915_drv.c               | 107 +++++++++---------
 drivers/gpu/drm/i915/i915_drv.h               |  20 ++--
 drivers/gpu/drm/i915/i915_gem.c               |  12 +-
 drivers/gpu/drm/i915/i915_gem_gtt.c           |   4 +-
 drivers/gpu/drm/i915/i915_gem_gtt.h           |   2 +-
 drivers/gpu/drm/i915/i915_pci.c               |   6 +-
 drivers/gpu/drm/i915/intel_gvt.c              |   7 +-
 drivers/gpu/drm/i915/intel_gvt.h              |   5 +-
 drivers/gpu/drm/i915/intel_runtime_pm.c       |   2 +-
 drivers/gpu/drm/i915/intel_runtime_pm.h       |   2 +-
 drivers/gpu/drm/i915/intel_uncore.c           |   2 +-
 drivers/gpu/drm/i915/intel_wopcm.c            |   2 +-
 19 files changed, 97 insertions(+), 94 deletions(-)

Comments

Chris Wilson July 11, 2019, 7:40 a.m. UTC | #1
Quoting Janusz Krzysztofik (2019-07-11 08:31:52)
> Need for this was identified while working on split of driver unbind
> path into _remove() and _release() parts.  Consistency in function
> naming has been recognized as helpful when trying to work out which
> phase the code is in.
> 
> v2: * early_probe pairs better with late_release (Chris),
>     * exclude patch 6/6 "drm/i915: Rename "inject_load_failure" module
>       parameter" for now, it requires updates on user (IGT) side
>     * rebase on top of "drm/i915: Drop extern qualifiers from header
>       function prototypes"
> 
> Janusz Krzysztofik (5):
>   drm/i915: Rename "_load"/"_unload" to match PCI entry points
>   drm/i915: Replace "_load" with "_probe" consequently
>   drm/i915: Propagate "_release" function name suffix down
>   drm/i915: Propagate "_remove" function name suffix down
>   drm/i915: Propagate "_probe" function name suffix down

I'm happy with the chosen names and my main concern is for improving
consistency for ease of discoverability, so

Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>

A few of the usual suspects should chime in as well...
-Chris
Joonas Lahtinen July 12, 2019, 7:42 a.m. UTC | #2
Quoting Chris Wilson (2019-07-11 10:40:02)
> Quoting Janusz Krzysztofik (2019-07-11 08:31:52)
> > Need for this was identified while working on split of driver unbind
> > path into _remove() and _release() parts.  Consistency in function
> > naming has been recognized as helpful when trying to work out which
> > phase the code is in.
> > 
> > v2: * early_probe pairs better with late_release (Chris),
> >     * exclude patch 6/6 "drm/i915: Rename "inject_load_failure" module
> >       parameter" for now, it requires updates on user (IGT) side
> >     * rebase on top of "drm/i915: Drop extern qualifiers from header
> >       function prototypes"
> > 
> > Janusz Krzysztofik (5):
> >   drm/i915: Rename "_load"/"_unload" to match PCI entry points
> >   drm/i915: Replace "_load" with "_probe" consequently
> >   drm/i915: Propagate "_release" function name suffix down
> >   drm/i915: Propagate "_remove" function name suffix down
> >   drm/i915: Propagate "_probe" function name suffix down
> 
> I'm happy with the chosen names and my main concern is for improving
> consistency for ease of discoverability, so

Definitely a change for the better. Found one typo, otherwise all good
to go.

Regards, Joonas