mbox series

[v2,0/2] drm/i915: Conclude load -> probe naming convention switch

Message ID 20191001143738.16573-1-janusz.krzysztofik@linux.intel.com (mailing list archive)
Headers show
Series drm/i915: Conclude load -> probe naming convention switch | expand

Message

Janusz Krzysztofik Oct. 1, 2019, 2:37 p.m. UTC
Test-with: <20191001142724.16472-2-janusz.krzysztofik@linux.intel.com>

The purpose is:
* to fix incompatible names of new functions introduced meanwhile,
* to complete postponed rename of module parameter.

v2: * drop unnecessary statement about custom user applications from
      commit message of 2/2, there are no such (Chris),
    * add R-b (thanks Chris),
    * use correct message ID of (also rerolled) IGT counterpart to be
      tested with.

Janusz Krzysztofik (2):
  drm/i915: Fix i915_inject_load_error() name to read *_probe_*
  drm/i915: Rename "inject_load_failure" module parameter

 .../gpu/drm/i915/gt/uc/intel_guc_submission.c |  2 +-
 drivers/gpu/drm/i915/gt/uc/intel_huc.c        |  4 ++--
 drivers/gpu/drm/i915/gt/uc/intel_uc.c         |  6 +++---
 drivers/gpu/drm/i915/gt/uc/intel_uc_fw.c      | 20 ++++++++++---------
 drivers/gpu/drm/i915/i915_gem.c               |  4 ++--
 drivers/gpu/drm/i915/i915_params.c            |  2 +-
 drivers/gpu/drm/i915/i915_params.h            |  2 +-
 drivers/gpu/drm/i915/i915_utils.c             | 14 ++++++-------
 drivers/gpu/drm/i915/i915_utils.h             | 12 +++++------
 9 files changed, 34 insertions(+), 32 deletions(-)

Comments

Janusz Krzysztofik Oct. 2, 2019, 8:58 a.m. UTC | #1
On Tuesday, October 1, 2019 9:32:32 PM CEST Patchwork wrote:
> == Series Details ==
> 
> Series: drm/i915: Conclude load -> probe naming convention switch
> URL   : https://patchwork.freedesktop.org/series/67454/
> State : failure
> 
> == Summary ==
> 
> CI Bug Log - changes from CI_DRM_6986 -> Patchwork_14613
> ====================================================
> 
> Summary
> -------
> 
>   **FAILURE**
> 
>   Serious unknown changes coming with Patchwork_14613 absolutely need to be
>   verified manually.
>   
>   If you think the reported changes have nothing to do with the changes
>   introduced in Patchwork_14613, please notify your bug team to allow them
>   to document this new failure mode, which will reduce false positives in CI.

That's the case, I believe.  The possible regression indicated below seems to 
have nothing to do with the change.  The only subtest which does have 
something to do with it - i915_module_load --run-subtest reload-with-fault-
injection - succeeded, when tested with the corresponding IGT change, on all 
machines where it also succeeded without the changes.

Thanks,
Janusz

> 
>   External URL: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/index.html
> 
> Possible new issues
> -------------------
> 
>   Here are the unknown changes that may have been introduced in Patchwork_14613:
> 
> ### IGT changes ###
> 
> #### Possible regressions ####
> 
>   * igt@i915_selftest@live_gem_contexts:
>     - fi-whl-u:           [PASS][1] -> [INCOMPLETE][2]
>    [1]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-whl-u/igt@i915_selftest@live_gem_contexts.html
>    [2]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-whl-u/igt@i915_selftest@live_gem_contexts.html
> 
>   
> Known issues
> ------------
> 
>   Here are the changes found in Patchwork_14613 that come from known issues:
> 
> ### IGT changes ###
> 
> #### Issues hit ####
> 
>   * igt@kms_frontbuffer_tracking@basic:
>     - fi-hsw-peppy:       [PASS][3] -> [DMESG-WARN][4] ([fdo#102614])
>    [3]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-hsw-peppy/igt@kms_frontbuffer_tracking@basic.html
>    [4]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-hsw-peppy/igt@kms_frontbuffer_tracking@basic.html
> 
>   * igt@prime_self_import@basic-with_fd_dup:
>     - fi-icl-u3:          [PASS][5] -> [DMESG-WARN][6] ([fdo#107724]) +3 similar issues
>    [5]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-icl-u3/igt@prime_self_import@basic-with_fd_dup.html
>    [6]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-icl-u3/igt@prime_self_import@basic-with_fd_dup.html
> 
>   
> #### Possible fixes ####
> 
>   * igt@gem_exec_suspend@basic-s3:
>     - fi-blb-e6850:       [INCOMPLETE][7] ([fdo#107718]) -> [PASS][8]
>    [7]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-blb-e6850/igt@gem_exec_suspend@basic-s3.html
>    [8]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-blb-e6850/igt@gem_exec_suspend@basic-s3.html
> 
>   * igt@gem_linear_blits@basic:
>     - fi-icl-u3:          [DMESG-WARN][9] ([fdo#107724]) -> [PASS][10]
>    [9]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-icl-u3/igt@gem_linear_blits@basic.html
>    [10]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-icl-u3/igt@gem_linear_blits@basic.html
> 
>   * igt@i915_module_load@reload:
>     - fi-icl-u3:          [DMESG-WARN][11] ([fdo#107724] / [fdo#111214]) -> [PASS][12]
>    [11]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-icl-u3/igt@i915_module_load@reload.html
>    [12]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-icl-u3/igt@i915_module_load@reload.html
> 
>   * igt@kms_chamelium@hdmi-hpd-fast:
>     - fi-kbl-7500u:       [FAIL][13] ([fdo#111407]) -> [PASS][14]
>    [13]: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6986/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html
>    [14]: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html
> 
>   
>   {name}: This element is suppressed. This means it is ignored when computing
>           the status of the difference (SUCCESS, WARNING, or FAILURE).
> 
>   [fdo#102614]: https://bugs.freedesktop.org/show_bug.cgi?id=102614
>   [fdo#107718]: https://bugs.freedesktop.org/show_bug.cgi?id=107718
>   [fdo#107724]: https://bugs.freedesktop.org/show_bug.cgi?id=107724
>   [fdo#111214]: https://bugs.freedesktop.org/show_bug.cgi?id=111214
>   [fdo#111407]: https://bugs.freedesktop.org/show_bug.cgi?id=111407
>   [fdo#111600]: https://bugs.freedesktop.org/show_bug.cgi?id=111600
>   [fdo#111647]: https://bugs.freedesktop.org/show_bug.cgi?id=111647
> 
> 
> Participating hosts (54 -> 46)
> ------------------------------
> 
>   Missing    (8): fi-ilk-m540 fi-cml-h fi-hsw-4200u fi-byt-squawks fi-bsw-cyan fi-icl-y fi-byt-clapper fi-bdw-samus 
> 
> 
> Build changes
> -------------
> 
>   * CI: CI-20190529 -> None
>   * IGT: IGT_5208 -> IGTPW_3522
>   * Linux: CI_DRM_6986 -> Patchwork_14613
> 
>   CI-20190529: 20190529
>   CI_DRM_6986: 9300459553e8c1032f10ec1953e1a375a99aba13 @ git://anongit.freedesktop.org/gfx-ci/linux
>   IGTPW_3522: https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3522/index.html
>   IGT_5208: c0131b4f132acf287d9d05b0f5078003d3159e1c @ git://anongit.freedesktop.org/xorg/app/intel-gpu-tools
>   Patchwork_14613: 99ddd1e63a9f12c5c4174784f31c05e4214c0fe2 @ git://anongit.freedesktop.org/gfx-ci/linux
> 
> 
> == Linux commits ==
> 
> 99ddd1e63a9f drm/i915: Rename "inject_load_failure" module parameter
> f23ba0cec202 drm/i915: Fix i915_inject_load_error() name to read *_probe_*
> 
> == Logs ==
> 
> For more details see: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14613/index.html
>
Janusz Krzysztofik Oct. 2, 2019, 9:14 a.m. UTC | #2
On Tuesday, October 1, 2019 9:08:48 PM CEST Patchwork wrote:
> == Series Details ==
> 
> Series: drm/i915: Conclude load -> probe naming convention switch
> URL   : https://patchwork.freedesktop.org/series/67454/
> State : warning
> 
> == Summary ==
> 
> $ dim checkpatch origin/drm-tip
> f23ba0cec202 drm/i915: Fix i915_inject_load_error() name to read *_probe_*
> -:11: ERROR:GIT_COMMIT_ID: Please use git commit description style 'commit <12+ chars of sha1> ("<title line>")' - ie: 'commit f2db53f14d3d ("drm/i915: Replace "_load" with "_probe" consequently")'
> #11: 
> established by commit f2db53f14d3d ("drm/i915: Replace "_load" with

False positive, unless it is illegal to use double quotes in commit titles, 
otherwise current convention of quoting commit titles with ("...") may result 
in nested double quotes, not handled correctly by checkpatch.

> total: 1 errors, 0 warnings, 0 checks, 158 lines checked
> 99ddd1e63a9f drm/i915: Rename "inject_load_failure" module parameter
> -:9: ERROR:GIT_COMMIT_ID: Please use git commit description style 'commit <12+ chars of sha1> ("<title line>")' - ie: 'Commit f2db53f14d3d ("drm/i915: Replace "_load" with "_probe" consequently")'
> #9: 
> Commit f2db53f14d3d ("drm/i915: Replace "_load" with "_probe"

ditto

> -:34: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis
> #34: FILE: drivers/gpu/drm/i915/i915_params.c:169:
> +i915_param_named_unsafe(inject_probe_failure, uint, 0400,
>  	"Force an error after a number of failure check points (0:disabled (default), N:force failure at the Nth failure check point)");

Quoting Chris [1]: 
"This is one where we've considered the merits of not rigorously applying
checkpatch.pl and adopted a different convention."

Thanks,
Janusz

[1] https://lists.freedesktop.org/archives/intel-gfx/2019-July/205030.html

> 
> total: 1 errors, 0 warnings, 1 checks, 43 lines checked
> 
>