mbox series

[00/17] drm/i915/ddi: Fix/simplify port enabling/disabling

Message ID 20250129200221.2508101-1-imre.deak@intel.com (mailing list archive)
Headers show
Series drm/i915/ddi: Fix/simplify port enabling/disabling | expand

Message

Imre Deak Jan. 29, 2025, 8:02 p.m. UTC
This patchset fixes two issues (in patch 2 and 4) and simplifies a few
other things in the DDI port enabling/disabling sequences. I noticed
these while thinking about a way to enable/disable ports as part of
the HW readout/sanitization, for which this patchset is also a
preparation.

Imre Deak (17):
  drm/i915/dsi: Use TRANS_DDI_FUNC_CTL's own port width macro
  drm/i915/ddi: Fix HDMI port width programming in DDI_BUF_CTL
  drm/i915/ddi: Make all the PORT_WIDTH macros work the same way
  drm/i915/ddi: Set missing TC DP PHY lane stagger delay in DDI_BUF_CTL
  drm/i915/ddi: Simplify the port enabling via DDI_BUF_CTL
  drm/i915/ddi: Simplify the port disabling via DDI_BUF_CTL
  drm/i915/ddi: Simplify waiting for a port to idle via DDI_BUF_CTL
  drm/i915/ddi: Move platform checks within
    mtl_ddi_enable/disable_d2d_link()
  drm/i915/ddi: Unify the platform specific functions disabling a port
  drm/i915/ddi: Add a helper to enable a port
  drm/i915/ddi: Sanitize DDI_BUF_CTL register definitions
  drm/i915/ddi: Configure/enable a port in DDI_BUF_CTL via
    read-modify-write
  drm/i915/ddi: Factor out a helper to get DDI_BUF_CTL's config value
  drm/i915/ddi: Reuse helper to compute the HDMI DDI_BUF_CTL config
  drm/i915/ddi: Reuse helper to compute the HDMI PORT_BUF_CTL1 config
  drm/i915/ddi: Move platform/encoder checks within
    adlp_tbt_to_dp_alt_switch_wa()
  drm/i915/ddi: Unify the platform specific functions enabling a port

 drivers/gpu/drm/i915/display/icl_dsi.c        |   4 +-
 .../gpu/drm/i915/display/intel_cx0_phy_regs.h |   3 +-
 drivers/gpu/drm/i915/display/intel_ddi.c      | 378 +++++++-----------
 drivers/gpu/drm/i915/i915_reg.h               |  25 +-
 4 files changed, 169 insertions(+), 241 deletions(-)