diff mbox

configure: Use proper variables set by PKG_CHECK_MODULES

Message ID 1383938099-7218-1-git-send-email-remi@gentoo.org (mailing list archive)
State New, archived
Headers show

Commit Message

Rémi Cardona Nov. 8, 2013, 7:14 p.m. UTC
$DRI_CFLAGS does not actually exist. The PKG_CHECK_MODULES call creates
a $DRI1_CFLAGS variable instead. This doesn't break often because
"recent" versions of xorg-server.pc indirectly depend on xf86driproto.pc
thus bringing in the required CFLAGS through $XORG_CFLAGS.

Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=490342
Signed-off-by: Rémi Cardona <remi@gentoo.org>
---
 configure.ac | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Chris Wilson Nov. 10, 2013, 11:36 a.m. UTC | #1
On Fri, Nov 08, 2013 at 08:14:59PM +0100, Rémi Cardona wrote:
> $DRI_CFLAGS does not actually exist. The PKG_CHECK_MODULES call creates
> a $DRI1_CFLAGS variable instead. This doesn't break often because
> "recent" versions of xorg-server.pc indirectly depend on xf86driproto.pc
> thus bringing in the required CFLAGS through $XORG_CFLAGS.
> 
> Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=490342
> Signed-off-by: Rémi Cardona <remi@gentoo.org>

Thanks, pushed.
-Chris
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index eb20807..539ad9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,8 +396,8 @@  if test "x$enable_dri" != "xno" -a "x$UMS" = "xyes"; then
 	PKG_CHECK_MODULES(DRI1, [xf86driproto], [DRI1="yes"], [DRI1="no"])
         save_CFLAGS="$CFLAGS"
         save_CPPFLAGS="$CPPFLAGS"
-        CFLAGS="$CFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
-        CPPFLAGS="$CPPFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
+        CFLAGS="$CFLAGS $XORG_CFLAGS $DRI1_CFLAGS $DRM_CFLAGS"
+        CPPFLAGS="$CPPFLAGS $XORG_CFLAGS $DRI1_CFLAGS $DRM_CFLAGS"
         AC_CHECK_HEADERS([dri.h sarea.h dristruct.h], [DRI1="yes"], [DRI1="no"],
                 [/* for dri.h */
                  #include <xf86str.h>
@@ -440,7 +440,7 @@  if test "x$enable_dri" != "xno"; then
 	AC_DEFINE_DIR(DRI_DRIVER_PATH, dridriverdir, [Default DRI2 driver path])
 	if test "x$DRI2" != "xno"; then
 		save_CFLAGS=$CFLAGS
-		CFLAGS="$XORG_CFLAGS $DRM_CFLAGS $DRI_CFLAGS $DRI2_CFLAGS"
+		CFLAGS="$XORG_CFLAGS $DRM_CFLAGS $DRI1_CFLAGS $DRI2_CFLAGS"
 		AC_CHECK_HEADERS([dri2.h], DRI2="yes", DRI2="no", [
 #include <dixstruct.h>
 #include <drm.h>