Message ID | 1402673891-14618-8-git-send-email-oscar.mateo@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Fri, Jun 13, 2014 at 04:37:25PM +0100, oscar.mateo@intel.com wrote: > From: Oscar Mateo <oscar.mateo@intel.com> > > Some legacy HW context code assumptions don't make sense for this new > submission method, so we will place this stuff in a separate file. > > Note for reviewers: I've carefully considered the best name for this file > and this was my best option (other possibilities were intel_lr_context.c > or intel_execlist.c). I am open to a certain bikeshedding on this matter, > anyway. Regarding splitting execlists and logical ring contexts, it is > probably not worth it for the moment. > > v2: Change to intel_lrc.c > > Signed-off-by: Oscar Mateo <oscar.mateo@intel.com> > --- > drivers/gpu/drm/i915/Makefile | 1 + > drivers/gpu/drm/i915/intel_lrc.c | 42 ++++++++++++++++++++++++++++++++++++++++ > 2 files changed, 43 insertions(+) > create mode 100644 drivers/gpu/drm/i915/intel_lrc.c > > diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile > index cad1683..9fee2a0 100644 > --- a/drivers/gpu/drm/i915/Makefile > +++ b/drivers/gpu/drm/i915/Makefile > @@ -31,6 +31,7 @@ i915-y += i915_cmd_parser.o \ > i915_gpu_error.o \ > i915_irq.o \ > i915_trace_points.o \ > + intel_lrc.o \ > intel_ringbuffer.o \ > intel_uncore.o > > diff --git a/drivers/gpu/drm/i915/intel_lrc.c b/drivers/gpu/drm/i915/intel_lrc.c > new file mode 100644 > index 0000000..49bb6fc > --- /dev/null > +++ b/drivers/gpu/drm/i915/intel_lrc.c > @@ -0,0 +1,42 @@ > +/* > + * Copyright © 2014 Intel Corporation > + * > + * Permission is hereby granted, free of charge, to any person obtaining a > + * copy of this software and associated documentation files (the "Software"), > + * to deal in the Software without restriction, including without limitation > + * the rights to use, copy, modify, merge, publish, distribute, sublicense, > + * and/or sell copies of the Software, and to permit persons to whom the > + * Software is furnished to do so, subject to the following conditions: > + * > + * The above copyright notice and this permission notice (including the next > + * paragraph) shall be included in all copies or substantial portions of the > + * Software. > + * > + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR > + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, > + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL > + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER > + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING > + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS > + * IN THE SOFTWARE. > + * > + * Authors: > + * Ben Widawsky <ben@bwidawsk.net> > + * Michel Thierry <michel.thierry@intel.com> > + * Thomas Daniel <thomas.daniel@intel.com> > + * Oscar Mateo <oscar.mateo@intel.com> > + * > + */ > + > +/* Overview comments should be kerneldoc DOC: sections and pulled into our driver doc. Brad knows how to do this, see i915_cmd_parser.c. Just in case a patch later on doesn't do this ;-) -Daniel > + * GEN8 brings an expansion of the HW contexts: "Logical Ring Contexts". > + * These expanded contexts enable a number of new abilities, especially > + * "Execlists" (also implemented in this file). > + * > + * Execlists are the new method by which, on gen8+ hardware, workloads are > + * submitted for execution (as opposed to the legacy, ringbuffer-based, method). > + */ > + > +#include <drm/drmP.h> > +#include <drm/i915_drm.h> > +#include "i915_drv.h" > -- > 1.9.0 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
> -----Original Message----- > From: Daniel Vetter [mailto:daniel.vetter@ffwll.ch] On Behalf Of Daniel > Vetter > Sent: Wednesday, June 18, 2014 9:17 PM > To: Mateo Lozano, Oscar > Cc: intel-gfx@lists.freedesktop.org > Subject: Re: [Intel-gfx] [PATCH 07/53] drm/i915/bdw: New file for Logical > Ring Contexts and Execlists > > On Fri, Jun 13, 2014 at 04:37:25PM +0100, oscar.mateo@intel.com wrote: > > From: Oscar Mateo <oscar.mateo@intel.com> > > > > Some legacy HW context code assumptions don't make sense for this new > > submission method, so we will place this stuff in a separate file. > > > > Note for reviewers: I've carefully considered the best name for this > > file and this was my best option (other possibilities were > > intel_lr_context.c or intel_execlist.c). I am open to a certain > > bikeshedding on this matter, anyway. Regarding splitting execlists and > > logical ring contexts, it is probably not worth it for the moment. > > > > v2: Change to intel_lrc.c > > > > Signed-off-by: Oscar Mateo <oscar.mateo@intel.com> > > --- > > drivers/gpu/drm/i915/Makefile | 1 + > > drivers/gpu/drm/i915/intel_lrc.c | 42 > > ++++++++++++++++++++++++++++++++++++++++ > > 2 files changed, 43 insertions(+) > > create mode 100644 drivers/gpu/drm/i915/intel_lrc.c > > > > diff --git a/drivers/gpu/drm/i915/Makefile > > b/drivers/gpu/drm/i915/Makefile index cad1683..9fee2a0 100644 > > --- a/drivers/gpu/drm/i915/Makefile > > +++ b/drivers/gpu/drm/i915/Makefile > > @@ -31,6 +31,7 @@ i915-y += i915_cmd_parser.o \ > > i915_gpu_error.o \ > > i915_irq.o \ > > i915_trace_points.o \ > > + intel_lrc.o \ > > intel_ringbuffer.o \ > > intel_uncore.o > > > > diff --git a/drivers/gpu/drm/i915/intel_lrc.c > > b/drivers/gpu/drm/i915/intel_lrc.c > > new file mode 100644 > > index 0000000..49bb6fc > > --- /dev/null > > +++ b/drivers/gpu/drm/i915/intel_lrc.c > > @@ -0,0 +1,42 @@ > > +/* > > + * Copyright © 2014 Intel Corporation > > + * > > + * Permission is hereby granted, free of charge, to any person > > +obtaining a > > + * copy of this software and associated documentation files (the > > +"Software"), > > + * to deal in the Software without restriction, including without > > +limitation > > + * the rights to use, copy, modify, merge, publish, distribute, > > +sublicense, > > + * and/or sell copies of the Software, and to permit persons to whom > > +the > > + * Software is furnished to do so, subject to the following conditions: > > + * > > + * The above copyright notice and this permission notice (including > > +the next > > + * paragraph) shall be included in all copies or substantial portions > > +of the > > + * Software. > > + * > > + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY > KIND, > > +EXPRESS OR > > + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF > > +MERCHANTABILITY, > > + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN > NO EVENT > > +SHALL > > + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, > DAMAGES > > +OR OTHER > > + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR > OTHERWISE, > > +ARISING > > + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE > OR > > +OTHER DEALINGS > > + * IN THE SOFTWARE. > > + * > > + * Authors: > > + * Ben Widawsky <ben@bwidawsk.net> > > + * Michel Thierry <michel.thierry@intel.com> > > + * Thomas Daniel <thomas.daniel@intel.com> > > + * Oscar Mateo <oscar.mateo@intel.com> > > + * > > + */ > > + > > +/* > > Overview comments should be kerneldoc DOC: sections and pulled into our > driver doc. Brad knows how to do this, see i915_cmd_parser.c. Just in case a > patch later on doesn't do this ;-) -Daniel The DOC: section is added in a later patch (at the end), but I forgot to integrate it into the DocBook. I´ll do it in the next version. -- Oscar
diff --git a/drivers/gpu/drm/i915/Makefile b/drivers/gpu/drm/i915/Makefile index cad1683..9fee2a0 100644 --- a/drivers/gpu/drm/i915/Makefile +++ b/drivers/gpu/drm/i915/Makefile @@ -31,6 +31,7 @@ i915-y += i915_cmd_parser.o \ i915_gpu_error.o \ i915_irq.o \ i915_trace_points.o \ + intel_lrc.o \ intel_ringbuffer.o \ intel_uncore.o diff --git a/drivers/gpu/drm/i915/intel_lrc.c b/drivers/gpu/drm/i915/intel_lrc.c new file mode 100644 index 0000000..49bb6fc --- /dev/null +++ b/drivers/gpu/drm/i915/intel_lrc.c @@ -0,0 +1,42 @@ +/* + * Copyright © 2014 Intel Corporation + * + * Permission is hereby granted, free of charge, to any person obtaining a + * copy of this software and associated documentation files (the "Software"), + * to deal in the Software without restriction, including without limitation + * the rights to use, copy, modify, merge, publish, distribute, sublicense, + * and/or sell copies of the Software, and to permit persons to whom the + * Software is furnished to do so, subject to the following conditions: + * + * The above copyright notice and this permission notice (including the next + * paragraph) shall be included in all copies or substantial portions of the + * Software. + * + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS + * IN THE SOFTWARE. + * + * Authors: + * Ben Widawsky <ben@bwidawsk.net> + * Michel Thierry <michel.thierry@intel.com> + * Thomas Daniel <thomas.daniel@intel.com> + * Oscar Mateo <oscar.mateo@intel.com> + * + */ + +/* + * GEN8 brings an expansion of the HW contexts: "Logical Ring Contexts". + * These expanded contexts enable a number of new abilities, especially + * "Execlists" (also implemented in this file). + * + * Execlists are the new method by which, on gen8+ hardware, workloads are + * submitted for execution (as opposed to the legacy, ringbuffer-based, method). + */ + +#include <drm/drmP.h> +#include <drm/i915_drm.h> +#include "i915_drv.h"