diff mbox series

test/kms_content_protection: Use generic debugfs name for HDCP caps

Message ID 20190923182325.24049-1-Bhawanpreet.Lakha@amd.com (mailing list archive)
State New, archived
Headers show
Series test/kms_content_protection: Use generic debugfs name for HDCP caps | expand

Commit Message

Bhawanpreet Lakha Sept. 23, 2019, 6:23 p.m. UTC
Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"

The content protection tests only start if this debugfs entry exists.
Since the name is specific to intel driver these tests cannot be used with
other drivers.

Remove "i915" so the debugfs name is generic.

Signed-off-by: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
---
 tests/kms_content_protection.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Petri Latvala Sept. 24, 2019, 9:54 a.m. UTC | #1
On Mon, Sep 23, 2019 at 02:23:25PM -0400, Bhawanpreet Lakha wrote:
> Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"
> 
> The content protection tests only start if this debugfs entry exists.
> Since the name is specific to intel driver these tests cannot be used with
> other drivers.
> 
> Remove "i915" so the debugfs name is generic.

I don't see any drivers currently using the name
"hdcp_sink_capability". Is the content of the file in other drivers
the same as i915's?

And is there a plan to rename i915's debugfs filename to
hdcp_sink_capability? Ram?

Agreed, for a DRIVER_ANY-using test generic names are preferrable, but
this needs some kind of a transition plan. If i915's filename is
staying as is, both names need to be tried.
Bhawanpreet Lakha Sept. 24, 2019, 2:41 p.m. UTC | #2
We have used the tests for our hdcp implementation. But because of the 
name we can't use it as is.


Bhawan

On 2019-09-24 5:54 a.m., Petri Latvala wrote:
> On Mon, Sep 23, 2019 at 02:23:25PM -0400, Bhawanpreet Lakha wrote:
>> Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"
>>
>> The content protection tests only start if this debugfs entry exists.
>> Since the name is specific to intel driver these tests cannot be used with
>> other drivers.
>>
>> Remove "i915" so the debugfs name is generic.
> I don't see any drivers currently using the name
> "hdcp_sink_capability". Is the content of the file in other drivers
> the same as i915's?
>
> And is there a plan to rename i915's debugfs filename to
> hdcp_sink_capability? Ram?
>
> Agreed, for a DRIVER_ANY-using test generic names are preferrable, but
> this needs some kind of a transition plan. If i915's filename is
> staying as is, both names need to be tried.
>
>
Ramalingam C Sept. 24, 2019, 3:41 p.m. UTC | #3
On 2019-09-24 at 12:54:54 +0300, Petri Latvala wrote:
> On Mon, Sep 23, 2019 at 02:23:25PM -0400, Bhawanpreet Lakha wrote:
> > Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"
> > 
> > The content protection tests only start if this debugfs entry exists.
> > Since the name is specific to intel driver these tests cannot be used with
> > other drivers.
> > 
> > Remove "i915" so the debugfs name is generic.
> 
> I don't see any drivers currently using the name
> "hdcp_sink_capability". Is the content of the file in other drivers
> the same as i915's?
> 
> And is there a plan to rename i915's debugfs filename to
> hdcp_sink_capability? Ram?
> 
> Agreed, for a DRIVER_ANY-using test generic names are preferrable, but
> this needs some kind of a transition plan. If i915's filename is
> staying as is, both names need to be tried.
This IGT test change has to wait untill we have the
i915_hdcp_sink_capabilities renamed, if at all we rename.

Else based on drm_device we could decide the debugfs file and read it.

Daniel,
Considering all other debugfs are prefixed with i915, could we rename this
debugfs as "hdcp_sink_capabilities" instead?

-Ram
> 
> 
> -- 
> Petri Latvala
diff mbox series

Patch

diff --git a/tests/kms_content_protection.c b/tests/kms_content_protection.c
index e676b60b..a105c5de 100644
--- a/tests/kms_content_protection.c
+++ b/tests/kms_content_protection.c
@@ -554,7 +554,7 @@  static bool sink_hdcp_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);
@@ -571,7 +571,7 @@  static bool sink_hdcp2_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);