diff mbox series

[v2,01/41] drm/tests: Order Kunit tests in Makefile

Message ID 20220728-rpi-analog-tv-properties-v2-1-459522d653a7@cerno.tech (mailing list archive)
State New, archived
Headers show
Series drm: Analog TV Improvements | expand

Commit Message

Maxime Ripard Aug. 29, 2022, 1:11 p.m. UTC
Since we've recently added a ton of tests, the list starts to be a bit
of a mess and creates unneeded conflicts.

Let's order it alphabetically.

Signed-off-by: Maxime Ripard <maxime@cerno.tech>

Comments

Noralf Trønnes Aug. 29, 2022, 6:46 p.m. UTC | #1
Den 29.08.2022 15.11, skrev Maxime Ripard:
> Since we've recently added a ton of tests, the list starts to be a bit
> 
> of a mess and creates unneeded conflicts.
> 
> 
> 
> Let's order it alphabetically.
> 
> 
> 
> Signed-off-by: Maxime Ripard <maxime@cerno.tech>
> 
> 
> 

Something has gone wrong with this patchset, there are double line endings.

I looked at the patchwork version and it look all right there so I
figured it might have fixed up the patches, but it failed:

git apply -v --check
/home/pi/tinydrm.gud-gadget/workdirs/tv_norm_gadget/500003.patch
Checking patch drivers/gpu/drm/tests/Makefile...
error: while searching for:
# SPDX-License-Identifier: GPL-2.0?
?
obj-$(CONFIG_DRM_KUNIT_TEST) += drm_format_helper_test.o
drm_damage_helper_test.o \?
        drm_cmdline_parser_test.o drm_rect_test.o drm_format_test.o
drm_plane_helper_test.o \?
        drm_dp_mst_helper_test.o drm_framebuffer_test.o drm_buddy_test.o
drm_mm_test.o?

error: patch failed: drivers/gpu/drm/tests/Makefile:1
error: drivers/gpu/drm/tests/Makefile: patch does not apply

ERROR: Failed check apply patch

pi@build-server:~/tinydrm.gud-gadget$ file
workdirs/tv_norm_gadget/500003.patch
workdirs/tv_norm_gadget/500003.patch: unified diff output, ASCII text,
with CRLF, LF line terminators

Noralf.

> diff --git a/drivers/gpu/drm/tests/Makefile b/drivers/gpu/drm/tests/Makefile
> 
> index 91b70f7d2769..2d9f49b62ecb 100644
> 
> --- a/drivers/gpu/drm/tests/Makefile
> 
> +++ b/drivers/gpu/drm/tests/Makefile
> 
> @@ -1,5 +1,13 @@
> 
>  # SPDX-License-Identifier: GPL-2.0
> 
>  
> 
> -obj-$(CONFIG_DRM_KUNIT_TEST) += drm_format_helper_test.o drm_damage_helper_test.o \
> 
> -	drm_cmdline_parser_test.o drm_rect_test.o drm_format_test.o drm_plane_helper_test.o \
> 
> -	drm_dp_mst_helper_test.o drm_framebuffer_test.o drm_buddy_test.o drm_mm_test.o
> 
> +obj-$(CONFIG_DRM_KUNIT_TEST) += \
> 
> +	drm_buddy_test.o \
> 
> +	drm_cmdline_parser_test.o \
> 
> +	drm_damage_helper_test.o \
> 
> +	drm_dp_mst_helper_test.o \
> 
> +	drm_format_helper_test.o \
> 
> +	drm_format_test.o \
> 
> +	drm_framebuffer_test.o \
> 
> +	drm_mm_test.o \
> 
> +	drm_plane_helper_test.o \
> 
> +	drm_rect_test.o
> 
> 
>
Maxime Ripard Aug. 30, 2022, 8:30 a.m. UTC | #2
Hi Konstantin,

On Mon, Aug 29, 2022 at 03:02:42PM -0400, Konstantin Ryabitsev wrote:
> On Mon, Aug 29, 2022 at 08:46:42PM +0200, Noralf Trønnes wrote:
> > Something has gone wrong with this patchset, there are double line endings.
> 
> I noticed this, too, and I think the reason is because these patches were
> generated with "b4 send -o", but actually sent using git-send-email. It's not
> a use-case I've considered (or tested) and the breakage is because when b4
> generates patches with "-o", they are written with CRLF line endings, which is
> not something git-send-email expects.

You're right

> Maxime, any reason you went this direction instead of just letting b4 send
> these patches directly?

For some reason, b4 send doesn't work for my setup and I haven't had the
time to look into why and let you know.

Whenever I used b4 send (on this series for example) I get:

$ b4 send
Converted the branch to 41 patches
Populating the To: and Cc: fields with automatically collected addresses
Invoking get_maintainer.pl for To: addresses
Invoking get_maintainer.pl for Cc: addresses
Will send the following messages:
---
To: David Airlie <airlied@linux.ie>
    Daniel Vetter <daniel@ffwll.ch>
    Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
    Maxime Ripard <mripard@kernel.org>
    Thomas Zimmermann <tzimmermann@suse.de>
    Noralf Trønnes <noralf@tronnes.org>
    Emma Anholt <emma@anholt.net>
    Ben Skeggs <bskeggs@redhat.com>
    Karol Herbst <kherbst@redhat.com>
    Lyude Paul <lyude@redhat.com>
    Jani Nikula <jani.nikula@linux.intel.com>
    Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
    Rodrigo Vivi <rodrigo.vivi@intel.com>
    Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
    Chen-Yu Tsai <wens@csie.org>
    Jernej Skrabec <jernej.skrabec@gmail.com>
    Samuel Holland <samuel@sholland.org>
    Philipp Zabel <p.zabel@pengutronix.de>
Cc: dri-devel@lists.freedesktop.org
    linux-kernel@vger.kernel.org
    nouveau@lists.freedesktop.org
    intel-gfx@lists.freedesktop.org
    linux-arm-kernel@lists.infradead.org
    linux-sunxi@lists.linux.dev
    Dom Cobley <dom@raspberrypi.com>
    Maxime Ripard <maxime@cerno.tech>
    Geert Uytterhoeven <geert@linux-m68k.org>
    Hans de Goede <hdegoede@redhat.com>
    Dave Stevenson <dave.stevenson@raspberrypi.com>
    Mateusz Kwiatkowski <kfyatek+publicgit@gmail.com>
    Phil Elwell <phil@raspberrypi.com>
---
  [PATCH v2 00/41] drm: Analog TV Improvements
  [PATCH v2 01/41] drm/tests: Order Kunit tests in Makefile
  [PATCH v2 02/41] drm/tests: Add Kunit Helpers
  [PATCH v2 03/41] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity
  [PATCH v2 04/41] drm/connector: Rename subconnector state variable
  [PATCH v2 05/41] drm/atomic: Add TV subconnector property to get/set_property
  [PATCH v2 06/41] drm/connector: Rename legacy TV property
  [PATCH v2 07/41] drm/connector: Only register TV mode property if present
  [PATCH v2 08/41] drm/connector: Rename drm_mode_create_tv_properties
  [PATCH v2 09/41] drm/connector: Add TV standard property
  [PATCH v2 10/41] drm/modes: Add a function to generate analog display modes
  [PATCH v2 11/41] drm/modes: Only consider bpp and refresh before options
  [PATCH v2 12/41] drm/modes: parse_cmdline: Add support for named modes containing dashes
  [PATCH v2 13/41] drm/client: Add some tests for drm_connector_pick_cmdline_mode()
  [PATCH v2 14/41] drm/modes: Move named modes parsing to a separate function
  [PATCH v2 15/41] drm/modes: Switch to named mode descriptors
  [PATCH v2 16/41] drm/modes: Fill drm_cmdline mode from named modes
  [PATCH v2 17/41] drm/connector: Add pixel clock to cmdline mode
  [PATCH v2 18/41] drm/connector: Add a function to lookup a TV mode by its name
  [PATCH v2 19/41] drm/modes: Introduce the tv_mode property as a command-line option
  [PATCH v2 20/41] drm/modes: Properly generate a drm_display_mode from a named mode
  [PATCH v2 21/41] drm/modes: Introduce more named modes
  [PATCH v2 22/41] drm/atomic-helper: Add a TV properties reset helper
  [PATCH v2 23/41] drm/atomic-helper: Add an analog TV atomic_check implementation
  [PATCH v2 24/41] drm/vc4: vec: Remove empty mode_fixup
  [PATCH v2 25/41] drm/vc4: vec: Convert to atomic helpers
  [PATCH v2 26/41] drm/vc4: vec: Refactor VEC TV mode setting
  [PATCH v2 27/41] drm/vc4: vec: Remove redundant atomic_mode_set
  [PATCH v2 28/41] drm/vc4: vec: Fix timings for VEC modes
  [PATCH v2 29/41] drm/vc4: vec: Switch for common modes
  [PATCH v2 30/41] drm/vc4: vec: Fix definition of PAL-M mode
  [PATCH v2 31/41] drm/vc4: vec: Use TV Reset implementation
  [PATCH v2 32/41] drm/vc4: vec: Convert to the new TV mode property
  [PATCH v2 33/41] drm/vc4: vec: Add support for more analog TV standards
  [PATCH v2 34/41] drm/sun4i: tv: Remove unused mode_valid
  [PATCH v2 35/41] drm/sun4i: tv: Convert to atomic hooks
  [PATCH v2 36/41] drm/sun4i: tv: Merge mode_set into atomic_enable
  [PATCH v2 37/41] drm/sun4i: tv: Remove useless function
  [PATCH v2 38/41] drm/sun4i: tv: Remove useless destroy function
  [PATCH v2 39/41] drm/sun4i: tv: Rename error label
  [PATCH v2 40/41] drm/sun4i: tv: Add missing reset assertion
  [PATCH v2 41/41] drm/sun4i: tv: Convert to the new TV mode property
---
Press Enter to send or Ctrl-C to abort
  [PATCH v2 00/41] drm: Analog TV Improvements
  [PATCH v2 01/41] drm/tests: Order Kunit tests in Makefile
  [PATCH v2 02/41] drm/tests: Add Kunit Helpers
  [PATCH v2 03/41] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity
  [PATCH v2 04/41] drm/connector: Rename subconnector state variable
  [PATCH v2 05/41] drm/atomic: Add TV subconnector property to get/set_property
  [PATCH v2 06/41] drm/connector: Rename legacy TV property
  [PATCH v2 07/41] drm/connector: Only register TV mode property if present
  [PATCH v2 08/41] drm/connector: Rename drm_mode_create_tv_properties
  [PATCH v2 09/41] drm/connector: Add TV standard property
  [PATCH v2 10/41] drm/modes: Add a function to generate analog display modes
  [PATCH v2 11/41] drm/modes: Only consider bpp and refresh before options
  [PATCH v2 12/41] drm/modes: parse_cmdline: Add support for named modes containing dashes
  [PATCH v2 13/41] drm/client: Add some tests for drm_connector_pick_cmdline_mode()
  [PATCH v2 14/41] drm/modes: Move named modes parsing to a separate function
  [PATCH v2 15/41] drm/modes: Switch to named mode descriptors
  [PATCH v2 16/41] drm/modes: Fill drm_cmdline mode from named modes
  [PATCH v2 17/41] drm/connector: Add pixel clock to cmdline mode
  [PATCH v2 18/41] drm/connector: Add a function to lookup a TV mode by its name
  [PATCH v2 19/41] drm/modes: Introduce the tv_mode property as a command-line option
  [PATCH v2 20/41] drm/modes: Properly generate a drm_display_mode from a named mode
  [PATCH v2 21/41] drm/modes: Introduce more named modes
  [PATCH v2 22/41] drm/atomic-helper: Add a TV properties reset helper
  [PATCH v2 23/41] drm/atomic-helper: Add an analog TV atomic_check implementation
  [PATCH v2 24/41] drm/vc4: vec: Remove empty mode_fixup
  [PATCH v2 25/41] drm/vc4: vec: Convert to atomic helpers
  [PATCH v2 26/41] drm/vc4: vec: Refactor VEC TV mode setting
  [PATCH v2 27/41] drm/vc4: vec: Remove redundant atomic_mode_set
  [PATCH v2 28/41] drm/vc4: vec: Fix timings for VEC modes
  [PATCH v2 29/41] drm/vc4: vec: Switch for common modes
  [PATCH v2 30/41] drm/vc4: vec: Fix definition of PAL-M mode
  [PATCH v2 31/41] drm/vc4: vec: Use TV Reset implementation
  [PATCH v2 32/41] drm/vc4: vec: Convert to the new TV mode property
  [PATCH v2 33/41] drm/vc4: vec: Add support for more analog TV standards
  [PATCH v2 34/41] drm/sun4i: tv: Remove unused mode_valid
  [PATCH v2 35/41] drm/sun4i: tv: Convert to atomic hooks
  [PATCH v2 36/41] drm/sun4i: tv: Merge mode_set into atomic_enable
  [PATCH v2 37/41] drm/sun4i: tv: Remove useless function
  [PATCH v2 38/41] drm/sun4i: tv: Remove useless destroy function
  [PATCH v2 39/41] drm/sun4i: tv: Rename error label
  [PATCH v2 40/41] drm/sun4i: tv: Add missing reset assertion
  [PATCH v2 41/41] drm/sun4i: tv: Convert to the new TV mode property
Connecting to /home/max/.local/bin/msmtpq:0
Failed to configure the smtp connection:
[Errno -2] Name or service not known

msmtpq is basically a sendmail-like tool to queue the mails if the
machine is offline. It is setup in my git config as
sendemail.smtpserver.

git-send-email works just fine, but somehow b4 send fails. I think it's
due to cmd_send calling b4.get_smtp() and expecting to get some
credentials out of it?

Maxime
diff mbox series

Patch

diff --git a/drivers/gpu/drm/tests/Makefile b/drivers/gpu/drm/tests/Makefile
index 91b70f7d2769..2d9f49b62ecb 100644
--- a/drivers/gpu/drm/tests/Makefile
+++ b/drivers/gpu/drm/tests/Makefile
@@ -1,5 +1,13 @@ 
 # SPDX-License-Identifier: GPL-2.0
 
-obj-$(CONFIG_DRM_KUNIT_TEST) += drm_format_helper_test.o drm_damage_helper_test.o \
-	drm_cmdline_parser_test.o drm_rect_test.o drm_format_test.o drm_plane_helper_test.o \
-	drm_dp_mst_helper_test.o drm_framebuffer_test.o drm_buddy_test.o drm_mm_test.o
+obj-$(CONFIG_DRM_KUNIT_TEST) += \
+	drm_buddy_test.o \
+	drm_cmdline_parser_test.o \
+	drm_damage_helper_test.o \
+	drm_dp_mst_helper_test.o \
+	drm_format_helper_test.o \
+	drm_format_test.o \
+	drm_framebuffer_test.o \
+	drm_mm_test.o \
+	drm_plane_helper_test.o \
+	drm_rect_test.o