Message ID | 20231226195432.10891-2-rdunlap@infradead.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v2,1/4] drm/i915/gem: reconcile Excess struct member kernel-doc warnings | expand |
Hi Randy, ... > /** > * struct intel_gsc - graphics security controller > * > - * @gem_obj: scratch memory GSC operations > - * @intf : gsc interface > + * @intf : gsc interface > + * @intf.adev : MEI aux. device for this @intf > + * @intf.gem_obj : scratch memory GSC operations > + * @intf.irq : IRQ for this device (%-1 for no IRQ) > + * @intf.id : this interface's id number/index > */ I don't really like the tabs here and the space before the ':', which makes it a bit harder to read. Besides it doesn't look consistent with the rest of the documentation. Otherwise, looks good. Andi
Hi Andi, On 12/28/23 08:25, Andi Shyti wrote: > Hi Randy, > > ... > >> /** >> * struct intel_gsc - graphics security controller >> * >> - * @gem_obj: scratch memory GSC operations >> - * @intf : gsc interface >> + * @intf : gsc interface >> + * @intf.adev : MEI aux. device for this @intf >> + * @intf.gem_obj : scratch memory GSC operations >> + * @intf.irq : IRQ for this device (%-1 for no IRQ) >> + * @intf.id : this interface's id number/index >> */ > > I don't really like the tabs here and the space before the ':', > which makes it a bit harder to read. Besides it doesn't look > consistent with the rest of the documentation. > > Otherwise, looks good. Yes, one existing line had " : " and somehow I managed to use that on all of the new lines. Not good. I'll redo patch 2/4. Thanks.
diff -- a/drivers/gpu/drm/i915/gt/intel_gsc.h b/drivers/gpu/drm/i915/gt/intel_gsc.h --- a/drivers/gpu/drm/i915/gt/intel_gsc.h +++ b/drivers/gpu/drm/i915/gt/intel_gsc.h @@ -21,8 +21,11 @@ struct mei_aux_device; /** * struct intel_gsc - graphics security controller * - * @gem_obj: scratch memory GSC operations - * @intf : gsc interface + * @intf : gsc interface + * @intf.adev : MEI aux. device for this @intf + * @intf.gem_obj : scratch memory GSC operations + * @intf.irq : IRQ for this device (%-1 for no IRQ) + * @intf.id : this interface's id number/index */ struct intel_gsc { struct intel_gsc_intf {