diff mbox series

[1/3] io_uring/kbuf: use 'bl' directly rather than req->buf_list

Message ID 20240811013359.7112-2-axboe@kernel.dk (mailing list archive)
State New
Headers show
Series Misc cleanups and improvements | expand

Commit Message

Jens Axboe Aug. 11, 2024, 1:32 a.m. UTC
req->buf_list is assigned higher up and is safe to use as we remain
within a locked region, as is the 'bl' variable itself from which it
was assigned. To improve readability, use 'bl' directly rather than
get it from the io_kiocb, if we need to increment the head directly
in the buffer selection path. This makes it readily apparent that
it's the same io_buffer_list being used.

Signed-off-by: Jens Axboe <axboe@kernel.dk>
---
 io_uring/kbuf.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/io_uring/kbuf.c b/io_uring/kbuf.c
index c95dc1736dd9..c75b22d246ec 100644
--- a/io_uring/kbuf.c
+++ b/io_uring/kbuf.c
@@ -295,7 +295,7 @@  int io_buffers_select(struct io_kiocb *req, struct buf_sel_arg *arg,
 		 */
 		if (ret > 0) {
 			req->flags |= REQ_F_BL_NO_RECYCLE;
-			req->buf_list->head += ret;
+			bl->head += ret;
 		}
 	} else {
 		ret = io_provided_buffers_select(req, &arg->out_len, bl, arg->iovs);