mbox series

[v2,0/5] crypto: rsa-pkcs1pad fixes

Message ID 20220119001306.85355-1-ebiggers@kernel.org (mailing list archive)
Headers show
Series crypto: rsa-pkcs1pad fixes | expand

Message

Eric Biggers Jan. 19, 2022, 12:13 a.m. UTC
This series fixes some bugs in rsa-pkcs1pad.

Changed v1 => v2:
   - Added patch "crypto: rsa-pkcs1pad - only allow with rsa"
     (previously was a standalone patch)
   - Added patch "crypto: rsa-pkcs1pad - restore signature length check"

Eric Biggers (5):
  crypto: rsa-pkcs1pad - only allow with rsa
  crypto: rsa-pkcs1pad - correctly get hash from source scatterlist
  crypto: rsa-pkcs1pad - restore signature length check
  crypto: rsa-pkcs1pad - fix buffer overread in
    pkcs1pad_verify_complete()
  crypto: rsa-pkcs1pad - use clearer variable names

 crypto/rsa-pkcs1pad.c | 38 +++++++++++++++++++++++---------------
 1 file changed, 23 insertions(+), 15 deletions(-)

Comments

Herbert Xu Jan. 28, 2022, 6:26 a.m. UTC | #1
On Tue, Jan 18, 2022 at 04:13:01PM -0800, Eric Biggers wrote:
> This series fixes some bugs in rsa-pkcs1pad.
> 
> Changed v1 => v2:
>    - Added patch "crypto: rsa-pkcs1pad - only allow with rsa"
>      (previously was a standalone patch)
>    - Added patch "crypto: rsa-pkcs1pad - restore signature length check"
> 
> Eric Biggers (5):
>   crypto: rsa-pkcs1pad - only allow with rsa
>   crypto: rsa-pkcs1pad - correctly get hash from source scatterlist
>   crypto: rsa-pkcs1pad - restore signature length check
>   crypto: rsa-pkcs1pad - fix buffer overread in
>     pkcs1pad_verify_complete()
>   crypto: rsa-pkcs1pad - use clearer variable names
> 
>  crypto/rsa-pkcs1pad.c | 38 +++++++++++++++++++++++---------------
>  1 file changed, 23 insertions(+), 15 deletions(-)

All applied.  Thanks.