mbox series

[v3,0/8] vfio: Split the container code into a clean layer and dedicated file

Message ID 0-v3-297af71838d2+b9-vfio_container_split_jgg@nvidia.com (mailing list archive)
Headers show
Series vfio: Split the container code into a clean layer and dedicated file | expand

Message

Jason Gunthorpe Sept. 22, 2022, 7:20 p.m. UTC
This creates an isolated layer around the container FD code and everything
under it, including the VFIO iommu drivers. All this code is placed into
container.c, along with the "struct vfio_container" to compartmentalize
it.

Future patches will provide an iommufd based layer that gives the same API
as the container layer and choose which layer to go to based on how
userspace operates.

The patches continue to split up existing functions and finally the last
patch just moves every function that is a "container" function to the new
file and creates the global symbols to link them together.

Cross-file container functions are prefixed with vfio_container_* for
clarity.

The last patch can be defered and queued during the merge window to manage
conflicts. The earlier patches should be fine immediately conflicts wise.

This is the last big series I have to enable basic iommufd functionality.
As part of the iommufd series the entire container.c becomes conditionally
compiled:

https://github.com/jgunthorpe/linux/commits/vfio_iommufd

v3:
 - Rebase over the vfio struct device series
v2: https://lore.kernel.org/r/0-v2-d7744ee9cf4f+33d-vfio_container_split_jgg@nvidia.com
 - Rename s/vfio_container_detatch_group/vfio_group_detach_container/
          s/vfio_container_register_device/vfio_device_container_register/
          s/vfio_container_unregister_device/vfio_device_container_unregister/
 - Change argument order of vfio_container_attach_group()
 - Rebased onto merged patches
v1: https://lore.kernel.org/r/0-v1-a805b607f1fb+17b-vfio_container_split_jgg@nvidia.com

Signed-off-by: Jason Gunthorpe <jgg@nvidia.com>

Jason Gunthorpe (8):
  vfio: Add header guards and includes to drivers/vfio/vfio.h
  vfio: Rename __vfio_group_unset_container()
  vfio: Split the container logic into vfio_container_attach_group()
  vfio: Remove #ifdefs around CONFIG_VFIO_NOIOMMU
  vfio: Split out container code from the init/cleanup functions
  vfio: Rename vfio_ioctl_check_extension()
  vfio: Split the register_device ops call into functions
  vfio: Move container code into drivers/vfio/container.c

 drivers/vfio/Makefile    |   1 +
 drivers/vfio/container.c | 680 +++++++++++++++++++++++++++++++++++++
 drivers/vfio/vfio.h      |  56 ++++
 drivers/vfio/vfio_main.c | 708 ++-------------------------------------
 4 files changed, 765 insertions(+), 680 deletions(-)
 create mode 100644 drivers/vfio/container.c


base-commit: 3c28a76124b25882411f005924be73795b6ef078

Comments

Alex Williamson Sept. 23, 2022, 5:10 p.m. UTC | #1
On Thu, 22 Sep 2022 16:20:18 -0300
Jason Gunthorpe <jgg@nvidia.com> wrote:

> This creates an isolated layer around the container FD code and everything
> under it, including the VFIO iommu drivers. All this code is placed into
> container.c, along with the "struct vfio_container" to compartmentalize
> it.
> 
> Future patches will provide an iommufd based layer that gives the same API
> as the container layer and choose which layer to go to based on how
> userspace operates.
> 
> The patches continue to split up existing functions and finally the last
> patch just moves every function that is a "container" function to the new
> file and creates the global symbols to link them together.
> 
> Cross-file container functions are prefixed with vfio_container_* for
> clarity.
> 
> The last patch can be defered and queued during the merge window to manage
> conflicts. The earlier patches should be fine immediately conflicts wise.
> 
> This is the last big series I have to enable basic iommufd functionality.
> As part of the iommufd series the entire container.c becomes conditionally
> compiled:
> 
> https://github.com/jgunthorpe/linux/commits/vfio_iommufd
> 
> v3:
>  - Rebase over the vfio struct device series

Applied to vfio next branch for v6.1.  Thanks,

Alex