mbox series

[v3,0/5] Update vfio_group to use the modern cdev lifecycle

Message ID 0-v3-2fdfe4ca2cc6+18c-vfio_group_cdev_jgg@nvidia.com (mailing list archive)
Headers show
Series Update vfio_group to use the modern cdev lifecycle | expand

Message

Jason Gunthorpe Oct. 15, 2021, 11:40 a.m. UTC
These days drivers with state should use cdev_device_add() and
cdev_device_del() to manage the cdev and sysfs lifetime. This simple
pattern ties all the state (vfio, dev, and cdev) together in one memory
structure and uses container_of() to navigate between the layers.

This is a followup to the discussion here:

https://lore.kernel.org/kvm/20210921155705.GN327412@nvidia.com/

This builds on Christoph's work to revise how the vfio_group works and is
against the latest VFIO tree.

This is on github: https://github.com/jgunthorpe/linux/commits/vfio_group_cdev

v3:
 - Streamline vfio_group_find_or_alloc()
 - Remove vfio_group_try_get() and just opencode the refcount_inc_not_zero
v2: https://lore.kernel.org/r/0-v2-fd9627d27b2b+26c-vfio_group_cdev_jgg@nvidia.com
 - Remove comment before iommu_group_unregister_notifier()
 - Add comment explaining what the WARN_ONs vfio_group_put() do
 - Fix error logic around vfio_create_group() in patch 3
 - Add horizontal whitespace
 - Clarify comment is refering to group->users
v1: https://lore.kernel.org/r/0-v1-fba989159158+2f9b-vfio_group_cdev_jgg@nvidia.com

Cc: Liu Yi L <yi.l.liu@intel.com>
Cc: "Tian, Kevin" <kevin.tian@intel.com>
Cc: Christoph Hellwig <hch@lst.de>
Signed-off-by: Jason Gunthorpe <jgg@nvidia.com>

Jason Gunthorpe (5):
  vfio: Delete vfio_get/put_group from vfio_iommu_group_notifier()
  vfio: Do not open code the group list search in vfio_create_group()
  vfio: Don't leak a group reference if the group already exists
  vfio: Use a refcount_t instead of a kref in the vfio_group
  vfio: Use cdev_device_add() instead of device_create()

 drivers/vfio/vfio.c | 381 +++++++++++++++++---------------------------
 1 file changed, 149 insertions(+), 232 deletions(-)


base-commit: d9a0cd510c3383b61db6f70a84e0c3487f836a63

Comments

Christoph Hellwig Oct. 15, 2021, 1:20 p.m. UTC | #1
On Fri, Oct 15, 2021 at 08:40:49AM -0300, Jason Gunthorpe wrote:
> This builds on Christoph's work to revise how the vfio_group works and is
> against the latest VFIO tree.

Which already is in vfio/next now, btw.
Alex Williamson Oct. 20, 2021, 7:52 p.m. UTC | #2
On Fri, 15 Oct 2021 08:40:49 -0300
Jason Gunthorpe <jgg@nvidia.com> wrote:

> These days drivers with state should use cdev_device_add() and
> cdev_device_del() to manage the cdev and sysfs lifetime. This simple
> pattern ties all the state (vfio, dev, and cdev) together in one memory
> structure and uses container_of() to navigate between the layers.
> 
> This is a followup to the discussion here:
> 
> https://lore.kernel.org/kvm/20210921155705.GN327412@nvidia.com/
> 
> This builds on Christoph's work to revise how the vfio_group works and is
> against the latest VFIO tree.
> 
> This is on github: https://github.com/jgunthorpe/linux/commits/vfio_group_cdev
> 
> v3:
>  - Streamline vfio_group_find_or_alloc()
>  - Remove vfio_group_try_get() and just opencode the refcount_inc_not_zero
> v2: https://lore.kernel.org/r/0-v2-fd9627d27b2b+26c-vfio_group_cdev_jgg@nvidia.com
>  - Remove comment before iommu_group_unregister_notifier()
>  - Add comment explaining what the WARN_ONs vfio_group_put() do
>  - Fix error logic around vfio_create_group() in patch 3
>  - Add horizontal whitespace
>  - Clarify comment is refering to group->users
> v1: https://lore.kernel.org/r/0-v1-fba989159158+2f9b-vfio_group_cdev_jgg@nvidia.com
> 
> Cc: Liu Yi L <yi.l.liu@intel.com>
> Cc: "Tian, Kevin" <kevin.tian@intel.com>
> Cc: Christoph Hellwig <hch@lst.de>
> Signed-off-by: Jason Gunthorpe <jgg@nvidia.com>
> 
> Jason Gunthorpe (5):
>   vfio: Delete vfio_get/put_group from vfio_iommu_group_notifier()
>   vfio: Do not open code the group list search in vfio_create_group()
>   vfio: Don't leak a group reference if the group already exists
>   vfio: Use a refcount_t instead of a kref in the vfio_group
>   vfio: Use cdev_device_add() instead of device_create()
> 
>  drivers/vfio/vfio.c | 381 +++++++++++++++++---------------------------
>  1 file changed, 149 insertions(+), 232 deletions(-)

Applied to vfio next branch for v5.16.  Thanks,

Alex