mbox series

[0/6] KVM: Trivial cleanups

Message ID 20220605063417.308311-1-jiangshanlai@gmail.com (mailing list archive)
Headers show
Series KVM: Trivial cleanups | expand

Message

Lai Jiangshan June 5, 2022, 6:34 a.m. UTC
From: Lai Jiangshan <jiangshan.ljs@antgroup.com>

A small collection of trivial cleanups.

Lai Jiangshan (6):
  KVM: X86/MMU: Remove unused macros from paging_tmpl.h
  KVM: X86/MMU: Remove unused PT32_DIR_BASE_ADDR_MASK from mmu.c
  KVM: X86/MMU: Update comments in paging_tmpl.h for the kinds of guest
    PTEs
  KVM: Rename ack_flush() to ack_kick()
  KVM: X86/MMU: Remove useless mmu_topup_memory_caches() in
    kvm_mmu_pte_write()
  KVM: X86/SVM: Use root_level in svm_load_mmu_pgd()

 arch/x86/kvm/mmu/mmu.c         |  9 ---------
 arch/x86/kvm/mmu/paging_tmpl.h | 16 ++--------------
 arch/x86/kvm/svm/svm.c         |  2 +-
 virt/kvm/kvm_main.c            |  4 ++--
 4 files changed, 5 insertions(+), 26 deletions(-)

Comments

David Matlack June 8, 2022, 4:59 p.m. UTC | #1
On Sun, Jun 05, 2022 at 02:34:11PM +0800, Lai Jiangshan wrote:
> From: Lai Jiangshan <jiangshan.ljs@antgroup.com>
> 
> A small collection of trivial cleanups.

Nice cleanups. My only feedback is on the commit messages, which are a
bit terse. Here's what I would recommend:

 - Explain what the commit does in the first sentence/paragraph of the
   commit message and then explain why/background info.

 - Include "No functional change intended." for commits that are
   expected to be no-ops. It's pretty obvious for most of these changes
   but it's still nice that have to convey your intent.

Commit messages aside:

Reviewed-by: David Matlack <dmatlack@google.com>

> 
> Lai Jiangshan (6):
>   KVM: X86/MMU: Remove unused macros from paging_tmpl.h
>   KVM: X86/MMU: Remove unused PT32_DIR_BASE_ADDR_MASK from mmu.c
>   KVM: X86/MMU: Update comments in paging_tmpl.h for the kinds of guest
>     PTEs
>   KVM: Rename ack_flush() to ack_kick()
>   KVM: X86/MMU: Remove useless mmu_topup_memory_caches() in
>     kvm_mmu_pte_write()
>   KVM: X86/SVM: Use root_level in svm_load_mmu_pgd()
> 
>  arch/x86/kvm/mmu/mmu.c         |  9 ---------
>  arch/x86/kvm/mmu/paging_tmpl.h | 16 ++--------------
>  arch/x86/kvm/svm/svm.c         |  2 +-
>  virt/kvm/kvm_main.c            |  4 ++--
>  4 files changed, 5 insertions(+), 26 deletions(-)
> 
> -- 
> 2.19.1.6.gb485710b
>
Paolo Bonzini June 14, 2022, 5:15 p.m. UTC | #2
Queued patches 2 and 4-6, thanks.

I also applied David's rewarded commit mesage for patch 6.

Paolo