mbox series

[v2,0/3] KVM: selftests: Rename perf_test_util to memstress

Message ID 20221012165729.3505266-1-dmatlack@google.com (mailing list archive)
Headers show
Series KVM: selftests: Rename perf_test_util to memstress | expand

Message

David Matlack Oct. 12, 2022, 4:57 p.m. UTC
This series renames the perf_test_util to memstress. patch 1 renames the files
perf_test_util.[ch] to memstress.[ch], and patch 2 replaces the perf_test_
prefix on symbols with memstress_.

The reason for this rename, as with any rename, is to improve readability.
perf_test_util is too generic and does not describe at all what the library
does, other than being used for perf tests.

I considered a lot of different names (naming is hard) and eventually settled
on memstress for a few reasons:

 - "memstress" better describes the functionality proveded by this library,
   which is to run a VM that reads/writes to memory from all vCPUs in parallel
   (i.e. stressing VM memory).

 - "memstress" contains the same number of characters as "perf_test", making
   it a drop in replacement in symbols wihout changing line lengths.

 - The lack of underscore between "mem" and "stress" makes it clear "memstress"
   is a noun, avoiding confusion in function names.

Looking to the future, I think "memstress" will remain a good name. Specifically
there are some in-flight improvements that will make this library even more of
a "memory stress tester":

 - A proposed series by yours truly [1] extends memstress/perf_test_util to
   support execute from memory, in addition to reading/writing.

 - Colton Lewis within Google is looking into adding support for more complex
   memory access patterns.

[1] https://lore.kernel.org/kvm/20220401233737.3021889-2-dmatlack@google.com/

Cc: Andrew Jones <andrew.jones@linux.dev>
Cc: Colton Lewis <coltonlewis@google.com>
Cc: Ricardo Koller <ricarkol@google.com>
Acked-by: Andrew Jones <andrew.jones@linux.dev>

v2:
 - Add precursor patch to rename pta to args [Sean]

v1: https://lore.kernel.org/kvm/20220919232300.1562683-1-dmatlack@google.com/
 - Rebased on top of kvm/queue
 - Drop RFC tag.
 - Add Andrew's Acked-by.

RFC: https://lore.kernel.org/kvm/20220725163539.3145690-1-dmatlack@google.com/

David Matlack (2):
  KVM: selftests: Rename perf_test_util.[ch] to memstress.[ch]
  KVM: selftests: Rename perf_test_util symbols to memstress

 tools/testing/selftests/kvm/Makefile          |   4 +-
 .../selftests/kvm/access_tracking_perf_test.c |  20 ++--
 .../selftests/kvm/demand_paging_test.c        |  20 ++--
 .../selftests/kvm/dirty_log_perf_test.c       |  22 ++--
 .../include/{perf_test_util.h => memstress.h} |  34 +++---
 .../kvm/lib/{perf_test_util.c => memstress.c} | 102 +++++++++---------
 .../x86_64/{perf_test_util.c => memstress.c}  |  36 +++----
 .../kvm/memslot_modification_stress_test.c    |  16 +--
 8 files changed, 127 insertions(+), 127 deletions(-)
 rename tools/testing/selftests/kvm/include/{perf_test_util.h => memstress.h} (50%)
 rename tools/testing/selftests/kvm/lib/{perf_test_util.c => memstress.c} (70%)
 rename tools/testing/selftests/kvm/lib/x86_64/{perf_test_util.c => memstress.c} (68%)


base-commit: 372d07084593dc7a399bf9bee815711b1fb1bcf2
prerequisite-patch-id: 2e3661ba8856c29b769499bac525b6943d9284b8

Comments

Andrew Jones Oct. 13, 2022, 2:03 p.m. UTC | #1
On Wed, Oct 12, 2022 at 09:57:26AM -0700, David Matlack wrote:
> This series renames the perf_test_util to memstress. patch 1 renames the files
> perf_test_util.[ch] to memstress.[ch], and patch 2 replaces the perf_test_
> prefix on symbols with memstress_.
> 
> The reason for this rename, as with any rename, is to improve readability.
> perf_test_util is too generic and does not describe at all what the library
> does, other than being used for perf tests.
> 
> I considered a lot of different names (naming is hard) and eventually settled
> on memstress for a few reasons:
> 
>  - "memstress" better describes the functionality proveded by this library,
>    which is to run a VM that reads/writes to memory from all vCPUs in parallel
>    (i.e. stressing VM memory).
> 
>  - "memstress" contains the same number of characters as "perf_test", making
>    it a drop in replacement in symbols wihout changing line lengths.
> 
>  - The lack of underscore between "mem" and "stress" makes it clear "memstress"
>    is a noun, avoiding confusion in function names.
> 
> Looking to the future, I think "memstress" will remain a good name. Specifically
> there are some in-flight improvements that will make this library even more of
> a "memory stress tester":
> 
>  - A proposed series by yours truly [1] extends memstress/perf_test_util to
>    support execute from memory, in addition to reading/writing.
> 
>  - Colton Lewis within Google is looking into adding support for more complex
>    memory access patterns.
> 
> [1] https://lore.kernel.org/kvm/20220401233737.3021889-2-dmatlack@google.com/
> 
> Cc: Andrew Jones <andrew.jones@linux.dev>
> Cc: Colton Lewis <coltonlewis@google.com>
> Cc: Ricardo Koller <ricarkol@google.com>
> Acked-by: Andrew Jones <andrew.jones@linux.dev>
> 
> v2:
>  - Add precursor patch to rename pta to args [Sean]
> 
> v1: https://lore.kernel.org/kvm/20220919232300.1562683-1-dmatlack@google.com/
>  - Rebased on top of kvm/queue
>  - Drop RFC tag.
>  - Add Andrew's Acked-by.
> 
> RFC: https://lore.kernel.org/kvm/20220725163539.3145690-1-dmatlack@google.com/
>

For the series

Reviewed-by: Andrew Jones <andrew.jones@linux.dev>