From patchwork Tue Nov 12 10:14:44 2024 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Mauro Carvalho Chehab X-Patchwork-Id: 13872054 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3578821217C; Tue, 12 Nov 2024 10:15:10 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal: i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1731406510; cv=none; b=A7YI+im8SOuaP1B4zU9IwMtR5QKwpvmfTzkAAKlt7VQ5W5pDrCK4NnxOcd2NF+1nZV5lnnp2h3Lp+Nvb6pycUw2Xi01vG+uXUrBKQ/f+hwPVwTtHo00HYGvdTuRYlgdySwP80DkQhlZz8EnTrspfAv+QjvAfzahfRk9rFfhE6bI= ARC-Message-Signature: i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1731406510; c=relaxed/simple; bh=gZRgH1s/cCNEFX8xLSnC7mwjctXwEV543Xrdpddjabs=; h=From:To:Cc:Subject:Date:Message-ID:MIME-Version; b=jSBDwQSU56mJMC75jyo5HBBctPrO9kQyE8N9bUX9ewcXhudBvvdY9+hHXUJjAAd6q3bzZ0KBecPzNuM40IDez2x3acIv58vnHKnE5dXmRUukwT47FMnjmwaQb3wbEt/2dTimwXXZPbMH179d8XylyatH3A09lKYjniQtzMQW57Y= ARC-Authentication-Results: i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=CpAIGCPz; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="CpAIGCPz" Received: by smtp.kernel.org (Postfix) with ESMTPSA id DCF3CC4AF09; Tue, 12 Nov 2024 10:15:09 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1731406509; bh=gZRgH1s/cCNEFX8xLSnC7mwjctXwEV543Xrdpddjabs=; h=From:To:Cc:Subject:Date:From; b=CpAIGCPzgLkx4n9gtfH7GATjIZqvFRiIIlxQiqia00L6/avKOdun3uGNQrVv/VH22 niAAYo0WSUWJf4fYKnU7aRyviDSKH49JvTSWpK0rU+RDYfn3bKuvTNILuZgew+epB9 hS7Jf+mMV4KWkZPxFi5SZIVZtDiaxAP6FTHZqPLu2JrWWzwMy25UIzaA8kXeudfR/q 5Vt+XXJ4nfN6zx2NdEa5Y+DEbyh1aaxN7MKr/x3Y+up8LUd8EwL8kGDpttf3WdWE72 sj/4WxXFCQ9pK75KEDuvApPvg3P22X39M3HXB7E4kNFdw1KuVVXQIdUbE2JTb2jQ1q qMWUAbX/jvb7w== Received: from mchehab by mail.kernel.org with local (Exim 4.98) (envelope-from ) id 1tAnvO-00000000Jcb-41oN; Tue, 12 Nov 2024 11:15:06 +0100 From: Mauro Carvalho Chehab To: Igor Mammedov Cc: Jonathan Cameron , Shiju Jose , Mauro Carvalho Chehab , "Michael S. Tsirkin" , Ani Sinha , Dongjiu Geng , Paolo Bonzini , Peter Maydell , Shannon Zhao , kvm@vger.kernel.org, linux-kernel@vger.kernel.org, qemu-arm@nongnu.org, qemu-devel@nongnu.org Subject: [PATCH v3 00/15] Prepare GHES driver to support error injection Date: Tue, 12 Nov 2024 11:14:44 +0100 Message-ID: X-Mailer: git-send-email 2.47.0 Precedence: bulk X-Mailing-List: kvm@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Sender: Mauro Carvalho Chehab During the development of a patch series meant to allow GHESv2 error injections, it was requested a change on how CPER offsets are calculated, by adding a new BIOS pointer and reworking the GHES logic. See: https://lore.kernel.org/qemu-devel/cover.1726293808.git.mchehab+huawei@kernel.org/ Such change ended being a big patch, so several intermediate steps are needed, together with several cleanups and renames. As agreed duing v10 review, I'll be splitting the big patch series into separate pull requests, starting with the cleanup series. This is the first patch set, containing only such preparation patches. The next series will contain the shift to use offsets from the location of the HEST table, together with a migration logic to make it compatible with 9.1. --- v3: - improved some patch descriptions; - some patches got reordered to better reflect the changes; - patch v2 08/15: acpi/ghes: Prepare to support multiple sources on ghes was split on two patches. The first one is in this cleanup series: acpi/ghes: Change ghes fill logic to work with only one source contains just the simplification logic. The actual preparation will be moved to this series: https://lore.kernel.org/qemu-devel/cover.1727782588.git.mchehab+huawei@kernel.org/ v2: - some indentation fixes; - some description improvements; - fixed a badly-solved merge conflict that ended renaming a parameter. Mauro Carvalho Chehab (15): acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED acpi/ghes: simplify acpi_ghes_record_errors() code acpi/ghes: simplify the per-arch caller to build HEST table acpi/ghes: better handle source_id and notification acpi/ghes: Fix acpi_ghes_record_errors() argument acpi/ghes: Remove a duplicated out of bounds check acpi/ghes: Change the type for source_id acpi/ghes: make the GHES record generation more generic acpi/ghes: better name GHES memory error function acpi/ghes: don't crash QEMU if ghes GED is not found acpi/ghes: rename etc/hardware_error file macros acpi/ghes: better name the offset of the hardware error firmware acpi/ghes: move offset calculus to a separate function acpi/ghes: Change ghes fill logic to work with only one source docs: acpi_hest_ghes: fix documentation for CPER size docs/specs/acpi_hest_ghes.rst | 6 +- hw/acpi/generic_event_device.c | 4 +- hw/acpi/ghes-stub.c | 2 +- hw/acpi/ghes.c | 256 +++++++++++++++++++-------------- hw/arm/virt-acpi-build.c | 5 +- include/hw/acpi/ghes.h | 17 ++- target/arm/kvm.c | 3 +- 7 files changed, 171 insertions(+), 122 deletions(-)