diff mbox

qemu-kvm: fix typo in configure

Message ID 20090701112720.GA16678@redhat.com (mailing list archive)
State New, archived
Headers show

Commit Message

Michael S. Tsirkin July 1, 2009, 11:27 a.m. UTC
Kill extra \). Also escape ! for clarity and bourne shell
compatibility.

Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---

This patch fixes configure on next for me

 configure |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

Comments

Dustin Kirkland July 1, 2009, 11:07 p.m. UTC | #1
On Wed, Jul 1, 2009 at 4:27 AM, Michael S. Tsirkin<mst@redhat.com> wrote:
> Kill extra \). Also escape ! for clarity and bourne shell
> compatibility.

Agreed.  Looks like this one was introduced during the last merge from
qemu.  It bit me too.

:-Dustin

> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
> ---
>
> This patch fixes configure on next for me
>
>  configure |    6 +++---
>  1 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/configure b/configure
> index f76f511..b62e3d7 100755
> --- a/configure
> +++ b/configure
> @@ -2141,10 +2141,10 @@ configure_kvm() {
>  }
>
>  # Make sure the target and host cpus are compatible
> -if test ! \( "$target_cpu" = "$cpu" -o \
> +if test \! \( "$target_cpu" = "$cpu" -o \
>   \( "$target_cpu" = "ppcemb" -a "$cpu" = "ppc" \) -o \
> -  \( "$target_cpu" = "x86_64" -a "$cpu" = "i386"   \) -o \
> -  \( "$target_cpu" = "i386"   -a "$cpu" = "x86_64" \) \) -o \
> +  \( "$target_cpu" = "x86_64" -a "$cpu" = "i386" \) -o \
> +  \( "$target_cpu" = "i386"   -a "$cpu" = "x86_64" \) -o \
>   \( "$target_cpu" = "ia64"   -a "$cpu" = "ia64" \) \) ; then
>   target_kvm="no"
>  fi
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Avi Kivity July 2, 2009, 11:22 a.m. UTC | #2
On 07/01/2009 02:27 PM, Michael S. Tsirkin wrote:
> Kill extra \). Also escape ! for clarity and bourne shell
> compatibility.
>
>    

I applied a similar fix from Jan.
>
>   # Make sure the target and host cpus are compatible
> -if test ! \( "$target_cpu" = "$cpu" -o \
> +if test \! \( "$target_cpu" = "$cpu" -o \
>    

This is needed in qemu.git, in several places.
diff mbox

Patch

diff --git a/configure b/configure
index f76f511..b62e3d7 100755
--- a/configure
+++ b/configure
@@ -2141,10 +2141,10 @@  configure_kvm() {
 }
 
 # Make sure the target and host cpus are compatible
-if test ! \( "$target_cpu" = "$cpu" -o \
+if test \! \( "$target_cpu" = "$cpu" -o \
   \( "$target_cpu" = "ppcemb" -a "$cpu" = "ppc" \) -o \
-  \( "$target_cpu" = "x86_64" -a "$cpu" = "i386"   \) -o \
-  \( "$target_cpu" = "i386"   -a "$cpu" = "x86_64" \) \) -o \
+  \( "$target_cpu" = "x86_64" -a "$cpu" = "i386" \) -o \
+  \( "$target_cpu" = "i386"   -a "$cpu" = "x86_64" \) -o \
   \( "$target_cpu" = "ia64"   -a "$cpu" = "ia64" \) \) ; then
   target_kvm="no"
 fi