Message ID | 20211103070310.43380-3-likexu@tencent.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Use static_call for kvm_pmu_ops | expand |
On Wed, Nov 03, 2021, Like Xu wrote: > diff --git a/arch/x86/kvm/pmu.c b/arch/x86/kvm/pmu.c > index 0db1887137d9..b6f08c719125 100644 > --- a/arch/x86/kvm/pmu.c > +++ b/arch/x86/kvm/pmu.c > @@ -50,6 +50,13 @@ > struct kvm_pmu_ops kvm_pmu_ops __read_mostly; > EXPORT_SYMBOL_GPL(kvm_pmu_ops); > > +#define KVM_X86_PMU_OP(func) \ > + DEFINE_STATIC_CALL_NULL(kvm_x86_pmu_##func, \ > + *(((struct kvm_pmu_ops *)0)->func)) > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP More of a question for the existing code, what's the point of KVM_X86_OP_NULL? AFAICT, it always resolves to KVM_X86_OP. Unless there's some magic I'm missing, I vote we remove KVM_X86_OP_NULL and then not introduce KVM_X86_PMU_OP_NULL. And I'm pretty sure it's useless, e.g. get_cs_db_l_bits is defined with the NULL variant, but it's never NULL and its calls aren't guarded with anything. And if KVM_X86_OP_NULL is intended to aid in documenting behavior, it's doing a pretty miserable job of that :-) > +#include <asm/kvm-x86-pmu-ops.h> > +EXPORT_STATIC_CALL_GPL(kvm_x86_pmu_is_valid_msr); I'll double down on my nVMX suggestion so that this export can be avoided. > static void kvm_pmi_trigger_fn(struct irq_work *irq_work) > { > struct kvm_pmu *pmu = container_of(irq_work, struct kvm_pmu, irq_work); > diff --git a/arch/x86/kvm/pmu.h b/arch/x86/kvm/pmu.h > index b2fe135d395a..e5550d4acf14 100644 > --- a/arch/x86/kvm/pmu.h > +++ b/arch/x86/kvm/pmu.h > @@ -3,6 +3,8 @@ > #define __KVM_X86_PMU_H > > #include <linux/nospec.h> > +#include <linux/static_call_types.h> > +#include <linux/static_call.h> > > #define vcpu_to_pmu(vcpu) (&(vcpu)->arch.pmu) > #define pmu_to_vcpu(pmu) (container_of((pmu), struct kvm_vcpu, arch.pmu)) > @@ -45,6 +47,19 @@ struct kvm_pmu_ops { > void (*cleanup)(struct kvm_vcpu *vcpu); > }; > > +#define KVM_X86_PMU_OP(func) \ > + DECLARE_STATIC_CALL(kvm_x86_pmu_##func, *(((struct kvm_pmu_ops *)0)->func)) > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP > +#include <asm/kvm-x86-pmu-ops.h> > + > +static inline void kvm_pmu_ops_static_call_update(void) > +{ > +#define KVM_X86_PMU_OP(func) \ > + static_call_update(kvm_x86_pmu_##func, kvm_pmu_ops.func) > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP > +#include <asm/kvm-x86-pmu-ops.h> > +} As alluded to in patch 01, I'd prefer these go in kvm_ops_static_call_update() to keep the static call magic somewhat contained. > + > static inline u64 pmc_bitmask(struct kvm_pmc *pmc) > { > struct kvm_pmu *pmu = pmc_to_pmu(pmc); > -- > 2.33.0 >
On 5/11/2021 11:48 pm, Sean Christopherson wrote: > On Wed, Nov 03, 2021, Like Xu wrote: >> diff --git a/arch/x86/kvm/pmu.c b/arch/x86/kvm/pmu.c >> index 0db1887137d9..b6f08c719125 100644 >> --- a/arch/x86/kvm/pmu.c >> +++ b/arch/x86/kvm/pmu.c >> @@ -50,6 +50,13 @@ >> struct kvm_pmu_ops kvm_pmu_ops __read_mostly; >> EXPORT_SYMBOL_GPL(kvm_pmu_ops); >> >> +#define KVM_X86_PMU_OP(func) \ >> + DEFINE_STATIC_CALL_NULL(kvm_x86_pmu_##func, \ >> + *(((struct kvm_pmu_ops *)0)->func)) >> +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP > > More of a question for the existing code, what's the point of KVM_X86_OP_NULL? The comment says: * KVM_X86_OP_NULL() can leave a NULL definition for the * case where there is no definition or a function name that * doesn't match the typical naming convention is supplied. Does it help ? > AFAICT, it always resolves to KVM_X86_OP. Unless there's some magic I'm missing, > I vote we remove KVM_X86_OP_NULL and then not introduce KVM_X86_PMU_OP_NULL. > And I'm pretty sure it's useless, e.g. get_cs_db_l_bits is defined with the NULL This transitions will not be included in the next version. Open to you. > variant, but it's never NULL and its calls aren't guarded with anything. And if > KVM_X86_OP_NULL is intended to aid in documenting behavior, it's doing a pretty > miserable job of that :-) > >> +#include <asm/kvm-x86-pmu-ops.h> >> +EXPORT_STATIC_CALL_GPL(kvm_x86_pmu_is_valid_msr); > > I'll double down on my nVMX suggestion so that this export can be avoided. Fine to me. > >> static void kvm_pmi_trigger_fn(struct irq_work *irq_work) >> { >> struct kvm_pmu *pmu = container_of(irq_work, struct kvm_pmu, irq_work); >> diff --git a/arch/x86/kvm/pmu.h b/arch/x86/kvm/pmu.h >> index b2fe135d395a..e5550d4acf14 100644 >> --- a/arch/x86/kvm/pmu.h >> +++ b/arch/x86/kvm/pmu.h >> @@ -3,6 +3,8 @@ >> #define __KVM_X86_PMU_H >> >> #include <linux/nospec.h> >> +#include <linux/static_call_types.h> >> +#include <linux/static_call.h> >> >> #define vcpu_to_pmu(vcpu) (&(vcpu)->arch.pmu) >> #define pmu_to_vcpu(pmu) (container_of((pmu), struct kvm_vcpu, arch.pmu)) >> @@ -45,6 +47,19 @@ struct kvm_pmu_ops { >> void (*cleanup)(struct kvm_vcpu *vcpu); >> }; >> >> +#define KVM_X86_PMU_OP(func) \ >> + DECLARE_STATIC_CALL(kvm_x86_pmu_##func, *(((struct kvm_pmu_ops *)0)->func)) >> +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP >> +#include <asm/kvm-x86-pmu-ops.h> >> + >> +static inline void kvm_pmu_ops_static_call_update(void) >> +{ >> +#define KVM_X86_PMU_OP(func) \ >> + static_call_update(kvm_x86_pmu_##func, kvm_pmu_ops.func) >> +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP >> +#include <asm/kvm-x86-pmu-ops.h> >> +} > > As alluded to in patch 01, I'd prefer these go in kvm_ops_static_call_update() > to keep the static call magic somewhat contained. Thank and applied. > >> + >> static inline u64 pmc_bitmask(struct kvm_pmc *pmc) >> { >> struct kvm_pmu *pmu = pmc_to_pmu(pmc); >> -- >> 2.33.0 >> >
On Mon, Nov 08, 2021, Like Xu wrote: > On 5/11/2021 11:48 pm, Sean Christopherson wrote: > > On Wed, Nov 03, 2021, Like Xu wrote: > > > diff --git a/arch/x86/kvm/pmu.c b/arch/x86/kvm/pmu.c > > > index 0db1887137d9..b6f08c719125 100644 > > > --- a/arch/x86/kvm/pmu.c > > > +++ b/arch/x86/kvm/pmu.c > > > @@ -50,6 +50,13 @@ > > > struct kvm_pmu_ops kvm_pmu_ops __read_mostly; > > > EXPORT_SYMBOL_GPL(kvm_pmu_ops); > > > +#define KVM_X86_PMU_OP(func) \ > > > + DEFINE_STATIC_CALL_NULL(kvm_x86_pmu_##func, \ > > > + *(((struct kvm_pmu_ops *)0)->func)) > > > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP > > > > More of a question for the existing code, what's the point of KVM_X86_OP_NULL? > > The comment says: > > * KVM_X86_OP_NULL() can leave a NULL definition for the > * case where there is no definition or a function name that > * doesn't match the typical naming convention is supplied. > > Does it help ? No. I understand the original intent of KVM_X86_OP_NULL, but unless there's some form of enforcement, it does more harm than good because it can very easily become stale, e.g. see get_cs_db_l_bits(). I guess "what's the point of KVM_X86_OP_NULL?" was somewhat of a rhetorical question. > > AFAICT, it always resolves to KVM_X86_OP. Unless there's some magic I'm missing, > > I vote we remove KVM_X86_OP_NULL and then not introduce KVM_X86_PMU_OP_NULL. > > And I'm pretty sure it's useless, e.g. get_cs_db_l_bits is defined with the NULL
diff --git a/arch/x86/include/asm/kvm-x86-pmu-ops.h b/arch/x86/include/asm/kvm-x86-pmu-ops.h new file mode 100644 index 000000000000..b7713b16d21d --- /dev/null +++ b/arch/x86/include/asm/kvm-x86-pmu-ops.h @@ -0,0 +1,32 @@ +/* SPDX-License-Identifier: GPL-2.0 */ +#if !defined(KVM_X86_PMU_OP) || !defined(KVM_X86_PMU_OP_NULL) +BUILD_BUG_ON(1) +#endif + +/* + * KVM_X86_PMU_OP() and KVM_X86_PMU_OP_NULL() are used to + * help generate "static_call()"s. They are also intended for use when defining + * the amd/intel KVM_X86_PMU_OPs. KVM_X86_PMU_OP() can be used + * for those functions that follow the [amd|intel]_func_name convention. + * KVM_X86_PMU_OP_NULL() can leave a NULL definition for the + * case where there is no definition or a function name that + * doesn't match the typical naming convention is supplied. + */ +KVM_X86_PMU_OP(find_arch_event); +KVM_X86_PMU_OP(find_fixed_event); +KVM_X86_PMU_OP(pmc_is_enabled); +KVM_X86_PMU_OP(pmc_idx_to_pmc); +KVM_X86_PMU_OP(rdpmc_ecx_to_pmc); +KVM_X86_PMU_OP(msr_idx_to_pmc); +KVM_X86_PMU_OP(is_valid_rdpmc_ecx); +KVM_X86_PMU_OP(is_valid_msr); +KVM_X86_PMU_OP(get_msr); +KVM_X86_PMU_OP(set_msr); +KVM_X86_PMU_OP(refresh); +KVM_X86_PMU_OP(init); +KVM_X86_PMU_OP(reset); +KVM_X86_PMU_OP_NULL(deliver_pmi); +KVM_X86_PMU_OP_NULL(cleanup); + +#undef KVM_X86_PMU_OP +#undef KVM_X86_PMU_OP_NULL diff --git a/arch/x86/kvm/pmu.c b/arch/x86/kvm/pmu.c index 0db1887137d9..b6f08c719125 100644 --- a/arch/x86/kvm/pmu.c +++ b/arch/x86/kvm/pmu.c @@ -50,6 +50,13 @@ struct kvm_pmu_ops kvm_pmu_ops __read_mostly; EXPORT_SYMBOL_GPL(kvm_pmu_ops); +#define KVM_X86_PMU_OP(func) \ + DEFINE_STATIC_CALL_NULL(kvm_x86_pmu_##func, \ + *(((struct kvm_pmu_ops *)0)->func)) +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP +#include <asm/kvm-x86-pmu-ops.h> +EXPORT_STATIC_CALL_GPL(kvm_x86_pmu_is_valid_msr); + static void kvm_pmi_trigger_fn(struct irq_work *irq_work) { struct kvm_pmu *pmu = container_of(irq_work, struct kvm_pmu, irq_work); diff --git a/arch/x86/kvm/pmu.h b/arch/x86/kvm/pmu.h index b2fe135d395a..e5550d4acf14 100644 --- a/arch/x86/kvm/pmu.h +++ b/arch/x86/kvm/pmu.h @@ -3,6 +3,8 @@ #define __KVM_X86_PMU_H #include <linux/nospec.h> +#include <linux/static_call_types.h> +#include <linux/static_call.h> #define vcpu_to_pmu(vcpu) (&(vcpu)->arch.pmu) #define pmu_to_vcpu(pmu) (container_of((pmu), struct kvm_vcpu, arch.pmu)) @@ -45,6 +47,19 @@ struct kvm_pmu_ops { void (*cleanup)(struct kvm_vcpu *vcpu); }; +#define KVM_X86_PMU_OP(func) \ + DECLARE_STATIC_CALL(kvm_x86_pmu_##func, *(((struct kvm_pmu_ops *)0)->func)) +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP +#include <asm/kvm-x86-pmu-ops.h> + +static inline void kvm_pmu_ops_static_call_update(void) +{ +#define KVM_X86_PMU_OP(func) \ + static_call_update(kvm_x86_pmu_##func, kvm_pmu_ops.func) +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP +#include <asm/kvm-x86-pmu-ops.h> +} + static inline u64 pmc_bitmask(struct kvm_pmc *pmc) { struct kvm_pmu *pmu = pmc_to_pmu(pmc);
Use static calls to improve kvm_pmu_ops performance. Introduce the definitions that will be used by a subsequent patch to actualize the savings. Add a new kvm-x86-pmu-ops.h header that can be used for the definition of static calls. This header is also intended to be used to simplify the defition of amd_pmu_ops and intel_pmu_ops. Like what we did for kvm_x86_ops, 'pmu_ops' can be covered by static calls in a simlilar manner for insignificant but not negligible performance impact, especially on older models. Signed-off-by: Like Xu <likexu@tencent.com> --- arch/x86/include/asm/kvm-x86-pmu-ops.h | 32 ++++++++++++++++++++++++++ arch/x86/kvm/pmu.c | 7 ++++++ arch/x86/kvm/pmu.h | 15 ++++++++++++ 3 files changed, 54 insertions(+) create mode 100644 arch/x86/include/asm/kvm-x86-pmu-ops.h