diff mbox series

KVM: x86: enhance the readability of function pic_intack()

Message ID 20220112085153.4506-1-wangguangju@baidu.com (mailing list archive)
State New, archived
Headers show
Series KVM: x86: enhance the readability of function pic_intack() | expand

Commit Message

Wang Guangju Jan. 12, 2022, 8:51 a.m. UTC
From: wangguangju <wangguangju@baidu.com>

In function pic_intack(), use a varibale of "mask" to
record expression of "1 << irq", so we can enhance the
readability of this function.

Signed-off-by: wangguangju <wangguangju@baidu.com>
---
 arch/x86/kvm/i8259.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Sean Christopherson Jan. 15, 2022, 12:46 a.m. UTC | #1
On Wed, Jan 12, 2022, Wang Guangju wrote:
> From: wangguangju <wangguangju@baidu.com>
> 
> In function pic_intack(), use a varibale of "mask" to
> record expression of "1 << irq", so we can enhance the
> readability of this function.

Please wrap at ~75 chars.

> Signed-off-by: wangguangju <wangguangju@baidu.com>
> ---
>  arch/x86/kvm/i8259.c | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
> index 814064d06016..ad6b64b11adc 100644
> --- a/arch/x86/kvm/i8259.c
> +++ b/arch/x86/kvm/i8259.c
> @@ -216,12 +216,14 @@ void kvm_pic_clear_all(struct kvm_pic *s, int irq_source_id)
>   */
>  static inline void pic_intack(struct kvm_kpic_state *s, int irq)
>  {
> -	s->isr |= 1 << irq;
> +	int mask;

Needs a newline, and could also be:

	int mask = 1 << irq;

or even

	int mask = BIT(irq);

That said, I oddly find the existing code more readable.  Maybe "irq_mask" instead
of "mask"?  Dunno.  I guess I don't have a strong opinion :-)
diff mbox series

Patch

diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
index 814064d06016..ad6b64b11adc 100644
--- a/arch/x86/kvm/i8259.c
+++ b/arch/x86/kvm/i8259.c
@@ -216,12 +216,14 @@  void kvm_pic_clear_all(struct kvm_pic *s, int irq_source_id)
  */
 static inline void pic_intack(struct kvm_kpic_state *s, int irq)
 {
-	s->isr |= 1 << irq;
+	int mask;
+	mask = 1 << irq;
+	s->isr |= mask;
 	/*
 	 * We don't clear a level sensitive interrupt here
 	 */
-	if (!(s->elcr & (1 << irq)))
-		s->irr &= ~(1 << irq);
+	if (!(s->elcr & mask))
+		s->irr &= ~mask;
 
 	if (s->auto_eoi) {
 		if (s->rotate_on_auto_eoi)