Message ID | 20240227200356.35114-1-john.allen@amd.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | KVM: SVM: Rename vmplX_ssp -> plX_ssp | expand |
On Tue, 27 Feb 2024 20:03:56 +0000, John Allen wrote: > The SSP fields in the SEV-ES save area were mistakenly named vmplX_ssp > instead of plX_ssp. Rename these to the correct names as defined in the > APM. Applied to kvm-x86 misc, thanks! I put this into "misc" instead of "svm" purely because I already sent the SVM pull request for 6.9, and the only other patches that are SVM specific is my SEV-ES VMRUN series, and I'm not sure I'll queue that for 6.9 or wait for 6.10 (and I'll probably throw it in its own branch regardless). [1/1] KVM: SVM: Rename vmplX_ssp -> plX_ssp https://github.com/kvm-x86/linux/commit/78ccfce77443 -- https://github.com/kvm-x86/linux/tree/next
diff --git a/arch/x86/include/asm/svm.h b/arch/x86/include/asm/svm.h index 87a7b917d30e..728c98175b9c 100644 --- a/arch/x86/include/asm/svm.h +++ b/arch/x86/include/asm/svm.h @@ -358,10 +358,10 @@ struct sev_es_save_area { struct vmcb_seg ldtr; struct vmcb_seg idtr; struct vmcb_seg tr; - u64 vmpl0_ssp; - u64 vmpl1_ssp; - u64 vmpl2_ssp; - u64 vmpl3_ssp; + u64 pl0_ssp; + u64 pl1_ssp; + u64 pl2_ssp; + u64 pl3_ssp; u64 u_cet; u8 reserved_0xc8[2]; u8 vmpl;
The SSP fields in the SEV-ES save area were mistakenly named vmplX_ssp instead of plX_ssp. Rename these to the correct names as defined in the APM. Fixes: 6d3b3d34e39e ("KVM: SVM: Update the SEV-ES save area mapping") Signed-off-by: John Allen <john.allen@amd.com> --- arch/x86/include/asm/svm.h | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)