diff mbox series

vfio/fsl-mc: Fix a typo in a comment

Message ID 2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo.fr (mailing list archive)
State New, archived
Headers show
Series vfio/fsl-mc: Fix a typo in a comment | expand

Commit Message

Christophe JAILLET Aug. 6, 2022, 7:56 p.m. UTC
L and S are swapped/
s/VFIO_FLS_MC/VFIO_FSL_MC/

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
prefix.
As they are dev_ function, the driver should already be displayed.

So, does it make sense or could they be all removed?
---
 drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Cornelia Huck Aug. 8, 2022, 9:57 a.m. UTC | #1
On Sat, Aug 06 2022, Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote:

$SUBJECT: s/comment/message/

> L and S are swapped/
> s/VFIO_FLS_MC/VFIO_FSL_MC/
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> prefix.
> As they are dev_ function, the driver should already be displayed.
>
> So, does it make sense or could they be all removed?

From a quick glance, there seem to be messages for when the device is
_not_ bound to the fsl-mc driver (e.g. in vfio_fsl_mc_bus_notifier());
I'd just fix the typo for now.

> ---
>  drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Acked-by: Cornelia Huck <cohuck@redhat.com>
Jason Gunthorpe Aug. 9, 2022, 4:20 p.m. UTC | #2
On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
> L and S are swapped/
> s/VFIO_FLS_MC/VFIO_FSL_MC/
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> prefix.
> As they are dev_ function, the driver should already be displayed.
> 
> So, does it make sense or could they be all removed?
> ---
>  drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> index 3feff729f3ce..66d01db1d240 100644
> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>  
>  	if (WARN_ON(ret))
>  		dev_warn(&mc_cont->dev,
> -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> +			 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

WARN_ON already prints, this is better written as

WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Jason
Christophe JAILLET Aug. 16, 2022, 3 p.m. UTC | #3
Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
> On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
>> L and S are swapped/
>> s/VFIO_FLS_MC/VFIO_FSL_MC/
>>
>> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>> ---
>> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
>> prefix.
>> As they are dev_ function, the driver should already be displayed.
>>
>> So, does it make sense or could they be all removed?
>> ---
>>   drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> index 3feff729f3ce..66d01db1d240 100644
>> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>>   
>>   	if (WARN_ON(ret))
>>   		dev_warn(&mc_cont->dev,
>> -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
>> +			 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
> 
> WARN_ON already prints, this is better written as
> 
> WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Or maybe, just:
if (ret)
	dev_warn(&mc_cont->dev,
		 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

This keep information about the device, avoid the duplicate printing 
related to WARN_ON+dev_warn and is more in line with error handling in 
other files.

Do you agree or do you prefer a v2 as you proposed with WARN()?

CJ


> 
> Jason
>
Jason Gunthorpe Aug. 16, 2022, 3:08 p.m. UTC | #4
On Tue, Aug 16, 2022 at 05:00:50PM +0200, Christophe JAILLET wrote:
> Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
> > On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
> > > L and S are swapped/
> > > s/VFIO_FLS_MC/VFIO_FSL_MC/
> > > 
> > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> > > ---
> > > All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> > > prefix.
> > > As they are dev_ function, the driver should already be displayed.
> > > 
> > > So, does it make sense or could they be all removed?
> > > ---
> > >   drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > 
> > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > index 3feff729f3ce..66d01db1d240 100644
> > > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
> > >   	if (WARN_ON(ret))
> > >   		dev_warn(&mc_cont->dev,
> > > -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> > > +			 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
> > 
> > WARN_ON already prints, this is better written as
> > 
> > WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
> 
> Or maybe, just:
> if (ret)
> 	dev_warn(&mc_cont->dev,
> 		 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
> 
> This keep information about the device, avoid the duplicate printing related
> to WARN_ON+dev_warn and is more in line with error handling in other files.
> 
> Do you agree or do you prefer a v2 as you proposed with WARN()?

If the original author wrote WARN I would not degrade it to just a
dev_warn.

Jason
Cornelia Huck Aug. 22, 2022, 9:14 a.m. UTC | #5
On Tue, Aug 16 2022, Jason Gunthorpe <jgg@ziepe.ca> wrote:

> On Tue, Aug 16, 2022 at 05:00:50PM +0200, Christophe JAILLET wrote:
>> Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
>> > On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
>> > > L and S are swapped/
>> > > s/VFIO_FLS_MC/VFIO_FSL_MC/
>> > > 
>> > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>> > > ---
>> > > All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
>> > > prefix.
>> > > As they are dev_ function, the driver should already be displayed.
>> > > 
>> > > So, does it make sense or could they be all removed?
>> > > ---
>> > >   drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>> > >   1 file changed, 1 insertion(+), 1 deletion(-)
>> > > 
>> > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > index 3feff729f3ce..66d01db1d240 100644
>> > > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>> > >   	if (WARN_ON(ret))
>> > >   		dev_warn(&mc_cont->dev,
>> > > -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
>> > > +			 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>> > 
>> > WARN_ON already prints, this is better written as
>> > 
>> > WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>> 
>> Or maybe, just:
>> if (ret)
>> 	dev_warn(&mc_cont->dev,
>> 		 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>> 
>> This keep information about the device, avoid the duplicate printing related
>> to WARN_ON+dev_warn and is more in line with error handling in other files.
>> 
>> Do you agree or do you prefer a v2 as you proposed with WARN()?
>
> If the original author wrote WARN I would not degrade it to just a
> dev_warn.

Having to decide between losing the WARN and losing the device info, I'd
just... fix the typo :)
diff mbox series

Patch

diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
index 3feff729f3ce..66d01db1d240 100644
--- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
+++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
@@ -110,7 +110,7 @@  static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
 
 	if (WARN_ON(ret))
 		dev_warn(&mc_cont->dev,
-			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
+			 "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
 
 	vfio_fsl_mc_irqs_cleanup(vdev);