diff mbox series

[v2] vfio/fsl-mc: Fix a typo in a message

Message ID 3d2aa8434393ee8d2aa23a620e59ce1059c9d7ad.1660663440.git.christophe.jaillet@wanadoo.fr (mailing list archive)
State New, archived
Headers show
Series [v2] vfio/fsl-mc: Fix a typo in a message | expand

Commit Message

Christophe JAILLET Aug. 16, 2022, 3:24 p.m. UTC
L and S are swapped in the message.
s/VFIO_FLS_MC/VFIO_FSL_MC/

Also use WARN instead of WARN_ON+dev_warn because WARN can already print
the message.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
Changes in v2:
  * s/comment/message/ in the subject   [Cornelia Huck <cohuck@redhat.com>]
  * use WARN instead of WARN_ON+dev_warn   [Jason Gunthorpe <jgg@ziepe.ca>]

v1:
  https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo.fr/
---
 drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Jason Gunthorpe Aug. 16, 2022, 3:46 p.m. UTC | #1
On Tue, Aug 16, 2022 at 05:24:46PM +0200, Christophe JAILLET wrote:
> L and S are swapped in the message.
> s/VFIO_FLS_MC/VFIO_FSL_MC/
> 
> Also use WARN instead of WARN_ON+dev_warn because WARN can already print
> the message.
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---

Reviewed-by: Jason Gunthorpe <jgg@nvidia.com>

Jason
Cornelia Huck Aug. 22, 2022, 9:19 a.m. UTC | #2
On Tue, Aug 16 2022, Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote:

> L and S are swapped in the message.
> s/VFIO_FLS_MC/VFIO_FSL_MC/
>
> Also use WARN instead of WARN_ON+dev_warn because WARN can already print
> the message.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> Changes in v2:
>   * s/comment/message/ in the subject   [Cornelia Huck <cohuck@redhat.com>]
>   * use WARN instead of WARN_ON+dev_warn   [Jason Gunthorpe <jgg@ziepe.ca>]
>
> v1:
>   https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo.fr/
> ---
>  drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> index 3feff729f3ce..57774009e0eb 100644
> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> @@ -108,9 +108,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>  	/* reset the device before cleaning up the interrupts */
>  	ret = vfio_fsl_mc_reset_device(vdev);
>  
> -	if (WARN_ON(ret))
> -		dev_warn(&mc_cont->dev,
> -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> +	WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Hm, but this drops the device information, not such a fan... maybe the
author can chime in?

>  
>  	vfio_fsl_mc_irqs_cleanup(vdev);
>
Alex Williamson Aug. 25, 2022, 9:01 p.m. UTC | #3
On Mon, 22 Aug 2022 11:19:57 +0200
Cornelia Huck <cohuck@redhat.com> wrote:

> On Tue, Aug 16 2022, Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote:
> 
> > L and S are swapped in the message.
> > s/VFIO_FLS_MC/VFIO_FSL_MC/
> >
> > Also use WARN instead of WARN_ON+dev_warn because WARN can already print
> > the message.
> >
> > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> > ---
> > Changes in v2:
> >   * s/comment/message/ in the subject   [Cornelia Huck <cohuck@redhat.com>]
> >   * use WARN instead of WARN_ON+dev_warn   [Jason Gunthorpe <jgg@ziepe.ca>]
> >
> > v1:
> >   https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo.fr/
> > ---
> >  drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > index 3feff729f3ce..57774009e0eb 100644
> > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > @@ -108,9 +108,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
> >  	/* reset the device before cleaning up the interrupts */
> >  	ret = vfio_fsl_mc_reset_device(vdev);
> >  
> > -	if (WARN_ON(ret))
> > -		dev_warn(&mc_cont->dev,
> > -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> > +	WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);  
> 
> Hm, but this drops the device information, not such a fan... maybe the
> author can chime in?

Diana, what do you want to do here?  Thanks,

Alex
Diana Madalina Craciun Aug. 26, 2022, 12:05 p.m. UTC | #4
On 8/26/2022 12:01 AM, Alex Williamson wrote:
> On Mon, 22 Aug 2022 11:19:57 +0200
> Cornelia Huck <cohuck@redhat.com> wrote:
>
>> On Tue, Aug 16 2022, Christophe JAILLET <christophe.jaillet@wanadoo.fr> wrote:
>>
>>> L and S are swapped in the message.
>>> s/VFIO_FLS_MC/VFIO_FSL_MC/
>>>
>>> Also use WARN instead of WARN_ON+dev_warn because WARN can already print
>>> the message.
>>>
>>> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>>> ---
>>> Changes in v2:
>>>    * s/comment/message/ in the subject   [Cornelia Huck <cohuck@redhat.com>]
>>>    * use WARN instead of WARN_ON+dev_warn   [Jason Gunthorpe <jgg@ziepe.ca>]
>>>
>>> v1:
>>>    https://lore.kernel.org/all/2b65bf8d2b4d940cafbafcede07c23c35f042f5a.1659815764.git.christophe.jaillet@wanadoo.fr/
>>> ---
>>>   drivers/vfio/fsl-mc/vfio_fsl_mc.c | 4 +---
>>>   1 file changed, 1 insertion(+), 3 deletions(-)
>>>
>>> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>>> index 3feff729f3ce..57774009e0eb 100644
>>> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>>> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>>> @@ -108,9 +108,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>>>   	/* reset the device before cleaning up the interrupts */
>>>   	ret = vfio_fsl_mc_reset_device(vdev);
>>>   
>>> -	if (WARN_ON(ret))
>>> -		dev_warn(&mc_cont->dev,
>>> -			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
>>> +	WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>> Hm, but this drops the device information, not such a fan... maybe the
>> author can chime in?
> Diana, what do you want to do here?  Thanks,

I would prefer to keep the device information. So, I am OK with 
something like:

if (ret)
     dev_warn(&mc_cont->dev,
          "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Thanks,
Diana
diff mbox series

Patch

diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
index 3feff729f3ce..57774009e0eb 100644
--- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
+++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
@@ -108,9 +108,7 @@  static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
 	/* reset the device before cleaning up the interrupts */
 	ret = vfio_fsl_mc_reset_device(vdev);
 
-	if (WARN_ON(ret))
-		dev_warn(&mc_cont->dev,
-			 "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
+	WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
 
 	vfio_fsl_mc_irqs_cleanup(vdev);