diff mbox series

[v6,1/2] ACPI: Move check for _DSD StorageD3Enable property to acpi

Message ID 20210607173156.5548-1-mario.limonciello@amd.com (mailing list archive)
State Changes Requested, archived
Headers show
Series [v6,1/2] ACPI: Move check for _DSD StorageD3Enable property to acpi | expand

Commit Message

Mario Limonciello June 7, 2021, 5:31 p.m. UTC
Although first implemented for NVME, this check may be usable by
other drivers as well. Microsoft's specification explicitly mentions
that is may be usable by SATA and AHCI devices.  Google also indicates
that they have used this with SDHCI in a downstream kernel tree that
a user can plug a storage device into.

Link: https://docs.microsoft.com/en-us/windows-hardware/design/component-guidelines/power-management-for-storage-hardware-devices-intro
Suggested-by: Keith Busch <kbusch@kernel.org>
CC: Shyam-sundar S-k <Shyam-sundar.S-k@amd.com>
CC: Alexander Deucher <Alexander.Deucher@amd.com>
CC: Rafael J. Wysocki <rjw@rjwysocki.net>
CC: Prike Liang <prike.liang@amd.com>
Signed-off-by: Mario Limonciello <mario.limonciello@amd.com>
Acked-by: Raul E Rangel <rrangel@chromium.org>
Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
Reviewed-by: Keith Busch <kbusch@kernel.org>
---
 drivers/acpi/device_pm.c | 25 +++++++++++++++++++++++++
 drivers/nvme/host/pci.c  | 28 +---------------------------
 include/linux/acpi.h     |  5 +++++
 3 files changed, 31 insertions(+), 27 deletions(-)

Changes from v4->v5:
 * Correct extra "Link:" word in commit message
Changes from v5->v6:
 * Add in commit message tags from Raul, Rafael and Keith

Comments

Christoph Hellwig June 8, 2021, 5:35 a.m. UTC | #1
On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
> +/**
> + * acpi_storage_d3 - Check if a storage device should use D3.
> + * @dev: Device to check
> + *
> + * Returns %true if @dev should be put into D3 when the ->suspend method is
> + * called, else %false.  The name of this function is somewhat misleading
> + * as it has nothing to do with storage except for the name of the ACPI
> + * property.  On some platforms resume will not work if this hint is ignored.
> + *
> + */

I still do not like this comment.  There is nothing about only using this
for storage devices.  It is specific to a PCIe slot, and if I plug
something that is not a storage device into it the same restrictions
still apply.

Also no need for the empty-ish line at the end.
Rafael J. Wysocki June 8, 2021, 11:20 a.m. UTC | #2
On Tue, Jun 8, 2021 at 7:35 AM Christoph Hellwig <hch@lst.de> wrote:
>
> On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
> > +/**
> > + * acpi_storage_d3 - Check if a storage device should use D3.

Let's be specific about what D3 means here in the first place and
that's D3hot AFAICS.

And the comment should be something like "Check whether or not to use
D3hot in the suspend path".

> > + * @dev: Device to check
> > + *
> > + * Returns %true if @dev should be put into D3 when the ->suspend method is
> > + * called, else %false.  The name of this function is somewhat misleading
> > + * as it has nothing to do with storage except for the name of the ACPI
> > + * property.  On some platforms resume will not work if this hint is ignored.

I would write it this way:

"Return %true if the platform firmware wants @dev to be programmed
into D3hot in the suspend path, or %false when there is no specific
preference. On some platforms, if this hint is ignored, @dev may
remain unresponsive after suspending the platform as a whole."

And I'm not sure if it is necessary to mention "storage" in this comment at all.

> > + *
> > + */
>
> I still do not like this comment.  There is nothing about only using this
> for storage devices.  It is specific to a PCIe slot, and if I plug
> something that is not a storage device into it the same restrictions
> still apply.

Originally, it was about storage devices IIUC (and that's why the
property name is what it is).

IIRC PCIe link management was broken in some NVMe drives and putting
them into D3hot would allow the link to go down later and it would
never go up again.  So you-know-who decided to avoid using D3hot for
all NVMe drives and they were generally characterized as "storage".
Alas, that turned out to break other things depending on the devices
being put into D3hot (like PS_ON) so the property was invented to
allow OEMs to mark the configurations including the devices that
actually worked (and Linux was/is on the receiving end). And
originally the property applied to the endpoint device under the root
port it was present for (my personal opinion about this doesn't really
matter, so let me avoid wasting time on expressing it).

Now, it evidently has been re-purposed to mark PCIe root ports that
require devices under them to be put into D3hot in the suspend path
(and it now means any device under the root port with this property,
at least in some cases).

> Also no need for the empty-ish line at the end.

Right.
Mario Limonciello June 8, 2021, 2:18 p.m. UTC | #3
On 6/8/2021 06:20, Rafael J. Wysocki wrote:
> On Tue, Jun 8, 2021 at 7:35 AM Christoph Hellwig <hch@lst.de> wrote:
>>
>> On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
>>> +/**
>>> + * acpi_storage_d3 - Check if a storage device should use D3.
> 
> Let's be specific about what D3 means here in the first place and
> that's D3hot AFAICS.
> 
> And the comment should be something like "Check whether or not to use
> D3hot in the suspend path".

Actually it can be D3hot or D3cold.  Microsoft's documentation doesn't 
indicate it's D3hot.  On the AMD platforms that prompted some of these 
changes it's D3cold.

> 
>>> + * @dev: Device to check
>>> + *
>>> + * Returns %true if @dev should be put into D3 when the ->suspend method is
>>> + * called, else %false.  The name of this function is somewhat misleading
>>> + * as it has nothing to do with storage except for the name of the ACPI
>>> + * property.  On some platforms resume will not work if this hint is ignored.
> 
> I would write it this way:
> 
> "Return %true if the platform firmware wants @dev to be programmed
> into D3hot in the suspend path, or %false when there is no specific
> preference. On some platforms, if this hint is ignored, @dev may
> remain unresponsive after suspending the platform as a whole."
> 
> And I'm not sure if it is necessary to mention "storage" in this comment at all.
> 

Is your thought here in not mentioning "storage" that this symbol may be 
overloaded in the future to look at more than just the StorageD3Enable 
property and used for other things too?

>>> + *
>>> + */
>>
>> I still do not like this comment.  There is nothing about only using this
>> for storage devices.  It is specific to a PCIe slot, and if I plug
>> something that is not a storage device into it the same restrictions
>> still apply.
> 
> Originally, it was about storage devices IIUC (and that's why the
> property name is what it is).
>  > IIRC PCIe link management was broken in some NVMe drives and putting
> them into D3hot would allow the link to go down later and it would
> never go up again.  So you-know-who decided to avoid using D3hot for
> all NVMe drives and they were generally characterized as "storage".
> Alas, that turned out to break other things depending on the devices
> being put into D3hot (like PS_ON) so the property was invented to
> allow OEMs to mark the configurations including the devices that
> actually worked (and Linux was/is on the receiving end). And
> originally the property applied to the endpoint device under the root
> port it was present for (my personal opinion about this doesn't really
> matter, so let me avoid wasting time on expressing it).
> 
> Now, it evidently has been re-purposed to mark PCIe root ports that
> require devices under them to be put into D3hot in the suspend path
> (and it now means any device under the root port with this property,
> at least in some cases).
> 
>> Also no need for the empty-ish line at the end.
> 
> Right.
>
Rafael J. Wysocki June 8, 2021, 3:27 p.m. UTC | #4
On Tue, Jun 8, 2021 at 4:18 PM Limonciello, Mario
<mario.limonciello@amd.com> wrote:
>
> On 6/8/2021 06:20, Rafael J. Wysocki wrote:
> > On Tue, Jun 8, 2021 at 7:35 AM Christoph Hellwig <hch@lst.de> wrote:
> >>
> >> On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
> >>> +/**
> >>> + * acpi_storage_d3 - Check if a storage device should use D3.
> >
> > Let's be specific about what D3 means here in the first place and
> > that's D3hot AFAICS.
> >
> > And the comment should be something like "Check whether or not to use
> > D3hot in the suspend path".
>
> Actually it can be D3hot or D3cold.  Microsoft's documentation doesn't
> indicate it's D3hot.  On the AMD platforms that prompted some of these
> changes it's D3cold.

So say "D3" in the one-line description above and "D3hot or D3cold (if
supported)" in the more detailed comment below.

> >
> >>> + * @dev: Device to check
> >>> + *
> >>> + * Returns %true if @dev should be put into D3 when the ->suspend method is
> >>> + * called, else %false.  The name of this function is somewhat misleading
> >>> + * as it has nothing to do with storage except for the name of the ACPI
> >>> + * property.  On some platforms resume will not work if this hint is ignored.
> >
> > I would write it this way:
> >
> > "Return %true if the platform firmware wants @dev to be programmed
> > into D3hot in the suspend path, or %false when there is no specific
> > preference. On some platforms, if this hint is ignored, @dev may
> > remain unresponsive after suspending the platform as a whole."
> >
> > And I'm not sure if it is necessary to mention "storage" in this comment at all.
> >
>
> Is your thought here in not mentioning "storage" that this symbol may be
> overloaded in the future to look at more than just the StorageD3Enable
> property and used for other things too?

Well, the property itself is not about storage any more anyway.
Keith Busch June 8, 2021, 8:01 p.m. UTC | #5
On Tue, Jun 08, 2021 at 07:35:46AM +0200, Christoph Hellwig wrote:
> On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
> > +/**
> > + * acpi_storage_d3 - Check if a storage device should use D3.
> > + * @dev: Device to check
> > + *
> > + * Returns %true if @dev should be put into D3 when the ->suspend method is
> > + * called, else %false.  The name of this function is somewhat misleading
> > + * as it has nothing to do with storage except for the name of the ACPI
> > + * property.  On some platforms resume will not work if this hint is ignored.
> > + *
> > + */
> 
> I still do not like this comment.  There is nothing about only using this
> for storage devices.  It is specific to a PCIe slot, and if I plug
> something that is not a storage device into it the same restrictions
> still apply.

Hm, I thought this comment was good. Despite the dupious connection to
storage, the function name matches the ACPI property, so an explanation
for this misnomer seems appropriate.
Christoph Hellwig June 9, 2021, 1 p.m. UTC | #6
On Tue, Jun 08, 2021 at 01:01:01PM -0700, Keith Busch wrote:
> On Tue, Jun 08, 2021 at 07:35:46AM +0200, Christoph Hellwig wrote:
> > On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
> > > +/**
> > > + * acpi_storage_d3 - Check if a storage device should use D3.
> > > + * @dev: Device to check
> > > + *
> > > + * Returns %true if @dev should be put into D3 when the ->suspend method is
> > > + * called, else %false.  The name of this function is somewhat misleading
> > > + * as it has nothing to do with storage except for the name of the ACPI
> > > + * property.  On some platforms resume will not work if this hint is ignored.
> > > + *
> > > + */
> > 
> > I still do not like this comment.  There is nothing about only using this
> > for storage devices.  It is specific to a PCIe slot, and if I plug
> > something that is not a storage device into it the same restrictions
> > still apply.
> 
> Hm, I thought this comment was good. Despite the dupious connection to
> storage, the function name matches the ACPI property, so an explanation
> for this misnomer seems appropriate.

I suggested a comment earlier that explains the connection without being
completely misleading.
diff mbox series

Patch

diff --git a/drivers/acpi/device_pm.c b/drivers/acpi/device_pm.c
index d260bc1f3e6e..1edb68d00b8e 100644
--- a/drivers/acpi/device_pm.c
+++ b/drivers/acpi/device_pm.c
@@ -1340,4 +1340,29 @@  int acpi_dev_pm_attach(struct device *dev, bool power_on)
 	return 1;
 }
 EXPORT_SYMBOL_GPL(acpi_dev_pm_attach);
+
+/**
+ * acpi_storage_d3 - Check if a storage device should use D3.
+ * @dev: Device to check
+ *
+ * Returns %true if @dev should be put into D3 when the ->suspend method is
+ * called, else %false.  The name of this function is somewhat misleading
+ * as it has nothing to do with storage except for the name of the ACPI
+ * property.  On some platforms resume will not work if this hint is ignored.
+ *
+ */
+bool acpi_storage_d3(struct device *dev)
+{
+	struct acpi_device *adev = ACPI_COMPANION(dev);
+	u8 val;
+
+	if (!adev)
+		return false;
+	if (fwnode_property_read_u8(acpi_fwnode_handle(adev), "StorageD3Enable",
+			&val))
+		return false;
+	return val == 1;
+}
+EXPORT_SYMBOL_GPL(acpi_storage_d3);
+
 #endif /* CONFIG_PM */
diff --git a/drivers/nvme/host/pci.c b/drivers/nvme/host/pci.c
index 3aa7245a505f..8fbc4c87a0d8 100644
--- a/drivers/nvme/host/pci.c
+++ b/drivers/nvme/host/pci.c
@@ -2828,32 +2828,6 @@  static unsigned long check_vendor_combination_bug(struct pci_dev *pdev)
 	return 0;
 }
 
-#ifdef CONFIG_ACPI
-static bool nvme_acpi_storage_d3(struct pci_dev *dev)
-{
-	struct acpi_device *adev = ACPI_COMPANION(&dev->dev);
-	u8 val;
-
-	/*
-	 * Look for _DSD property specifying that the storage device on the port
-	 * must use D3 to support deep platform power savings during
-	 * suspend-to-idle.
-	 */
-
-	if (!adev)
-		return false;
-	if (fwnode_property_read_u8(acpi_fwnode_handle(adev), "StorageD3Enable",
-			&val))
-		return false;
-	return val == 1;
-}
-#else
-static inline bool nvme_acpi_storage_d3(struct pci_dev *dev)
-{
-	return false;
-}
-#endif /* CONFIG_ACPI */
-
 static void nvme_async_probe(void *data, async_cookie_t cookie)
 {
 	struct nvme_dev *dev = data;
@@ -2903,7 +2877,7 @@  static int nvme_probe(struct pci_dev *pdev, const struct pci_device_id *id)
 
 	quirks |= check_vendor_combination_bug(pdev);
 
-	if (!noacpi && nvme_acpi_storage_d3(pdev)) {
+	if (!noacpi && acpi_storage_d3(&pdev->dev)) {
 		/*
 		 * Some systems use a bios work around to ask for D3 on
 		 * platforms that support kernel managed suspend.
diff --git a/include/linux/acpi.h b/include/linux/acpi.h
index c60745f657e9..dd0dafd21e33 100644
--- a/include/linux/acpi.h
+++ b/include/linux/acpi.h
@@ -1004,6 +1004,7 @@  int acpi_dev_resume(struct device *dev);
 int acpi_subsys_runtime_suspend(struct device *dev);
 int acpi_subsys_runtime_resume(struct device *dev);
 int acpi_dev_pm_attach(struct device *dev, bool power_on);
+bool acpi_storage_d3(struct device *dev);
 #else
 static inline int acpi_subsys_runtime_suspend(struct device *dev) { return 0; }
 static inline int acpi_subsys_runtime_resume(struct device *dev) { return 0; }
@@ -1011,6 +1012,10 @@  static inline int acpi_dev_pm_attach(struct device *dev, bool power_on)
 {
 	return 0;
 }
+static inline bool acpi_storage_d3(struct device *dev)
+{
+	return false;
+}
 #endif
 
 #if defined(CONFIG_ACPI) && defined(CONFIG_PM_SLEEP)