diff mbox series

[v2] reset: make shared pulsed reset controls re-triggerable

Message ID 20201112230043.28987-1-aouledameur@baylibre.com (mailing list archive)
State New, archived
Headers show
Series [v2] reset: make shared pulsed reset controls re-triggerable | expand

Commit Message

Amjad Ouled-Ameur Nov. 12, 2020, 11 p.m. UTC
The current reset framework API does not allow to release what is done by
reset_control_reset(), IOW decrement triggered_count. Add the new
reset_control_rearm() call to do so.

When reset_control_reset() has been called once, the counter
triggered_count, in the reset framework, is incremented i.e the resource
under the reset is in-use and the reset should not be done again.
reset_control_rearm() would be the way to state that the resource is
no longer used and, that from the caller's perspective, the reset can be
fired again if necessary.

Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
Reported-by: Jerome Brunet <jbrunet@baylibre.com>
---
Change since v1: [0]
* Renamed the new call from reset_control_(array_)resettable to 
reset_control_(array_)rearm
* Open-coded reset_control_array_rearm to check for errors before
decrementing triggered_count because we cannot roll back in case an
error occurs while decrementing one of the rstc.
* Reworded the new call's description.

[0] https://lore.kernel.org/lkml/20201001132758.12280-1-aouledameur@baylibre.com

 drivers/reset/core.c  | 73 +++++++++++++++++++++++++++++++++++++++++++
 include/linux/reset.h |  1 +
 2 files changed, 74 insertions(+)

Comments

Amjad Ouled-Ameur Nov. 13, 2020, 12:12 a.m. UTC | #1
Please find in this patchset [0] a use case of the reset_control_rearm() call
on some of meson usb drivers:


[0] https://lore.kernel.org/lkml/20201113000508.14702-1-aouledameur@baylibre.com/

On 13/11/2020 00:00, Amjad Ouled-Ameur wrote:

> The current reset framework API does not allow to release what is done by
> reset_control_reset(), IOW decrement triggered_count. Add the new
> reset_control_rearm() call to do so.
>
> When reset_control_reset() has been called once, the counter
> triggered_count, in the reset framework, is incremented i.e the resource
> under the reset is in-use and the reset should not be done again.
> reset_control_rearm() would be the way to state that the resource is
> no longer used and, that from the caller's perspective, the reset can be
> fired again if necessary.
>
> Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
> Reported-by: Jerome Brunet <jbrunet@baylibre.com>
> ---
> Change since v1: [0]
> * Renamed the new call from reset_control_(array_)resettable to
> reset_control_(array_)rearm
> * Open-coded reset_control_array_rearm to check for errors before
> decrementing triggered_count because we cannot roll back in case an
> error occurs while decrementing one of the rstc.
> * Reworded the new call's description.
>
> [0] https://lore.kernel.org/lkml/20201001132758.12280-1-aouledameur@baylibre.com
>
>   drivers/reset/core.c  | 73 +++++++++++++++++++++++++++++++++++++++++++
>   include/linux/reset.h |  1 +
>   2 files changed, 74 insertions(+)
>
> diff --git a/drivers/reset/core.c b/drivers/reset/core.c
> index a2df88e90011..34e89aa0fb5e 100644
> --- a/drivers/reset/core.c
> +++ b/drivers/reset/core.c
> @@ -208,6 +208,39 @@ static int reset_control_array_reset(struct reset_control_array *resets)
>   	return 0;
>   }
>   
> +static int reset_control_array_rearm(struct reset_control_array *resets)
> +{
> +	struct reset_control *rstc;
> +	int i;
> +
> +	for (i = 0; i < resets->num_rstcs; i++) {
> +		rstc = resets->rstc[i];
> +
> +		if (!rstc)
> +			continue;
> +
> +		if (WARN_ON(IS_ERR(rstc)))
> +			return -EINVAL;
> +
> +		if (rstc->shared) {
> +			if (WARN_ON(atomic_read(&rstc->deassert_count) != 0))
> +				return -EINVAL;
> +		} else {
> +			if (!rstc->acquired)
> +				return -EPERM;
> +		}
> +	}
> +
> +	for (i = 0; i < resets->num_rstcs; i++) {
> +		rstc = resets->rstc[i];
> +
> +		if (rstc && rstc->shared)
> +			WARN_ON(atomic_dec_return(&rstc->triggered_count) < 0);
> +	}
> +
> +	return 0;
> +}
> +
>   static int reset_control_array_assert(struct reset_control_array *resets)
>   {
>   	int ret, i;
> @@ -325,6 +358,46 @@ int reset_control_reset(struct reset_control *rstc)
>   }
>   EXPORT_SYMBOL_GPL(reset_control_reset);
>   
> +/**
> + * reset_control_rearm - allow shared reset line to be re-triggered"
> + * @rstc: reset controller
> + *
> + * On a shared reset line the actual reset pulse is only triggered once for the
> + * lifetime of the reset_control instance, except if this call is used.
> + *
> + * Calls to this function must be balanced with calls to reset_control_reset,
> + * a warning is thrown in case triggered_count ever dips below 0.
> + *
> + * Consumers must not use reset_control_(de)assert on shared reset lines when
> + * reset_control_reset or reset_control_rearm have been used.
> + *
> + * If rstc is NULL the function will just return 0.
> + */
> +int reset_control_rearm(struct reset_control *rstc)
> +{
> +	if (!rstc)
> +		return 0;
> +
> +	if (WARN_ON(IS_ERR(rstc)))
> +		return -EINVAL;
> +
> +	if (reset_control_is_array(rstc))
> +		return reset_control_array_rearm(rstc_to_array(rstc));
> +
> +	if (rstc->shared) {
> +		if (WARN_ON(atomic_read(&rstc->deassert_count) != 0))
> +			return -EINVAL;
> +
> +		WARN_ON(atomic_dec_return(&rstc->triggered_count) < 0);
> +	} else {
> +		if (!rstc->acquired)
> +			return -EPERM;
> +	}
> +
> +	return 0;
> +}
> +EXPORT_SYMBOL_GPL(reset_control_rearm);
> +
>   /**
>    * reset_control_assert - asserts the reset line
>    * @rstc: reset controller
> diff --git a/include/linux/reset.h b/include/linux/reset.h
> index 05aa9f440f48..439fec7112a9 100644
> --- a/include/linux/reset.h
> +++ b/include/linux/reset.h
> @@ -13,6 +13,7 @@ struct reset_control;
>   #ifdef CONFIG_RESET_CONTROLLER
>   
>   int reset_control_reset(struct reset_control *rstc);
> +int reset_control_rearm(struct reset_control *rstc);
>   int reset_control_assert(struct reset_control *rstc);
>   int reset_control_deassert(struct reset_control *rstc);
>   int reset_control_status(struct reset_control *rstc);
Philipp Zabel Nov. 13, 2020, 3:04 p.m. UTC | #2
On Fri, 2020-11-13 at 00:00 +0100, Amjad Ouled-Ameur wrote:
> The current reset framework API does not allow to release what is done by
> reset_control_reset(), IOW decrement triggered_count. Add the new
> reset_control_rearm() call to do so.
> 
> When reset_control_reset() has been called once, the counter
> triggered_count, in the reset framework, is incremented i.e the resource
> under the reset is in-use and the reset should not be done again.
> reset_control_rearm() would be the way to state that the resource is
> no longer used and, that from the caller's perspective, the reset can be
> fired again if necessary.
> 
> Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
> Reported-by: Jerome Brunet <jbrunet@baylibre.com>
> ---
> Change since v1: [0]
> * Renamed the new call from reset_control_(array_)resettable to 
> reset_control_(array_)rearm
> * Open-coded reset_control_array_rearm to check for errors before
> decrementing triggered_count because we cannot roll back in case an
> error occurs while decrementing one of the rstc.
> * Reworded the new call's description.

Thank you, applied to reset/next.

regards
Philipp
Jerome Brunet Nov. 13, 2020, 3:13 p.m. UTC | #3
On Fri 13 Nov 2020 at 16:04, Philipp Zabel <p.zabel@pengutronix.de> wrote:

> On Fri, 2020-11-13 at 00:00 +0100, Amjad Ouled-Ameur wrote:
>> The current reset framework API does not allow to release what is done by
>> reset_control_reset(), IOW decrement triggered_count. Add the new
>> reset_control_rearm() call to do so.
>> 
>> When reset_control_reset() has been called once, the counter
>> triggered_count, in the reset framework, is incremented i.e the resource
>> under the reset is in-use and the reset should not be done again.
>> reset_control_rearm() would be the way to state that the resource is
>> no longer used and, that from the caller's perspective, the reset can be
>> fired again if necessary.
>> 
>> Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
>> Reported-by: Jerome Brunet <jbrunet@baylibre.com>
>> ---
>> Change since v1: [0]
>> * Renamed the new call from reset_control_(array_)resettable to 
>> reset_control_(array_)rearm
>> * Open-coded reset_control_array_rearm to check for errors before
>> decrementing triggered_count because we cannot roll back in case an
>> error occurs while decrementing one of the rstc.
>> * Reworded the new call's description.
>
> Thank you, applied to reset/next.

Hi Philipp,

Would it be possible to get an immutable branch/tag with this ?
It would allow to move forward on the USB side, without waiting for the
next rc1.

Thx
Jerome

>
> regards
> Philipp
Amjad Ouled-Ameur Nov. 13, 2020, 3:28 p.m. UTC | #4
On 13/11/2020 16:04, Philipp Zabel wrote:

> On Fri, 2020-11-13 at 00:00 +0100, Amjad Ouled-Ameur wrote:
>> The current reset framework API does not allow to release what is done by
>> reset_control_reset(), IOW decrement triggered_count. Add the new
>> reset_control_rearm() call to do so.
>>
>> When reset_control_reset() has been called once, the counter
>> triggered_count, in the reset framework, is incremented i.e the resource
>> under the reset is in-use and the reset should not be done again.
>> reset_control_rearm() would be the way to state that the resource is
>> no longer used and, that from the caller's perspective, the reset can be
>> fired again if necessary.
>>
>> Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
>> Reported-by: Jerome Brunet <jbrunet@baylibre.com>
>> ---
>> Change since v1: [0]
>> * Renamed the new call from reset_control_(array_)resettable to
>> reset_control_(array_)rearm
>> * Open-coded reset_control_array_rearm to check for errors before
>> decrementing triggered_count because we cannot roll back in case an
>> error occurs while decrementing one of the rstc.
>> * Reworded the new call's description.
> Thank you, applied to reset/next.
>
> regards
> Philipp

Thank you for reviewing and approving my patch !

Furthermore, I think your idea of open coding reset_control_array_rearm
was accurate, and should be also applied to reset_control_array_reset()
and reset_control_array_(de)assert()

What do you think ?

In case you agree it is necessary to do so, I can work out an upcoming
patchset to fix this matter.

Best,
Amjad
Philipp Zabel Nov. 16, 2020, 4:36 p.m. UTC | #5
On Fri, 2020-11-13 at 16:13 +0100, Jerome Brunet wrote:
> On Fri 13 Nov 2020 at 16:04, Philipp Zabel <p.zabel@pengutronix.de> wrote:
> 
> > On Fri, 2020-11-13 at 00:00 +0100, Amjad Ouled-Ameur wrote:
> > > The current reset framework API does not allow to release what is done by
> > > reset_control_reset(), IOW decrement triggered_count. Add the new
> > > reset_control_rearm() call to do so.
> > > 
> > > When reset_control_reset() has been called once, the counter
> > > triggered_count, in the reset framework, is incremented i.e the resource
> > > under the reset is in-use and the reset should not be done again.
> > > reset_control_rearm() would be the way to state that the resource is
> > > no longer used and, that from the caller's perspective, the reset can be
> > > fired again if necessary.
> > > 
> > > Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
> > > Reported-by: Jerome Brunet <jbrunet@baylibre.com>
> > > ---
> > > Change since v1: [0]
> > > * Renamed the new call from reset_control_(array_)resettable to 
> > > reset_control_(array_)rearm
> > > * Open-coded reset_control_array_rearm to check for errors before
> > > decrementing triggered_count because we cannot roll back in case an
> > > error occurs while decrementing one of the rstc.
> > > * Reworded the new call's description.
> > 
> > Thank you, applied to reset/next.
> 
> Hi Philipp,
> 
> Would it be possible to get an immutable branch/tag with this ?
> It would allow to move forward on the USB side, without waiting for the
> next rc1.

Here you go,

The following changes since commit 3650b228f83adda7e5ee532e2b90429c03f7b9ec:

  Linux 5.10-rc1 (2020-10-25 15:14:11 -0700)

are available in the Git repository at:

  git://git.pengutronix.de/git/pza/linux.git reset/shared-retrigger

for you to fetch changes up to 557acb3d2cd9c82de19f944f6cc967a347735385:

  reset: make shared pulsed reset controls re-triggerable (2020-11-16 17:05:28 +0100)

----------------------------------------------------------------
Amjad Ouled-Ameur (1):
      reset: make shared pulsed reset controls re-triggerable

 drivers/reset/core.c  | 73 +++++++++++++++++++++++++++++++++++++++++++++++++++
 include/linux/reset.h |  1 +
 2 files changed, 74 insertions(+)

regards
Philipp
Jerome Brunet Nov. 16, 2020, 4:41 p.m. UTC | #6
On Mon 16 Nov 2020 at 17:36, Philipp Zabel <p.zabel@pengutronix.de> wrote:

> On Fri, 2020-11-13 at 16:13 +0100, Jerome Brunet wrote:
>> On Fri 13 Nov 2020 at 16:04, Philipp Zabel <p.zabel@pengutronix.de> wrote:
>> 
>> > On Fri, 2020-11-13 at 00:00 +0100, Amjad Ouled-Ameur wrote:
>> > > The current reset framework API does not allow to release what is done by
>> > > reset_control_reset(), IOW decrement triggered_count. Add the new
>> > > reset_control_rearm() call to do so.
>> > > 
>> > > When reset_control_reset() has been called once, the counter
>> > > triggered_count, in the reset framework, is incremented i.e the resource
>> > > under the reset is in-use and the reset should not be done again.
>> > > reset_control_rearm() would be the way to state that the resource is
>> > > no longer used and, that from the caller's perspective, the reset can be
>> > > fired again if necessary.
>> > > 
>> > > Signed-off-by: Amjad Ouled-Ameur <aouledameur@baylibre.com>
>> > > Reported-by: Jerome Brunet <jbrunet@baylibre.com>
>> > > ---
>> > > Change since v1: [0]
>> > > * Renamed the new call from reset_control_(array_)resettable to 
>> > > reset_control_(array_)rearm
>> > > * Open-coded reset_control_array_rearm to check for errors before
>> > > decrementing triggered_count because we cannot roll back in case an
>> > > error occurs while decrementing one of the rstc.
>> > > * Reworded the new call's description.
>> > 
>> > Thank you, applied to reset/next.
>> 
>> Hi Philipp,
>> 
>> Would it be possible to get an immutable branch/tag with this ?
>> It would allow to move forward on the USB side, without waiting for the
>> next rc1.
>
> Here you go,
>
> The following changes since commit 3650b228f83adda7e5ee532e2b90429c03f7b9ec:
>
>   Linux 5.10-rc1 (2020-10-25 15:14:11 -0700)
>
> are available in the Git repository at:
>
>   git://git.pengutronix.de/git/pza/linux.git reset/shared-retrigger
>
> for you to fetch changes up to 557acb3d2cd9c82de19f944f6cc967a347735385:
>
>   reset: make shared pulsed reset controls re-triggerable (2020-11-16 17:05:28 +0100)
>
> ----------------------------------------------------------------
> Amjad Ouled-Ameur (1):
>       reset: make shared pulsed reset controls re-triggerable
>
>  drivers/reset/core.c  | 73 +++++++++++++++++++++++++++++++++++++++++++++++++++
>  include/linux/reset.h |  1 +
>  2 files changed, 74 insertions(+)
>

Thx Philipp !

> regards
> Philipp
diff mbox series

Patch

diff --git a/drivers/reset/core.c b/drivers/reset/core.c
index a2df88e90011..34e89aa0fb5e 100644
--- a/drivers/reset/core.c
+++ b/drivers/reset/core.c
@@ -208,6 +208,39 @@  static int reset_control_array_reset(struct reset_control_array *resets)
 	return 0;
 }
 
+static int reset_control_array_rearm(struct reset_control_array *resets)
+{
+	struct reset_control *rstc;
+	int i;
+
+	for (i = 0; i < resets->num_rstcs; i++) {
+		rstc = resets->rstc[i];
+
+		if (!rstc)
+			continue;
+
+		if (WARN_ON(IS_ERR(rstc)))
+			return -EINVAL;
+
+		if (rstc->shared) {
+			if (WARN_ON(atomic_read(&rstc->deassert_count) != 0))
+				return -EINVAL;
+		} else {
+			if (!rstc->acquired)
+				return -EPERM;
+		}
+	}
+
+	for (i = 0; i < resets->num_rstcs; i++) {
+		rstc = resets->rstc[i];
+
+		if (rstc && rstc->shared)
+			WARN_ON(atomic_dec_return(&rstc->triggered_count) < 0);
+	}
+
+	return 0;
+}
+
 static int reset_control_array_assert(struct reset_control_array *resets)
 {
 	int ret, i;
@@ -325,6 +358,46 @@  int reset_control_reset(struct reset_control *rstc)
 }
 EXPORT_SYMBOL_GPL(reset_control_reset);
 
+/**
+ * reset_control_rearm - allow shared reset line to be re-triggered"
+ * @rstc: reset controller
+ *
+ * On a shared reset line the actual reset pulse is only triggered once for the
+ * lifetime of the reset_control instance, except if this call is used.
+ *
+ * Calls to this function must be balanced with calls to reset_control_reset,
+ * a warning is thrown in case triggered_count ever dips below 0.
+ *
+ * Consumers must not use reset_control_(de)assert on shared reset lines when
+ * reset_control_reset or reset_control_rearm have been used.
+ *
+ * If rstc is NULL the function will just return 0.
+ */
+int reset_control_rearm(struct reset_control *rstc)
+{
+	if (!rstc)
+		return 0;
+
+	if (WARN_ON(IS_ERR(rstc)))
+		return -EINVAL;
+
+	if (reset_control_is_array(rstc))
+		return reset_control_array_rearm(rstc_to_array(rstc));
+
+	if (rstc->shared) {
+		if (WARN_ON(atomic_read(&rstc->deassert_count) != 0))
+			return -EINVAL;
+
+		WARN_ON(atomic_dec_return(&rstc->triggered_count) < 0);
+	} else {
+		if (!rstc->acquired)
+			return -EPERM;
+	}
+
+	return 0;
+}
+EXPORT_SYMBOL_GPL(reset_control_rearm);
+
 /**
  * reset_control_assert - asserts the reset line
  * @rstc: reset controller
diff --git a/include/linux/reset.h b/include/linux/reset.h
index 05aa9f440f48..439fec7112a9 100644
--- a/include/linux/reset.h
+++ b/include/linux/reset.h
@@ -13,6 +13,7 @@  struct reset_control;
 #ifdef CONFIG_RESET_CONTROLLER
 
 int reset_control_reset(struct reset_control *rstc);
+int reset_control_rearm(struct reset_control *rstc);
 int reset_control_assert(struct reset_control *rstc);
 int reset_control_deassert(struct reset_control *rstc);
 int reset_control_status(struct reset_control *rstc);