Message ID | 1580117979-4629-1-git-send-email-peng.fan@nxp.com (mailing list archive) |
---|---|
Headers | show |
Series | soc: imx: increase build coverage for imx8 soc driver | expand |
On Mon, Jan 27, 2020 at 10:44 AM Peng Fan <peng.fan@nxp.com> wrote: > > From: Peng Fan <peng.fan@nxp.com> > > > V2: > Include Leonard's patch to fix build break after enable compile test > Add Leonard's R-b tag > > Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family > Add SOC_IMX8M for build gate soc-imx8m.c > Increase build coverage for i.MX SoC driver The changes all look good to me, but I'd just do it all in one combined patch, as the changes are all logically part of the same thing. You can leave Leonard's fix as a [PATCH 1/2] if you want, but the rest should clearly be a single change. Arnd
Hi Arnd, > Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for imx8 soc > driver > > On Mon, Jan 27, 2020 at 10:44 AM Peng Fan <peng.fan@nxp.com> wrote: > > > > From: Peng Fan <peng.fan@nxp.com> > > > > > > V2: > > Include Leonard's patch to fix build break after enable compile test > > Add Leonard's R-b tag > > > > Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family Add > > SOC_IMX8M for build gate soc-imx8m.c Increase build coverage for i.MX > > SoC driver > > The changes all look good to me, but I'd just do it all in one combined patch, as > the changes are all logically part of the same thing. You can leave Leonard's fix > as a [PATCH 1/2] if you want, but the rest should clearly be a single change. There is a arm64 defconfig change, should it be also included in the single change? Thanks, Peng. > > Arnd
On Mon, Jan 27, 2020 at 1:33 PM Peng Fan <peng.fan@nxp.com> wrote: > > Hi Arnd, > > > Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for imx8 soc > > driver > > > > On Mon, Jan 27, 2020 at 10:44 AM Peng Fan <peng.fan@nxp.com> wrote: > > > > > > From: Peng Fan <peng.fan@nxp.com> > > > > > > > > > V2: > > > Include Leonard's patch to fix build break after enable compile test > > > Add Leonard's R-b tag > > > > > > Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family Add > > > SOC_IMX8M for build gate soc-imx8m.c Increase build coverage for i.MX > > > SoC driver > > > > The changes all look good to me, but I'd just do it all in one combined patch, as > > the changes are all logically part of the same thing. You can leave Leonard's fix > > as a [PATCH 1/2] if you want, but the rest should clearly be a single change. > > There is a arm64 defconfig change, should it be also included in the single change? Good point, that one is probably better left separate indeed. Arnd
> Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for imx8 soc > driver > > On Mon, Jan 27, 2020 at 1:33 PM Peng Fan <peng.fan@nxp.com> wrote: > > > > Hi Arnd, > > > > > Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for > > > imx8 soc driver > > > > > > On Mon, Jan 27, 2020 at 10:44 AM Peng Fan <peng.fan@nxp.com> wrote: > > > > > > > > From: Peng Fan <peng.fan@nxp.com> > > > > > > > > > > > > V2: > > > > Include Leonard's patch to fix build break after enable compile > > > > test Add Leonard's R-b tag > > > > > > > > Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family Add > > > > SOC_IMX8M for build gate soc-imx8m.c Increase build coverage for > > > > i.MX SoC driver > > > > > > The changes all look good to me, but I'd just do it all in one > > > combined patch, as the changes are all logically part of the same > > > thing. You can leave Leonard's fix as a [PATCH 1/2] if you want, but the > rest should clearly be a single change. > > > > There is a arm64 defconfig change, should it be also included in the single > change? > > Good point, that one is probably better left separate indeed. Since the defconfig change needs stay alone in a patch, merge other patches into one might not be good. The patchset I did is to make sure the soc-imx8m.c could always be built. If I merge the others into one, without the defconfig patch set CONFIG option to y, soc-imx8m.c will not be built. This might break git bisect to check the soc-imx8m.c So I prefer not to merge the others into one patch. Do you agree? Thanks, Peng. > > Arnd
On Mon, Jan 27, 2020 at 2:22 PM Peng Fan <peng.fan@nxp.com> wrote: > > > Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for imx8 soc > > driver > > > > On Mon, Jan 27, 2020 at 1:33 PM Peng Fan <peng.fan@nxp.com> wrote: > > > > > > > Subject: Re: [PATCH V2 0/5] soc: imx: increase build coverage for > > > > imx8 soc driver > > > > > > > > On Mon, Jan 27, 2020 at 10:44 AM Peng Fan <peng.fan@nxp.com> wrote: > > > > > > > > > > From: Peng Fan <peng.fan@nxp.com> > > > > > > > > > > > > > > > V2: > > > > > Include Leonard's patch to fix build break after enable compile > > > > > test Add Leonard's R-b tag > > > > > > > > > > Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family Add > > > > > SOC_IMX8M for build gate soc-imx8m.c Increase build coverage for > > > > > i.MX SoC driver > > > > > > > > The changes all look good to me, but I'd just do it all in one > > > > combined patch, as the changes are all logically part of the same > > > > thing. You can leave Leonard's fix as a [PATCH 1/2] if you want, but the > > rest should clearly be a single change. > > > > > > There is a arm64 defconfig change, should it be also included in the single > > change? > > > > Good point, that one is probably better left separate indeed. > > Since the defconfig change needs stay alone in a patch, > merge other patches into one might not be good. The patchset > I did is to make sure the soc-imx8m.c could always be built. If > I merge the others into one, without the defconfig patch set CONFIG > option to y, soc-imx8m.c will not be built. This might break git bisect > to check the soc-imx8m.c > > So I prefer not to merge the others into one patch. Do you agree? I'm generally not too worried about intermittent defconfig breaks during bisection, as the defconfig is not use all that much in practice. Splitting the other changes into separate patches wouldn't help here either unless you want to spread it out over multiple merge windows. I'd probably just put it all in one patch (including the defconfig change) in this case, alternatively you could add a 'default ARCH_MXC && ARM64' to the Kconfig symbol. Arnd
From: Peng Fan <peng.fan@nxp.com> V2: Include Leonard's patch to fix build break after enable compile test Add Leonard's R-b tag Rename soc-imx8.c to soc-imx8m.c which is for i.MX8M family Add SOC_IMX8M for build gate soc-imx8m.c Increase build coverage for i.MX SoC driver Leonard Crestez (1): soc: imx: gpcv2: include linux/sizes.h Peng Fan (4): soc: imx: Kconfig: add SOC_IMX8M entry arm64: defconfig: Enable CONFIG_SOC_IMX8M by default soc: Makefile: increase build coverage for i.MX soc: imx: Use CONFIG_SOC_IMX8M as build gate arch/arm64/configs/defconfig | 1 + drivers/soc/Makefile | 2 +- drivers/soc/imx/Kconfig | 8 ++++++++ drivers/soc/imx/Makefile | 2 +- drivers/soc/imx/gpcv2.c | 1 + drivers/soc/imx/{soc-imx8.c => soc-imx8m.c} | 0 6 files changed, 12 insertions(+), 2 deletions(-) rename drivers/soc/imx/{soc-imx8.c => soc-imx8m.c} (100%)