mbox series

[v10,00/18] arm64: MMU enabled kexec relocation

Message ID 20210125191923.1060122-1-pasha.tatashin@soleen.com (mailing list archive)
Headers show
Series arm64: MMU enabled kexec relocation | expand

Message

Pavel Tatashin Jan. 25, 2021, 7:19 p.m. UTC
Changelog:
v10:
	- Addressed a lot of comments form James Morse and from  Marc Zyngier
	- Added review-by's
	- Synchronized with mainline

v9:	- 9 patches from previous series landed in upstream, so now series
	  is smaller
	- Added two patches from James Morse to address idmap issues for machines
	  with high physical addresses.
	- Addressed comments from Selin Dag about compiling issues. He also tested
	  my series and got similar performance results: ~60 ms instead of ~580 ms
	  with an initramfs size of ~120MB.
v8:
	- Synced with mainline to keep series up-to-date
v7:
	-- Addressed comments from James Morse
	- arm64: hibernate: pass the allocated pgdp to ttbr0
	  Removed "Fixes" tag, and added Added Reviewed-by: James Morse
	- arm64: hibernate: check pgd table allocation
	  Sent out as a standalone patch so it can be sent to stable
	  Series applies on mainline + this patch
	- arm64: hibernate: add trans_pgd public functions
	  Remove second allocation of tmp_pg_dir in swsusp_arch_resume
	  Added Reviewed-by: James Morse <james.morse@arm.com>
	- arm64: kexec: move relocation function setup and clean up
	  Fixed typo in commit log
	  Changed kern_reloc to phys_addr_t types.
	  Added explanation why kern_reloc is needed.
	  Split into four patches:
	  arm64: kexec: make dtb_mem always enabled
	  arm64: kexec: remove unnecessary debug prints
	  arm64: kexec: call kexec_image_info only once
	  arm64: kexec: move relocation function setup
	- arm64: kexec: add expandable argument to relocation function
	  Changed types of new arguments from unsigned long to phys_addr_t.
	  Changed offset prefix to KEXEC_*
	  Split into four patches:
	  arm64: kexec: cpu_soft_restart change argument types
	  arm64: kexec: arm64_relocate_new_kernel clean-ups
	  arm64: kexec: arm64_relocate_new_kernel don't use x0 as temp
	  arm64: kexec: add expandable argument to relocation function
	- arm64: kexec: configure trans_pgd page table for kexec
	  Added invalid entries into EL2 vector table
	  Removed KEXEC_EL2_VECTOR_TABLE_SIZE and KEXEC_EL2_VECTOR_TABLE_OFFSET
	  Copy relocation functions and table into separate pages
	  Changed types in kern_reloc_arg.
	  Split into three patches:
	  arm64: kexec: offset for relocation function
	  arm64: kexec: kexec EL2 vectors
	  arm64: kexec: configure trans_pgd page table for kexec
	- arm64: kexec: enable MMU during kexec relocation
	  Split into two patches:
	  arm64: kexec: enable MMU during kexec relocation
	  arm64: kexec: remove head from relocation argument
v6:
	- Sync with mainline tip
	- Added Acked's from Dave Young
v5:
	- Addressed comments from Matthias Brugger: added review-by's, improved
	  comments, and made cleanups to swsusp_arch_resume() in addition to
	  create_safe_exec_page().
	- Synced with mainline tip.
v4:
	- Addressed comments from James Morse.
	- Split "check pgd table allocation" into two patches, and moved to
	  the beginning of series  for simpler backport of the fixes.
	  Added "Fixes:" tags to commit logs.
	- Changed "arm64, hibernate:" to "arm64: hibernate:"
	- Added Reviewed-by's
	- Moved "add PUD_SECT_RDONLY" earlier in series to be with other
	  clean-ups
	- Added "Derived from:" to arch/arm64/mm/trans_pgd.c
	- Removed "flags" from trans_info
	- Changed .trans_alloc_page assumption to return zeroed page.
	- Simplify changes to trans_pgd_map_page(), by keeping the old
	  code.
	- Simplify changes to trans_pgd_create_copy, by keeping the old
	  code.
	- Removed: "add trans_pgd_create_empty"
	- replace init_mm with NULL, and keep using non "__" version of
	  populate functions.
v3:
	- Split changes to create_safe_exec_page() into several patches for
	  easier review as request by Mark Rutland. This is why this series
	  has 3 more patches.
	- Renamed trans_table to tans_pgd as agreed with Mark. The header
	  comment in trans_pgd.c explains that trans stands for
	  transitional page tables. Meaning they are used in transition
	  between two kernels.
v2:
	- Fixed hibernate bug reported by James Morse
	- Addressed comments from James Morse:
	  * More incremental changes to trans_table
	  * Removed TRANS_FORCEMAP
	  * Added kexec reboot data for image with 380M in size.

Enable MMU during kexec relocation in order to improve reboot performance.

If kexec functionality is used for a fast system update, with a minimal
downtime, the relocation of kernel + initramfs takes a significant portion
of reboot.

The reason for slow relocation is because it is done without MMU, and thus
not benefiting from D-Cache.

Performance data
----------------
For this experiment, the size of kernel plus initramfs is small, only 25M.
If initramfs was larger, than the improvements would be greater, as time
spent in relocation is proportional to the size of relocation.

Previously:
kernel shutdown	0.022131328s
relocation	0.440510736s
kernel startup	0.294706768s

Relocation was taking: 58.2% of reboot time

Now:
kernel shutdown	0.032066576s
relocation	0.022158152s
kernel startup	0.296055880s

Now: Relocation takes 6.3% of reboot time

Total reboot is x2.16 times faster.

With bigger userland (fitImage 380M), the reboot time is improved by 3.57s,
and is reduced from 3.9s down to 0.33s

Previous approaches and discussions
-----------------------------------
v9: https://lore.kernel.org/lkml/20200326032420.27220-1-pasha.tatashin@soleen.com
v8: https://lore.kernel.org/lkml/20191204155938.2279686-1-pasha.tatashin@soleen.com
v7: https://lore.kernel.org/lkml/20191016200034.1342308-1-pasha.tatashin@soleen.com
v6: https://lore.kernel.org/lkml/20191004185234.31471-1-pasha.tatashin@soleen.com
v5: https://lore.kernel.org/lkml/20190923203427.294286-1-pasha.tatashin@soleen.com
v4: https://lore.kernel.org/lkml/20190909181221.309510-1-pasha.tatashin@soleen.com
v3: https://lore.kernel.org/lkml/20190821183204.23576-1-pasha.tatashin@soleen.com
v2: https://lore.kernel.org/lkml/20190817024629.26611-1-pasha.tatashin@soleen.com
v1: https://lore.kernel.org/lkml/20190801152439.11363-1-pasha.tatashin@soleen.com

Older approaches:
https://lore.kernel.org/lkml/20190709182014.16052-1-pasha.tatashin@soleen.com
reserve space for kexec to avoid relocation, involves changes to generic code
to optimize a problem that exists on arm64 only:

https://lore.kernel.org/lkml/20190716165641.6990-1-pasha.tatashin@soleen.com
The first attempt to enable MMU, some bugs that prevented performance
improvement. The page tables unnecessary configured idmap for the whole
physical space.

https://lore.kernel.org/lkml/20190731153857.4045-1-pasha.tatashin@soleen.com
No linear copy, bug with EL2 reboots.

James Morse (2):
  arm64: mm: Always update TCR_EL1 from __cpu_set_tcr_t0sz()
  arm64: trans_pgd: hibernate: idmap the single page that holds the copy
    page routines

Pavel Tatashin (16):
  arm64: kexec: make dtb_mem always enabled
  arm64: hibernate: variable pudp is used instead of pd4dp
  arm64: hibernate: move page handling function to new trans_pgd.c
  arm64: trans_pgd: make trans_pgd_map_page generic
  arm64: trans_pgd: pass allocator trans_pgd_create_copy
  arm64: trans_pgd: pass NULL instead of init_mm to *_populate functions
  arm64: kexec: move relocation function setup
  arm64: kexec: call kexec_image_info only once
  arm64: kexec: arm64_relocate_new_kernel clean-ups and optimizations
  arm64: kexec: arm64_relocate_new_kernel don't use x0 as temp
  arm64: kexec: add expandable argument to relocation function
  arm64: kexec: use ld script for relocation function
  arm64: kexec: kexec may require EL2 vectors
  arm64: kexec: configure trans_pgd page table for kexec
  arm64: kexec: enable MMU during kexec relocation
  arm64: kexec: remove head from relocation argument

 arch/arm64/Kconfig                   |   4 +
 arch/arm64/include/asm/kexec.h       |  42 +++-
 arch/arm64/include/asm/mmu_context.h |   7 +-
 arch/arm64/include/asm/sections.h    |   1 +
 arch/arm64/include/asm/trans_pgd.h   |  39 ++++
 arch/arm64/kernel/asm-offsets.c      |  15 ++
 arch/arm64/kernel/cpu-reset.S        |  11 +-
 arch/arm64/kernel/cpu-reset.h        |   8 +-
 arch/arm64/kernel/hibernate.c        | 271 +++-------------------
 arch/arm64/kernel/machine_kexec.c    | 182 +++++++++++----
 arch/arm64/kernel/relocate_kernel.S  | 218 ++++++++++--------
 arch/arm64/kernel/vmlinux.lds.S      |  19 ++
 arch/arm64/mm/Makefile               |   1 +
 arch/arm64/mm/trans_pgd.c            | 324 +++++++++++++++++++++++++++
 14 files changed, 749 insertions(+), 393 deletions(-)
 create mode 100644 arch/arm64/include/asm/trans_pgd.h
 create mode 100644 arch/arm64/mm/trans_pgd.c

Comments

Will Deacon Jan. 26, 2021, 10:58 p.m. UTC | #1
Hi Pavel,

On Mon, Jan 25, 2021 at 02:19:05PM -0500, Pavel Tatashin wrote:
> Changelog:
> v10:
> 	- Addressed a lot of comments form James Morse and from  Marc Zyngier
> 	- Added review-by's
> 	- Synchronized with mainline

This series has been doing the rounds for a while, but still isn't fully
reviewed. Would it help if I merged, e.g. the first 12 patches to reduce the
amount you have to repost?

Will
Pavel Tatashin Jan. 26, 2021, 11:05 p.m. UTC | #2
On Tue, Jan 26, 2021 at 5:58 PM Will Deacon <will@kernel.org> wrote:
>
> Hi Pavel,
>
> On Mon, Jan 25, 2021 at 02:19:05PM -0500, Pavel Tatashin wrote:
> > Changelog:
> > v10:
> >       - Addressed a lot of comments form James Morse and from  Marc Zyngier
> >       - Added review-by's
> >       - Synchronized with mainline
>
> This series has been doing the rounds for a while, but still isn't fully
> reviewed. Would it help if I merged, e.g. the first 12 patches to reduce the
> amount you have to repost?

Hi Will,

Yes, it would. The first 10 patches of this series were already merged
sometime ago:

a2c2e67923ec arm64: hibernate: add trans_pgd public functions
7ea4088938b7 arm64: hibernate: add PUD_SECT_RDONLY
13373f0e6580 arm64: hibernate: rename dst to page in create_safe_exec_page
a89d7ff933b0 arm64: hibernate: remove gotos as they are not needed
051a7a94aaa9 arm64: hibernate: use get_safe_page directly
d234332c2815 arm64: hibernate: pass the allocated pgdp to ttbr0
621516789ee6 arm64: kexec: make dtb_mem always enabled
3b54b743397e arm64: kexec: remove unnecessary debug prints
de68e4daea90 kexec: add machine_kexec_post_load()
d42cc530b18d kexec: quiet down kexec reboot

So, merging another ~12, would substantially help with getting
everything reviewed and merged.

Thank you,
Pavel

>
> Will
Will Deacon Jan. 26, 2021, 11:11 p.m. UTC | #3
On Tue, Jan 26, 2021 at 06:05:10PM -0500, Pavel Tatashin wrote:
> On Tue, Jan 26, 2021 at 5:58 PM Will Deacon <will@kernel.org> wrote:
> >
> > Hi Pavel,
> >
> > On Mon, Jan 25, 2021 at 02:19:05PM -0500, Pavel Tatashin wrote:
> > > Changelog:
> > > v10:
> > >       - Addressed a lot of comments form James Morse and from  Marc Zyngier
> > >       - Added review-by's
> > >       - Synchronized with mainline
> >
> > This series has been doing the rounds for a while, but still isn't fully
> > reviewed. Would it help if I merged, e.g. the first 12 patches to reduce the
> > amount you have to repost?
> 
> Hi Will,
> 
> Yes, it would. The first 10 patches of this series were already merged
> sometime ago:
> 
> a2c2e67923ec arm64: hibernate: add trans_pgd public functions
> 7ea4088938b7 arm64: hibernate: add PUD_SECT_RDONLY
> 13373f0e6580 arm64: hibernate: rename dst to page in create_safe_exec_page
> a89d7ff933b0 arm64: hibernate: remove gotos as they are not needed
> 051a7a94aaa9 arm64: hibernate: use get_safe_page directly
> d234332c2815 arm64: hibernate: pass the allocated pgdp to ttbr0
> 621516789ee6 arm64: kexec: make dtb_mem always enabled
> 3b54b743397e arm64: kexec: remove unnecessary debug prints
> de68e4daea90 kexec: add machine_kexec_post_load()
> d42cc530b18d kexec: quiet down kexec reboot
> 
> So, merging another ~12, would substantially help with getting
> everything reviewed and merged.

Ok, great; I'll have a crack at that tomorrow, and thanks for persevering.

Will
Will Deacon Jan. 27, 2021, 3:59 p.m. UTC | #4
On Mon, 25 Jan 2021 14:19:05 -0500, Pavel Tatashin wrote:
> Changelog:
> v10:
> 	- Addressed a lot of comments form James Morse and from  Marc Zyngier
> 	- Added review-by's
> 	- Synchronized with mainline
> 
> [...]

Applied the first 12 patches to arm64 (for-next/kexec), thanks!

[01/18] arm64: kexec: make dtb_mem always enabled
        https://git.kernel.org/arm64/c/117cda9a7847
[02/18] arm64: hibernate: variable pudp is used instead of pd4dp
        https://git.kernel.org/arm64/c/41f67d40a31d
[03/18] arm64: hibernate: move page handling function to new trans_pgd.c
        https://git.kernel.org/arm64/c/072e3d96a79a
[04/18] arm64: trans_pgd: make trans_pgd_map_page generic
        https://git.kernel.org/arm64/c/50f53fb72181
[05/18] arm64: trans_pgd: pass allocator trans_pgd_create_copy
        https://git.kernel.org/arm64/c/89d1410f4af5
[06/18] arm64: trans_pgd: pass NULL instead of init_mm to *_populate functions
        https://git.kernel.org/arm64/c/5de59884ac0e
[07/18] arm64: mm: Always update TCR_EL1 from __cpu_set_tcr_t0sz()
        https://git.kernel.org/arm64/c/1401bef703a4
[08/18] arm64: trans_pgd: hibernate: idmap the single page that holds the copy page routines
        https://git.kernel.org/arm64/c/7018d467ff2d
[09/18] arm64: kexec: move relocation function setup
        https://git.kernel.org/arm64/c/4c3c31230c91
[10/18] arm64: kexec: call kexec_image_info only once
        https://git.kernel.org/arm64/c/77a43be11648
[11/18] arm64: kexec: arm64_relocate_new_kernel clean-ups and optimizations
        https://git.kernel.org/arm64/c/dbd82fee0f25
[12/18] arm64: kexec: arm64_relocate_new_kernel don't use x0 as temp
        https://git.kernel.org/arm64/c/a360190e8a42

Cheers,
Pavel Tatashin Jan. 27, 2021, 4:12 p.m. UTC | #5
On Wed, Jan 27, 2021 at 10:59 AM Will Deacon <will@kernel.org> wrote:
>
> On Mon, 25 Jan 2021 14:19:05 -0500, Pavel Tatashin wrote:
> > Changelog:
> > v10:
> >       - Addressed a lot of comments form James Morse and from  Marc Zyngier
> >       - Added review-by's
> >       - Synchronized with mainline
> >
> > [...]
>
> Applied the first 12 patches to arm64 (for-next/kexec), thanks!

Great, thank you. I will resend the rest of the series based on your gate.

Pasha