Message ID | 20230130145429.903791-1-mark.rutland@arm.com (mailing list archive) |
---|---|
Headers | show |
Series | arm64: pseudo-nmi: elide code when CONFIG_ARM64_PSEUDO_NMI=n | expand |
On Mon, 30 Jan 2023 14:54:24 +0000, Mark Rutland wrote: > This series addresses a couple of sub-optimal code generation issues with > arm64's pseudo-nmi support code: > > * Even when CONFIG_ARM64_PSEUDO_NMI=n, we generate alternative code > sequences and alt_instr entries which will never be used. This series > reworks the irqflags code to use alternative branches (with an > IS_ENABLED() check), which allows the alternatives to be elided when > CONFIG_ARM64_PSEUDO_NMI=n. > > [...] Applied to arm64 (for-next/pseudo-nmi), thanks! [1/5] arm64: rename ARM64_HAS_SYSREG_GIC_CPUIF to ARM64_HAS_GIC_CPUIF_SYSREGS https://git.kernel.org/arm64/c/0e62ccb9598d [2/5] arm64: rename ARM64_HAS_IRQ_PRIO_MASKING to ARM64_HAS_GIC_PRIO_MASKING https://git.kernel.org/arm64/c/c888b7bd916c [3/5] arm64: make ARM64_HAS_GIC_PRIO_MASKING depend on ARM64_HAS_GIC_CPUIF_SYSREGS https://git.kernel.org/arm64/c/4b43f1cd70df [4/5] arm64: add ARM64_HAS_GIC_PRIO_RELAXED_SYNC cpucap https://git.kernel.org/arm64/c/8bf0a8048b15 [5/5] arm64: irqflags: use alternative branches for pseudo-NMI logic https://git.kernel.org/arm64/c/a5f61cc636f4