new file mode 100644
@@ -0,0 +1,68 @@
+/*
+ * dlan-usb-extender.dts - Device Tree file for Devolo dLAN USB Extender
+ *
+ * Copyright (C) 2012, Florian Fainelli <florian@openwrt.org>
+ *
+ * Licensed under GPLv2
+ */
+
+/dts-v1/;
+/include/ "mcs8140.dtsi"
+
+/ {
+ model = "Devolo dLAN USB Extender";
+ compatible = "devolo,dlan-usb-extender", "moschip,mcs8140", "moschip,mcs814x";
+
+ chosen {
+ bootargs = "mem=16M console=ttyS0,57600 earlyprintk";
+ };
+
+ ahb {
+ vci {
+
+ adc {
+ sdram: memory@0,0 {
+ reg = <0 0 0x1000000>;
+ };
+
+ nor: flash@7,0 {
+
+ partition@0 {
+ label = "ArmBoot";
+ reg = <0 0x30000>;
+ };
+ partition@30000 {
+ label = "Config1";
+ reg = <0x30000 0x10000>;
+ };
+ partition@40000 {
+ label = "Config2";
+ reg = <0x40000 0x10000>;
+ };
+ partition@50000 {
+ label = "bZimage";
+ reg = <0x50000 0x100000>;
+ };
+ partition@150000 {
+ label = "UserFS";
+ reg = <0x150000 0x3C0000>;
+ };
+ partition@50001 {
+ label = "Combined";
+ reg = <0x50000 0x4C0000>;
+ };
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ usb {
+ label = "dlan-usb-extender:green:usb";
+ gpios = <&gpio 19 0>; // gpio 19 active high
+ };
+ };
+ };
+ };
+};
+
@@ -6,6 +6,15 @@ config MCS8140
menu "Moschip MCS8140 boards"
+config MACH_DLAN_USB_EXT
+ bool "Devolo dLAN USB Extender"
+ select MCS8140
+ select NEW_LEDS
+ select LEDS_CLASS
+ select LEDS_GPIO
+ help
+ Machine support for the Devolo dLAN USB Extender
+
config MACH_RBT_832
bool "Tigal RBT-832"
select MCS8140
@@ -2,4 +2,5 @@
params_phys-y := 0x00000008
initrd_phys-y := 0x00400000
+dtb-$(CONFIG_MACH_DLAN_USB_EXT) += dlan-usb-extender.dtb
dtb-$(CONFIG_MACH_RBT_832) += rbt-832.dtb
@@ -27,6 +27,7 @@ static void __init mcs814x_dt_device_init(void)
}
static const char *mcs8140_dt_board_compat[] __initdata = {
+ "devolo,dlan-usb-extender",
"tigal,rbt-832",
"moschip,mcs8140",
NULL, /* sentinel */
This patch adds support for Devolo's dLAN USB Extender board: - 16MB of SDRAM available - GPIO for the USB port activity - MTD partition map Signed-off-by: Florian Fainelli <florian@openwrt.org> --- arch/arm/boot/dts/dlan-usb-extender.dts | 68 ++++++++++++++++++++++++++++++ arch/arm/mach-mcs814x/Kconfig | 9 ++++ arch/arm/mach-mcs814x/Makefile.boot | 1 + arch/arm/mach-mcs814x/board-mcs8140-dt.c | 1 + 4 files changed, 79 insertions(+) create mode 100644 arch/arm/boot/dts/dlan-usb-extender.dts