Message ID | 1346923381-14144-3-git-send-email-thomas.abraham@linaro.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Hi Thomas, On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote: > compatible = "samsung,s3c2440-i2c"; > reg = <0x13860000 0x100>; > interrupts = <0 58 0>; > + pinctrl-names = "default"; > + pinctrl-0 = <&i2c0_bus>; If pinctrl-names property is omitted then the state index is used as a name (e.g. pinctrl-0 would be named "0"). Maybe it would be better to use this approach (with respective adjustment in first patch)? What do you think? Best regards,
On 6 September 2012 15:43, Tomasz Figa <t.figa@samsung.com> wrote: > Hi Thomas, > > On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote: >> compatible = "samsung,s3c2440-i2c"; >> reg = <0x13860000 0x100>; >> interrupts = <0 58 0>; >> + pinctrl-names = "default"; >> + pinctrl-0 = <&i2c0_bus>; > > If pinctrl-names property is omitted then the state index is used as a name > (e.g. pinctrl-0 would be named "0"). Maybe it would be better to use this > approach (with respective adjustment in first patch)? What do you think? I tend to prefer to name the states because it is easier to cross-reference code and dts files. i2c was a simple one, but for mmc controllers, there will 1-bit state, 4-bit state and 8-bit state, and it will be nicer to name then accordingly. So I prefer to use names but if there is wider consensus on not using names, we can drop names. Thanks, Thomas. > > Best regards, > -- > Tomasz Figa > Samsung Poland R&D Center >
On 09/06/2012 05:14 AM, Thomas Abraham wrote: > On 6 September 2012 15:43, Tomasz Figa <t.figa@samsung.com> wrote: >> Hi Thomas, >> >> On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote: >>> compatible = "samsung,s3c2440-i2c"; >>> reg = <0x13860000 0x100>; >>> interrupts = <0 58 0>; >>> + pinctrl-names = "default"; >>> + pinctrl-0 = <&i2c0_bus>; >> >> If pinctrl-names property is omitted then the state index is used as a name >> (e.g. pinctrl-0 would be named "0"). Maybe it would be better to use this >> approach (with respective adjustment in first patch)? What do you think? > > I tend to prefer to name the states because it is easier to > cross-reference code and dts files. i2c was a simple one, but for mmc > controllers, there will 1-bit state, 4-bit state and 8-bit state, and > it will be nicer to name then accordingly. So I prefer to use names > but if there is wider consensus on not using names, we can drop names. I would only expect to see multiple states defined in a single board .dts file /if/ runtime muxing is required. Given MMC doesn't runtime mux, I wouldn't expect there to be multiple states for different bus widths; it's just that the "default" state would point at whatever single configuration is appropriate for the board.
diff --git a/arch/arm/boot/dts/exynos4210-smdkv310.dts b/arch/arm/boot/dts/exynos4210-smdkv310.dts index 1beccc8..ea76542 100644 --- a/arch/arm/boot/dts/exynos4210-smdkv310.dts +++ b/arch/arm/boot/dts/exynos4210-smdkv310.dts @@ -126,8 +126,6 @@ #size-cells = <0>; samsung,i2c-sda-delay = <100>; samsung,i2c-max-bus-freq = <20000>; - gpios = <&gpd1 0 2 3 0>, - <&gpd1 1 2 3 0>; eeprom@50 { compatible = "samsung,24ad0xd1"; diff --git a/arch/arm/boot/dts/exynos4210.dtsi b/arch/arm/boot/dts/exynos4210.dtsi index a4bd0c9..e08387f 100644 --- a/arch/arm/boot/dts/exynos4210.dtsi +++ b/arch/arm/boot/dts/exynos4210.dtsi @@ -157,6 +157,8 @@ compatible = "samsung,s3c2440-i2c"; reg = <0x13860000 0x100>; interrupts = <0 58 0>; + pinctrl-names = "default"; + pinctrl-0 = <&i2c0_bus>; }; i2c@13870000 {
Add a default pin state for i2c0 controller which the pinctrl interface can use to setup the i2c0 bus. Signed-off-by: Thomas Abraham <thomas.abraham@linaro.org> --- arch/arm/boot/dts/exynos4210-smdkv310.dts | 2 -- arch/arm/boot/dts/exynos4210.dtsi | 2 ++ 2 files changed, 2 insertions(+), 2 deletions(-)